You are not logged in.

#1 2022-04-30 10:29:40

FrozenArcher
Member
From: Jiaxing, Zhejiang, China.
Registered: 2022-03-31
Posts: 5

[SOLVED]Error when upgrading libinih

I'm upgrading my system with pacman -Syu and libinih seems broken:
```
:: 正在获取软件包......
libinih-55-2-x86_64                            15.4 KiB   159 KiB/s 00:00 [##########################################] 100%
(105/105) 正在检查密钥环里的密钥                                                    [##########################################] 100%
(105/105) 正在检查软件包完整性                                                         [##########################################] 100%
错误:libinih: 来自 "Maxime Gauduin <alucryd@gmail.com>" 的签名是勉强信任的
:: 文件 /var/cache/pacman/pkg/libinih-55-2-x86_64.pkg.tar.zst 已损坏 (无效或已损坏的软件包 (PGP 签名)).
打算删除吗? [Y/n]
```
I tried to enter "Y" and"N" but both of them leads to another error:
```
打算删除吗? [Y/n] y
错误:无法提交处理 (无效或已损坏的软件包)
发生错误,没有软件包被更新。
-> 安装软件库软件包时出错

打算删除吗? [Y/n] n
错误:无法提交处理 (无效或已损坏的软件包)
发生错误,没有软件包被更新。
-> 安装软件库软件包时出错
```
And then pacman returns an error code. My system can't be upgraded(((

I'm sorry the output isn't in English. It says that "/var/cache/pacman/pkg/libinih-55-2-x86_64.pkg.tar.zst  is broken", and PGP signature is broken too.
It asks me whether I want to remove it, but it "can't be committed(?)".  (I don't know how to translate this)

Last edited by FrozenArcher (2022-04-30 13:45:33)

Offline

#2 2022-04-30 10:34:53

Raynman
Member
Registered: 2011-10-22
Posts: 1,417

Re: [SOLVED]Error when upgrading libinih

Offline

#3 2022-04-30 10:36:05

jeancf
Member
Registered: 2011-03-02
Posts: 6

Re: [SOLVED]Error when upgrading libinih

Same problem for me:

'''
:: Retrieving packages...
libinih-55-2-x86_64                                         15.4 KiB   385 KiB/s 00:00 [###################################################] 100%
(35/35) checking keys in keyring                                                        [###################################################] 100%
(35/35) checking package integrity                                                      [###################################################] 100%
error: libinih: signature from "Maxime Gauduin <alucryd@gmail.com>" is marginal trust
:: File /var/cache/pacman/pkg/libinih-55-2-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: failed to commit transaction (invalid or corrupted package)
Errors occurred, no packages were upgraded.
-> error installing repo packages
''''

Offline

#4 2022-04-30 11:12:14

archimboldo
Member
Registered: 2016-03-07
Posts: 232

Re: [SOLVED]Error when upgrading libinih


Rules for problems.
Everyone has problems. Animals have problems. And buildings. And cats, and trees.
Problems are your friends. Treat them well.

Offline

#5 2022-04-30 13:44:56

FrozenArcher
Member
From: Jiaxing, Zhejiang, China.
Registered: 2022-03-31
Posts: 5

Re: [SOLVED]Error when upgrading libinih

yes, upgrading archlinux-keyring works.

pacman -Sy archlinux-keyring

and then pacman -Syu is successful.

Offline

Board footer

Powered by FluxBB