You are not logged in.

#1 2022-05-01 16:34:16

Neven
Member
Registered: 2014-05-02
Posts: 49

[RESOLVED] qemu edk2 optdepends disagreement on archlinux.org

I noticed this a few hours ago:

extra/edk2-ovmf says that it is optdepended on by extra/qemu, but extra/qemu disagrees:

https://archlinux.org/packages/extra/any/edk2-ovmf/

https://archlinux.org/packages/extra/x86_64/qemu/

I guess this could have something to do with the upcoming qemu transition from v6 to v7, but not sure how exactly...

Last edited by Neven (2022-05-01 17:43:57)

Offline

#2 2022-05-01 17:17:15

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 26,877
Website

Re: [RESOLVED] qemu edk2 optdepends disagreement on archlinux.org

Those packages were updated at different times and thus the website metadata was also regenerated at diffefent times.  When edk2-ovmf was last updated qemu did list it as an optdepends:
https://github.com/archlinux/svntogit-p … 4/PKGBUILD


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Online

#3 2022-05-01 17:42:59

Neven
Member
Registered: 2014-05-02
Posts: 49

Re: [RESOLVED] qemu edk2 optdepends disagreement on archlinux.org

Trilby wrote:

Those packages were updated at different times and thus the website metadata was also regenerated at diffefent times.  When edk2-ovmf was last updated qemu did list it as an optdepends:
https://github.com/archlinux/svntogit-p … 4/PKGBUILD

Thank you, didn't know the package page dep listings on archlinux.org worked that way.

Offline

Board footer

Powered by FluxBB