You are not logged in.

#1 2022-01-23 09:31:21

jose1711
Member
Registered: 2006-07-08
Posts: 142

Blank screen after updating to 5.16.2.arch1-1 (AMD Radeon VEGA)

Hello,

I upgraded to linux 5.16.2.arch1-1 from 5.15.13.arch1-1 and after reboot and passing GRUB screen the screen turned just blank. I was still able to reboot it using keyboard, but even single user mode did not work. I was able to get the prompt by appending

nomodeset single

but then Xorg reported it could not find screen. I was not able to find anything relevant on Arch Wiki.

GPU is AMD Radeon Vega, full HW specs https://support.hp.com/hr-en/document/c06955645

Anyone was dealing with a similar issue?

Thanks, jose

Edit: Used "single", not "init=/bin/bash"

Last edited by jose1711 (2022-03-05 10:38:18)

Offline

#2 2022-01-23 12:13:18

Head_on_a_Stick
Member
From: London
Registered: 2014-02-20
Posts: 6,350

Re: Blank screen after updating to 5.16.2.arch1-1 (AMD Radeon VEGA)

jose1711 wrote:

Anyone was dealing with a similar issue?

Have you seen https://bbs.archlinux.org/viewtopic.php?id=273100? "AMD Radeon Vega" is too vague to determine if your card is of the Tahiti type.

jose1711 wrote:

but then Xorg reported it could not find screen

Applying the nomodeset parameter disables KMS, which is required for AMD cards, so that is expected.

Offline

#3 2022-01-23 21:47:18

jose1711
Member
Registered: 2006-07-08
Posts: 142

Re: Blank screen after updating to 5.16.2.arch1-1 (AMD Radeon VEGA)

Head_on_a_Stick wrote:
jose1711 wrote:

Anyone was dealing with a similar issue?

Have you seen https://bbs.archlinux.org/viewtopic.php?id=273100? "AMD Radeon Vega" is too vague to determine if your card is of the Tahiti type.

Sorry, missed that. Mine is this:

0a:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Renoir [1002:1636] (rev dc)

Anyway, it's probably better to wait for a new kernel version hoping for a fix. Thanks.

Offline

#4 2022-01-23 21:54:36

loqs
Member
Registered: 2014-03-06
Posts: 14,701

Re: Blank screen after updating to 5.16.2.arch1-1 (AMD Radeon VEGA)

Was anything recorded in the system journal from a 5.16 boot?

Offline

#5 2022-03-11 08:03:26

jose1711
Member
Registered: 2006-07-08
Posts: 142

Re: Blank screen after updating to 5.16.2.arch1-1 (AMD Radeon VEGA)

loqs wrote:

Was anything recorded in the system journal from a 5.16 boot?

Yes, it actually looks like a regular boot, even the system is accessible remotely.

Reached target GNOME X11 Session.

The screen is still blank and at this moment running the older kernel is the only workaround I am aware of.

Offline

#6 2022-03-12 13:27:52

loqs
Member
Registered: 2014-03-06
Posts: 14,701

Re: Blank screen after updating to 5.16.2.arch1-1 (AMD Radeon VEGA)

Please post the journal from a 5.16 boot and the journal from a 5.15 boot.

Offline

#7 2022-03-30 22:54:41

jose1711
Member
Registered: 2006-07-08
Posts: 142

Re: Blank screen after updating to 5.16.2.arch1-1 (AMD Radeon VEGA)

loqs wrote:

Please post the journal from a 5.16 boot and the journal from a 5.15 boot.

I am looking for a way how to anonymize the logs in a reasonable way. Or perhaps make a bootable flash drive. But since I have no physical access to the PC currently it's going to take time.

Offline

#8 2022-05-08 20:33:21

jose1711
Member
Registered: 2006-07-08
Posts: 142

Re: Blank screen after updating to 5.16.2.arch1-1 (AMD Radeon VEGA)

I tested with a bootable Fedora 36 (beta) live USB and it's the same behaviour: I see grub textual menu, then Grub image (loading Fedora) and suddenly the video signal is gone. So not an Arch-specific issue.

Offline

Board footer

Powered by FluxBB