You are not logged in.

#1 2022-05-03 07:29:45

Salkay
Member
Registered: 2014-05-22
Posts: 570

[SOLVED] Make bluetooth headphones default to SBC-XQ codec

I'm using my bluetooth headphones with pipewire and pipewire-pulse. After connecting, I can use pavucontrol to switch from the default AAC codec to the SBC-XQ codec. However, I have to manually switch this every time I connect. Is there a way to use this codec by default?

Last edited by Salkay (2022-05-19 03:25:36)

Offline

#2 2022-05-03 08:02:44

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 16,239

Re: [SOLVED] Make bluetooth headphones default to SBC-XQ codec

https://wiki.archlinux.org/title/PipeWi … _Bluetooth

should allow you to select the primary codec to use

Last edited by V1del (2022-05-03 08:04:11)

Offline

#3 2022-05-06 06:38:56

Salkay
Member
Registered: 2014-05-22
Posts: 570

Re: [SOLVED] Make bluetooth headphones default to SBC-XQ codec

Thanks V1del. I'm using pipewire-media-session, so I created ~/.config/pipewire/media-session.d/bluez-monitor.conf using the template at /usr/share/pipewire/media-session.d/bluez-monitor.conf, and added

properties = {
    ...
    bluez5.codecs = [ sbc_xq ]

This now works by removing the other codecs. I guess that's fine, although I can't access the other codecs any more now.

From your comment

V1del wrote:

should allow you to select the primary codec to use

I'm not sure if you were suggesting there was a way to leave all codecs enabled, and just default to one?

Offline

#4 2022-05-06 07:58:36

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 16,239

Re: [SOLVED] Make bluetooth headphones default to SBC-XQ codec

Not using bluetooth so not sure whether you can just list them and it will default to the first or whether you can set an additional flag for explicitly selecting the default profile/codec

Offline

#5 2022-05-11 05:00:23

Salkay
Member
Registered: 2014-05-22
Posts: 570

Re: [SOLVED] Make bluetooth headphones default to SBC-XQ codec

It looks like pipewire-media-session has been removed from the repos, and I was automatically migrated to wireplumber.

I created a new config as per the link above at ~/.config/wireplumber/bluetooth.lua.d/51-bluez-config.lua. Again, I disabled all the other codecs and left sbc_xq. I restarted pipewire and this had the same effect as before with pipewire-media-session. Similarly with wireplumber, I can't see a way to leave all enabled and just specify a default. I checked the docs and there was nothing obvious there either.

Offline

#6 2022-05-19 03:25:17

Salkay
Member
Registered: 2014-05-22
Posts: 570

Re: [SOLVED] Make bluetooth headphones default to SBC-XQ codec

For the record, after the issues reported with wireplumber, I reverted to pipewire-media-session. I tested putting multiple codecs into ~/.config/pipewire/media-session.d/bluez-monitor.conf, as per above, but the order of these was not used to determine the default. I'm just specifying the one sbc_xq codec for now. Not entirely ideal, but this works well enough. Thank you for your help!

Offline

Board footer

Powered by FluxBB