You are not logged in.

#1 2022-05-10 01:58:06

IanMoVill
Member
Registered: 2022-05-10
Posts: 2

Nvidia card not detected

I've already searched it and I can't find an answer. Yesterday I noticed Blender was going really bad, I checked the GPU and it says is using the Intel one. Is not even detected by the system, but my BIOS detects it. I tried forcing Xorg for using Nvidia (with Nvidia and Nouveau), but mesa is being used by Intel. Can anyone help me? hmm

$ glxinfo -B
name of display: :0
display: :0  screen: 0
direct rendering: Yes
Extended renderer info (GLX_MESA_query_renderer):
    Vendor: Intel (0x8086)
    Device: Mesa Intel(R) HD Graphics 630 (KBL GT2) (0x591b)
    Version: 22.0.3
    Accelerated: yes
    Video memory: 3072MB
    Unified memory: yes
    Preferred profile: core (0x1)
    Max core profile version: 4.6
    Max compat profile version: 4.6
    Max GLES1 profile version: 1.1
    Max GLES[23] profile version: 3.2
OpenGL vendor string: Intel
OpenGL renderer string: Mesa Intel(R) HD Graphics 630 (KBL GT2)
OpenGL core profile version string: 4.6 (Core Profile) Mesa 22.0.3
OpenGL core profile shading language version string: 4.60
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile

OpenGL version string: 4.6 (Compatibility Profile) Mesa 22.0.3
OpenGL shading language version string: 4.60
OpenGL context flags: (none)
OpenGL profile mask: compatibility profile

OpenGL ES profile version string: OpenGL ES 3.2 Mesa 22.0.3
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20

Last edited by IanMoVill (2022-05-10 02:07:27)

Offline

#2 2022-05-10 05:56:58

seth
Member
Registered: 2012-09-03
Posts: 29,026

Re: Nvidia card not detected

Is not even detected by the system, but my BIOS detects it.

lspci -k

I tried forcing Xorg for using Nvidia (with Nvidia and Nouveau)

How exactly?
Please post your xorg log and also make sure to visit https://wiki.archlinux.org/title/NVIDIA_Optimus

but mesa is being used by Intel.

That's like saying that the road is being used by a car.
The intel and nouveau drivers use mesa, the nvidia blob doesn't. And mesa is simply a dependency, it doesn't get consumed or so.

Offline

#3 2022-05-11 01:26:54

IanMoVill
Member
Registered: 2022-05-10
Posts: 2

Re: Nvidia card not detected

$ lspci -k
00:00.0 Host bridge: Intel Corporation Xeon E3-1200 v6/7th Gen Core Processor Host Bridge/DRAM Registers (rev 05)
	Subsystem: ASUSTeK Computer Inc. Device 15e0
	Kernel driver in use: skl_uncore
00:01.0 PCI bridge: Intel Corporation 6th-10th Gen Core Processor PCIe Controller (x16) (rev 05)
	Subsystem: ASUSTeK Computer Inc. Device 15e0
	Kernel driver in use: pcieport
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 630 (rev 04)
	DeviceName:  Onboard IGD
	Subsystem: ASUSTeK Computer Inc. Device 15e0
	Kernel driver in use: i915
	Kernel modules: i915
00:08.0 System peripheral: Intel Corporation Xeon E3-1200 v5/v6 / E3-1500 v5 / 6th/7th/8th Gen Core Processor Gaussian Mixture Model
	Subsystem: ASUSTeK Computer Inc. Device 15e0
00:14.0 USB controller: Intel Corporation 100 Series/C230 Series Chipset Family USB 3.0 xHCI Controller (rev 31)
	Subsystem: ASUSTeK Computer Inc. Device 201f
	Kernel driver in use: xhci_hcd
	Kernel modules: xhci_pci
00:14.2 Signal processing controller: Intel Corporation 100 Series/C230 Series Chipset Family Thermal Subsystem (rev 31)
	Subsystem: ASUSTeK Computer Inc. Device 15e0
	Kernel driver in use: intel_pch_thermal
	Kernel modules: intel_pch_thermal
00:15.0 Signal processing controller: Intel Corporation 100 Series/C230 Series Chipset Family Serial IO I2C Controller #0 (rev 31)
	Subsystem: ASUSTeK Computer Inc. Device 15e0
	Kernel driver in use: intel-lpss
	Kernel modules: intel_lpss_pci
00:16.0 Communication controller: Intel Corporation 100 Series/C230 Series Chipset Family MEI Controller #1 (rev 31)
	Subsystem: ASUSTeK Computer Inc. Device 15e0
	Kernel driver in use: mei_me
	Kernel modules: mei_me
00:17.0 SATA controller: Intel Corporation HM170/QM170 Chipset SATA Controller [AHCI Mode] (rev 31)
	Subsystem: ASUSTeK Computer Inc. Device 15e0
	Kernel driver in use: ahci
00:1c.0 PCI bridge: Intel Corporation 100 Series/C230 Series Chipset Family PCI Express Root Port #3 (rev f1)
	Subsystem: ASUSTeK Computer Inc. Device 15e0
	Kernel driver in use: pcieport
00:1c.3 PCI bridge: Intel Corporation 100 Series/C230 Series Chipset Family PCI Express Root Port #4 (rev f1)
	Subsystem: ASUSTeK Computer Inc. Device 15e0
	Kernel driver in use: pcieport
00:1c.6 PCI bridge: Intel Corporation 100 Series/C230 Series Chipset Family PCI Express Root Port #7 (rev f1)
	Subsystem: ASUSTeK Computer Inc. Device 15e0
	Kernel driver in use: pcieport
00:1d.0 PCI bridge: Intel Corporation 100 Series/C230 Series Chipset Family PCI Express Root Port #9 (rev f1)
	Subsystem: ASUSTeK Computer Inc. Device 15e0
	Kernel driver in use: pcieport
00:1f.0 ISA bridge: Intel Corporation HM175 Chipset LPC/eSPI Controller (rev 31)
	Subsystem: ASUSTeK Computer Inc. Device 15e0
00:1f.2 Memory controller: Intel Corporation 100 Series/C230 Series Chipset Family Power Management Controller (rev 31)
	Subsystem: ASUSTeK Computer Inc. Device 15e0
00:1f.3 Audio device: Intel Corporation CM238 HD Audio Controller (rev 31)
	Subsystem: ASUSTeK Computer Inc. Device 15e0
	Kernel driver in use: snd_hda_intel
	Kernel modules: snd_hda_intel
00:1f.4 SMBus: Intel Corporation 100 Series/C230 Series Chipset Family SMBus (rev 31)
	Subsystem: ASUSTeK Computer Inc. Device 15e0
	Kernel driver in use: i801_smbus
	Kernel modules: i2c_i801
01:00.0 3D controller: NVIDIA Corporation GP107M [GeForce GTX 1050 Mobile] (rev a1)
	Subsystem: ASUSTeK Computer Inc. Device 15e0
	Kernel driver in use: nouveau
	Kernel modules: nouveau
02:00.0 Network controller: Intel Corporation Wireless 7265 (rev 59)
	Subsystem: Intel Corporation Dual Band Wireless-AC 7265
	Kernel driver in use: iwlwifi
	Kernel modules: iwlwifi
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15)
	Subsystem: ASUSTeK Computer Inc. Device 200f
	Kernel driver in use: r8169
	Kernel modules: r8169
04:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5229 PCI Express Card Reader (rev 01)
	Subsystem: ASUSTeK Computer Inc. Device 202f
	Kernel driver in use: rtsx_pci
	Kernel modules: rtsx_pci
05:00.0 Non-Volatile memory controller: Sandisk Corp WD Black NVMe SSD
	Subsystem: Marvell Technology Group Ltd. Device 1093
	Kernel driver in use: nvme

Now I see it detects Nvidia, but my problem is, why is it not using it?
I tried 20-nouveau.conf with:

Section "Device"
    Identifier "Nvidia card"
   Driver "nouveau"
EndSection

Thanks for your help


Edit: I think the best solution for me is in here https://wiki.archlinux.org/title/PRIME#Installation

Last edited by IanMoVill (2022-05-11 01:31:53)

Offline

#4 2022-05-11 05:37:44

seth
Member
Registered: 2012-09-03
Posts: 29,026

Re: Nvidia card not detected

01:00.0 3D controller: NVIDIA Corporation GP107M [GeForce GTX 1050 Mobile] (rev a1)

I think the best solution for me is [prime]

It's the only solution. You can default to the nvidia chip, but will have to redirect it through the intel chip no matter what since the nvidia chip has no crtc. It can only render frames and pass them on. Not act as a VGA device.
You BIOS might have options to deactivate the IGP and only use the nvidia chip which then becomes a VGA device - but it also might not.

Offline

Board footer

Powered by FluxBB