You are not logged in.

#1 2022-05-13 16:52:26

rootpeer
Member
Registered: 2019-04-07
Posts: 31

nut-driver.service missing in 2.8.0-1

Hello, I upgraded nut from 2.7.4-3 to 2.8.0-1 and the nut-driver.service file disappeared.

That leads to the nut driver not starting at boot and me having to manually issue

upsdrvctl start

every time to get nut working.

Has anyone else had this problem?

Offline

#2 2022-05-13 17:43:15

ayekat
Member
Registered: 2011-01-17
Posts: 1,509
Website

Re: nut-driver.service missing in 2.8.0-1

Not using nut myself, but looking at the services provided by the package, you now probably have to start the service for your chosen device (e.g. `nut-driver@myups.service`).


{,META,RE}PKGBUILDSpacman-hacks (includes makemetapkg and remakepkg) │ dotfiles

Offline

#3 2022-05-13 18:47:52

rootpeer
Member
Registered: 2019-04-07
Posts: 31

Re: nut-driver.service missing in 2.8.0-1

ayekat wrote:

Not using nut myself, but looking at the services provided by the package, you now probably have to start the service for your chosen device (e.g. `nut-driver@myups.service`).

Thanks for your reply! the nut-driver@myups.service was there before, mainly for UPSs that exhibited issues. Enabling that service for my UPS fixes the problem.

If such a change has occured, I guess the documentation needs updating: https://wiki.archlinux.org/title/Networ … figuration

Offline

#4 2022-05-13 19:03:15

ayekat
Member
Registered: 2011-01-17
Posts: 1,509
Website

Re: nut-driver.service missing in 2.8.0-1

Glad that was it.

That section there tells you about nut-server.service, though. If you look at the revision history, the nut-driver service rename was handled 11 days ago.


{,META,RE}PKGBUILDSpacman-hacks (includes makemetapkg and remakepkg) │ dotfiles

Offline

#5 2022-05-17 22:39:29

heidegger
Member
Registered: 2013-04-24
Posts: 58

Re: nut-driver.service missing in 2.8.0-1

I am having a similar issue with the update now requiring the driver to be manually loaded with upsdrvctl upon every reboot.
The wiki for nut indicates that nut-server.service should load the driver automatically (within the upsd configuration section), and so I have never manually started or enabled the nut-driver.service or nut-driver@myups.service.
If we need to enable/start the driver, perhaps the wiki page should be updated to reflect this.
Otherwise, nut-server.service may need to be updated to start the driver automatically using the new nut-driver@myups.service convention.

Offline

Board footer

Powered by FluxBB