You are not logged in.

#1 2022-05-14 05:40:01

askreceive
Member
Registered: 2022-03-01
Posts: 48

[Solved]Fonts have broken rendering on native Wayland applications

Applications such as LibreWolf, Firefox, and Libreoffice have blurry fonts when run under native Wayland. I used all versions of the aforementioned applications (i.e Aur, Flatpak, and Native), and they had the same issue even with the prerequisites installed. I tried using Gnome, installing xdg-desktop-portal-gtk/gnome, and other workarounds, but the issue persisted. XWayland worked fine, but I want to try Wayland since it's working with my GPU now thanks to the recent driver update.

For what it's worth, the desktop (or plasma-wayland) itself is working fine without any issues, and I'm currently using EGL backend, but the issue remained with GBM.

Last edited by askreceive (2022-05-14 15:14:17)

Offline

#2 2022-05-14 06:11:33

seth
Member
Registered: 2012-09-03
Posts: 28,889

Re: [Solved]Fonts have broken rendering on native Wayland applications

Fonts do not have anti-aliasing

have blurry fonts when run under native Wayland

This is contradictive (aliased fonts will show pixelated edges), please link a screenshot to illustrate the actual situation.


Causes for over-blurryness could be a scaled output (HiDPI situation) and, since you mentioned EGLstreams, also MSAA/FXAA being enabled "somehow"
For the latter case, try to export __GL_ALLOW_FXAA_USAGE=0 to the client.

Offline

#3 2022-05-14 08:31:34

askreceive
Member
Registered: 2022-03-01
Posts: 48

Re: [Solved]Fonts have broken rendering on native Wayland applications

Example:
https://imgur.com/2nupItx.png

Another issue is it uses Adwaita's cursor instead of Breeze, which is the one I'm using.

Last edited by askreceive (2022-05-14 08:33:28)

Offline

#4 2022-05-14 12:04:12

seth
Member
Registered: 2012-09-03
Posts: 28,889

Re: [Solved]Fonts have broken rendering on native Wayland applications

That's consistent w/ what you'd get for flatschpak.
https://bugzilla.mozilla.org/show_bug.cgi?id=1649978
https://www.reddit.com/r/archlinux/comm … eaks_when/

And might relate to bitmap scaling, https://bbs.archlinux.org/viewtopic.php … 8#p1898198
(This solution is likely not gonna work w/ flatpak)

https://www.reddit.com/r/wayland/commen … gly_fonts/ enabled global autohinting or lcd filter, possibly not picked up from the user specific settings?

Offline

#5 2022-05-14 15:13:37

askreceive
Member
Registered: 2022-03-01
Posts: 48

Re: [Solved]Fonts have broken rendering on native Wayland applications

https://www.reddit.com/r/wayland/commen … gly_fonts/ enabled global autohinting or lcd filter, possibly not picked up from the user specific settings?

This worked, thanks!

Offline

Board footer

Powered by FluxBB