You are not logged in.

#1 2022-05-13 14:23:35

zpg443
Member
Registered: 2016-12-03
Posts: 244

[SOLVED] Clarification needed: pipewire news item 5/12/2022

Regarding news item https://archlinux.org/news/undone-repla … replumber/

Doing this action creates a conflicting dependency:

$ sudo pacman -Syu pipewire-media-session
:: Synchronizing package databases...
 core                                     155.3 KiB   255 KiB/s 00:01 [######################################] 100%
 extra                                   1720.4 KiB  7.00 MiB/s 00:00 [######################################] 100%
 community                                  6.6 MiB  16.5 MiB/s 00:00 [######################################] 100%
 seblu is up to date
 repo is up to date
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: pipewire-media-session and wireplumber are in conflict

$ sudo pacman -R wireplumber
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: removing wireplumber breaks dependency 'pipewire-session-manager' required by kwin
:: removing wireplumber breaks dependency 'pipewire-session-manager' required by pipewire-alsa
:: removing wireplumber breaks dependency 'pipewire-session-manager' required by pipewire-pulse

$ sudo pacman -R kwin pipewire-alsa pipewire-pulse
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: removing kwin breaks dependency 'kwin' required by plasma-workspace
:: removing pipewire-pulse breaks dependency 'pulseaudio' required by paprefs
:: removing pipewire-pulse breaks dependency 'pulseaudio' required by plasma-pa
:: removing pipewire-pulse breaks dependency 'pulseaudio' required by pulseaudio-ctl

Is it safe to use --override for this, or do I need to uninstall kwin, pipewire-alsa, and pipewire-pulse? I prefer not to uninstall plasma-workspace.

Last edited by zpg443 (2022-05-13 23:17:15)

Offline

#2 2022-05-13 14:42:27

Scimmia
Fellow
Registered: 2012-09-01
Posts: 9,209

Re: [SOLVED] Clarification needed: pipewire news item 5/12/2022

If you actually want to go back to pipewire-media-session, just install that. Everything should work.

If you're on pipewire-pulse, though, there's no reason not to keep wireplumber. Why are you trying to replace it? The news item says "If you are currently not using PipeWire for audio", but yo uare.

Offline

#3 2022-05-13 23:07:58

zpg443
Member
Registered: 2016-12-03
Posts: 244

Re: [SOLVED] Clarification needed: pipewire news item 5/12/2022

Scimmia wrote:

If you actually want to go back to pipewire-media-session, just install that. Everything should work.

The point of the post is that one cannot "just install that" because it causes a conflicting dependency. The above code shows what happens when following the instruction of how to to "go back to pipewire-media-session."

The reversion to pipewire-media-session worked after today's system upgrade, which updated with wireplumber-0.4.10-3-x86_64. Marking as solved.

Last edited by zpg443 (2022-05-13 23:16:55)

Offline

#4 2022-05-14 05:05:32

seth
Member
Registered: 2012-09-03
Posts: 28,841

Re: [SOLVED] Clarification needed: pipewire news item 5/12/2022

Generally you could try to segment it, "pacman -Syu; pacman -S pipewire-media-session" (what has ultimately happened, I guess) because otherwise you want to update wireplumber at the same time you need to replace it.
Alternatively "pacman -Rdd wireplubmer; -S --asdeps pipewire-media-session"

Sounds like a pacman bug still - even "pacman -S wireplumber pipewire-media-session" should™ ask you to resolve the conflict by picking one, not just fail to resolve the conflict.
Is "type pacman" pacman or some "--noconfirm" alias or do you indeed use some wrapper or something else?

Offline

#5 2022-05-14 12:03:19

zpg443
Member
Registered: 2016-12-03
Posts: 244

Re: [SOLVED] Clarification needed: pipewire news item 5/12/2022

seth wrote:

Generally you could try to segment it, "pacman -Syu; pacman -S pipewire-media-session" (what has ultimately happened, I guess) because otherwise you want to update wireplumber at the same time you need to replace it.

This is what I did, and I am guessing the last update to wireplumber fixed whatever was stopping the prompt to "resolve the conflict by picking one" when installing pipewire-media-session. It is not clear why it did not prompt before, so I (wrongly?) presumed it was the referenced new version of wireplumber installed during system update, prior to trying again to install pipewire-media-session.

Last edited by zpg443 (2022-05-14 12:04:16)

Offline

#6 2022-05-14 12:15:45

seth
Member
Registered: 2012-09-03
Posts: 28,841

Re: [SOLVED] Clarification needed: pipewire news item 5/12/2022

I presumed it was the referenced new version of wireplumber installed during system update, prior to trying again to install pipewire-media-session

That'd be my guess - the update added wireplumber, you explcitly added pipewire-media-session and pacman figured "stupid user tries to install conflicting packages, I'm not even gonna ask here"
*shrug*

Offline

Board footer

Powered by FluxBB