You are not logged in.

#1 2022-05-15 05:37:55

Registered: 2022-05-15
Posts: 1

[SOLVED] Error when setting up shim for Secure Boot

Hi, I just installed Arch a few days ago and I'm very happy with what it can offer so far however I do have one issue. I've been reading the Arch Wiki article for setting up Secure Boot over and over again and I just don't know where I'm doing it wrong. I installed shim-signed from the AUR and followed the guide I just mentioned step by step. I decided to go with the shim with hash method as I didn't want to be hassled with setting up keys and whatnot. Everything was going smoothly and I did manage to add shim to efibootmgr. I encountered the problem when I rebooted my machine after setting shim up. I was greeted with this error message:

Verification failed: (0x1A) Security Violation

Pressing enter brings up MokManager and things seem to be normal - I can even enroll hashes from disk but even if I do all that, nothing seems to take effect as even if I reboot I get thrown back into the same screen. I followed the article with my bootloader being GRUB. I also tried setting my Secure Boot settings from Standard to Custom, back and forth with both options not working. As a last resort, I also tried PreLoader but that didn't work at all with PreLoader just booting me straight into GRUB rescue. I'm now back to the shim method trying to solve this problem. I'd appreciate any help, thank you!

EDIT: I just replaced GRUB with systemd-boot and Secure Boot with PreLoader works right off the bat now.

Last edited by festivity (2022-05-16 14:55:58)


Board footer

Powered by FluxBB