You are not logged in.

#1 2022-05-24 20:12:19

Slixe
Member
Registered: 2022-05-24
Posts: 2

DELL G15 5525 - Microphone not working

Hello, I'm new on Archlinux and I searched all my afternoon to find a solution for my microphone problem.
Nothing working yet, but it's fully working on Windows 11.

~  inxi -Fxz
System:
  Kernel: 5.17.8-arch1-1 arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    Desktop: GNOME v: 42.1 Distro: Arch Linux
Machine:
  Type: Laptop System: Dell product: Dell G15 5525 v: 1.2.1
    serial: <superuser required>
  Mobo: Dell model: 081W41 v: A00 serial: <superuser required> UEFI: Dell
    v: 1.2.1 date: 04/06/2022
Battery:
  ID-1: BAT1 charge: 65.6 Wh (76.3%) condition: 86.0/86.0 Wh (100.0%)
    volts: 12.8 min: 11.4 model: BYD DELL M59JH23 status: charging
CPU:
  Info: 8-core model: AMD Ryzen 7 6800H with Radeon Graphics bits: 64
    type: MT MCP arch: Zen 3 rev: 1 cache: L1: 512 KiB L2: 4 MiB L3: 16 MiB
  Speed (MHz): avg: 1448 high: 1750 min/max: 1600/3200 boost: enabled
    cores: 1: 1409 2: 1519 3: 1390 4: 1389 5: 1384 6: 1722 7: 1479 8: 1504
    9: 1354 10: 1386 11: 1371 12: 1331 13: 1750 14: 1380 15: 1383 16: 1418
    bogomips: 102243
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Graphics:
  Device-1: NVIDIA GA106M [GeForce RTX 3060 Mobile / Max-Q] vendor: Dell
    driver: nouveau v: kernel arch: Ampere bus-ID: 01:00.0
  Device-2: AMD Rembrandt [Radeon 680M] vendor: Dell driver: amdgpu
    v: kernel bus-ID: 05:00.0
  Device-3: Sonix Integrated_Webcam_HD type: USB driver: uvcvideo
    bus-ID: 1-4:3
  Display: wayland server: X.Org v: 22.1.1 with: Xwayland v: 22.1.1
    compositor: gnome-shell driver: X: loaded: modesetting unloaded: vesa
    gpu: amdgpu resolution: 1920x1080~120Hz
  Message: Wayland GBM/EGL data currently not available.
Audio:
  Device-1: NVIDIA vendor: Dell driver: snd_hda_intel v: kernel
    bus-ID: 01:00.1
  Device-2: AMD Rembrandt Radeon High Definition Audio
    driver: snd_hda_intel v: kernel bus-ID: 05:00.1
  Device-3: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Dell
    driver: snd_pci_acp6x v: kernel bus-ID: 05:00.5
  Device-4: AMD Family 17h/19h HD Audio vendor: Dell driver: snd_hda_intel
    v: kernel bus-ID: 05:00.6
  Sound Server-1: ALSA v: k5.17.8-arch1-1 running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.51 running: yes
Network:
  Device-1: Realtek RTL8125 2.5GbE vendor: Dell driver: r8169 v: kernel
    port: 2000 bus-ID: 03:00.0
  IF: enp3s0 state: down mac: <filter>
  Device-2: MEDIATEK MT7921 802.11ax PCI Express Wireless Network Adapter
    vendor: Foxconn driver: mt7921e v: kernel bus-ID: 04:00.0
  IF: wlan0 state: up mac: <filter>
Bluetooth:
  Device-1: MediaTek Wireless_Device type: USB driver: btusb v: 0.8
    bus-ID: 1-3:2
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
Drives:
  Local Storage: total: 953.87 GiB used: 21.52 GiB (2.3%)
  ID-1: /dev/nvme0n1 vendor: Micron model: 2450 NVMe 1024GB
    size: 953.87 GiB temp: 36.9 C
Partition:
  ID-1: / size: 195.5 GiB used: 21.46 GiB (11.0%) fs: ext4 dev: /dev/dm-0
    mapped: root
  ID-2: /boot size: 458.3 MiB used: 60.6 MiB (13.2%) fs: ext4
    dev: /dev/nvme0n1p7
Swap:
  Alert: No swap data was found.
Sensors:
  System Temperatures: cpu: 43.0 C mobo: N/A gpu: amdgpu temp: 46.0 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 404 Uptime: 9m Memory: 14.93 GiB used: 3.13 GiB (21.0%)
  Init: systemd Compilers: gcc: 12.1.0 Packages: 871 Shell: fish v: 3.4.1
  inxi: 3.3.16

~  arecord -l
**** Liste des périphériques matériels CAPTURE ****
carte 2 : Generic_1 [HD-Audio Generic], périphérique 0 : ALC3204 Analog [ALC3204 Analog]
  Sous-périphériques : 0/1
  Sous-périphérique #0 : subdevice #0
carte 2 : Generic_1 [HD-Audio Generic], périphérique 2 : ALC3204 Alt Analog [ALC3204 Alt Analog]
  Sous-périphériques : 0/1
  Sous-périphérique #0 : subdevice #0


Everything is at max volume in alsamixer, and nothing looks mute in PulseAudio GUI.

Thank you in advance.

Offline

#2 2022-05-25 07:39:58

Slixe
Member
Registered: 2022-05-24
Posts: 2

Re: DELL G15 5525 - Microphone not working

Sound / speaker is working, only the microphone (this laptop have a double microphone) is not working.

And compared to others threads that may have the same problem, they have HD-Audio Intel instead of HD-Audio Generic, does that mean the intel driver is not present / used ?

Thanks.

EDIT:

~  pacmd list-cards
3 card(s) available.
    index: 0
    name: <alsa_card.pci-0000_01_00.1>
    driver: <module-alsa-card.c>
    owner module: 6
    properties:
        alsa.card = "0"
        alsa.card_name = "HDA NVidia"
        alsa.long_card_name = "HDA NVidia at 0x81000000 irq 68"
        alsa.driver_name = "snd_hda_intel"
        device.bus_path = "pci-0000:01:00.1"
        sysfs.path = "/devices/pci0000:00/0000:00:01.1/0000:01:00.1/sound/card0"
        device.bus = "pci"
        device.vendor.id = "10de"
        device.vendor.name = "NVIDIA Corporation"
        device.product.id = "228e"
        device.string = "0"
        device.description = "HDA NVidia"
        module-udev-detect.discovered = "1"
        device.icon_name = "audio-card-pci"
    profiles:
        output:hdmi-stereo: Sortie Digital Stereo (HDMI) (priority 5900, available: no)
        output:hdmi-surround: Sortie Digital Surround 5.1 (HDMI) (priority 800, available: no)
        output:hdmi-surround71: Sortie Digital Surround 7.1 (HDMI) (priority 800, available: no)
        output:hdmi-stereo-extra1: Sortie Digital Stereo (HDMI 2) (priority 5700, available: no)
        output:hdmi-surround-extra1: Sortie Digital Surround 5.1 (HDMI 2) (priority 600, available: no)
        output:hdmi-surround71-extra1: Sortie Digital Surround 7.1 (HDMI 2) (priority 600, available: no)
        output:hdmi-stereo-extra2: Sortie Digital Stereo (HDMI 3) (priority 5700, available: no)
        output:hdmi-surround-extra2: Sortie Digital Surround 5.1 (HDMI 3) (priority 600, available: no)
        output:hdmi-surround71-extra2: Sortie Digital Surround 7.1 (HDMI 3) (priority 600, available: no)
        output:hdmi-stereo-extra3: Sortie Digital Stereo (HDMI 4) (priority 5700, available: no)
        output:hdmi-surround-extra3: Sortie Digital Surround 5.1 (HDMI 4) (priority 600, available: no)
        output:hdmi-surround71-extra3: Sortie Digital Surround 7.1 (HDMI 4) (priority 600, available: no)
        off: Éteint (priority 0, available: unknown)
    active profile: <off>
    ports:
        hdmi-output-0: HDMI / DisplayPort (priority 5900, latency offset 0 usec, available: no)
            properties:
                device.icon_name = "video-display"
        hdmi-output-1: HDMI / DisplayPort 2 (priority 5800, latency offset 0 usec, available: no)
            properties:
                device.icon_name = "video-display"
        hdmi-output-2: HDMI / DisplayPort 3 (priority 5700, latency offset 0 usec, available: no)
            properties:
                device.icon_name = "video-display"
        hdmi-output-3: HDMI / DisplayPort 4 (priority 5600, latency offset 0 usec, available: no)
            properties:
                device.icon_name = "video-display"
    index: 1
    name: <alsa_card.pci-0000_05_00.1>
    driver: <module-alsa-card.c>
    owner module: 7
    properties:
        alsa.card = "1"
        alsa.card_name = "HD-Audio Generic"
        alsa.long_card_name = "HD-Audio Generic at 0x817c8000 irq 98"
        alsa.driver_name = "snd_hda_intel"
        device.bus_path = "pci-0000:05:00.1"
        sysfs.path = "/devices/pci0000:00/0000:00:08.1/0000:05:00.1/sound/card1"
        device.bus = "pci"
        device.vendor.id = "1002"
        device.vendor.name = "Advanced Micro Devices, Inc. [AMD/ATI]"
        device.product.id = "1640"
        device.product.name = "Rembrandt Radeon High Definition Audio Controller"
        device.string = "1"
        device.description = "Rembrandt Radeon High Definition Audio Controller"
        module-udev-detect.discovered = "1"
        device.icon_name = "audio-card-pci"
    profiles:
        output:hdmi-stereo: Sortie Digital Stereo (HDMI) (priority 5900, available: no)
        output:hdmi-surround: Sortie Digital Surround 5.1 (HDMI) (priority 800, available: no)
        output:hdmi-surround71: Sortie Digital Surround 7.1 (HDMI) (priority 800, available: no)
        off: Éteint (priority 0, available: unknown)
    active profile: <off>
    ports:
        hdmi-output-0: HDMI / DisplayPort (priority 5900, latency offset 0 usec, available: no)
            properties:
                device.icon_name = "video-display"
    index: 2
    name: <alsa_card.pci-0000_05_00.6>
    driver: <module-alsa-card.c>
    owner module: 8
    properties:
        alsa.card = "2"
        alsa.card_name = "HD-Audio Generic"
        alsa.long_card_name = "HD-Audio Generic at 0x817c0000 irq 99"
        alsa.driver_name = "snd_hda_intel"
        device.bus_path = "pci-0000:05:00.6"
        sysfs.path = "/devices/pci0000:00/0000:00:08.1/0000:05:00.6/sound/card2"
        device.bus = "pci"
        device.vendor.id = "1022"
        device.vendor.name = "Advanced Micro Devices, Inc. [AMD]"
        device.product.id = "15e3"
        device.product.name = "Family 17h/19h HD Audio Controller"
        device.string = "2"
        device.description = "Family 17h/19h HD Audio Controller"
        module-udev-detect.discovered = "1"
        device.icon_name = "audio-card-pci"
    profiles:
        input:analog-stereo: Entrée Stéréo analogique (priority 65, available: no)
        output:analog-stereo: Sortie Stéréo analogique (priority 39268, available: unknown)
        output:analog-stereo+input:analog-stereo: Duplex stéréo analogique (priority 6565, available: unknown)
        off: Éteint (priority 0, available: unknown)
    active profile: <output:analog-stereo+input:analog-stereo>
    sinks:
        alsa_output.pci-0000_05_00.6.analog-stereo/#0: Family 17h/19h HD Audio Controller Stéréo analogique
    sources:
        alsa_output.pci-0000_05_00.6.analog-stereo.monitor/#0: Monitor of Family 17h/19h HD Audio Controller Stéréo analogique
        alsa_input.pci-0000_05_00.6.analog-stereo/#1: Family 17h/19h HD Audio Controller Stéréo analogique
    ports:
        analog-input-headphone-mic: Microphone (priority 8700, latency offset 0 usec, available: no)
            properties:
                device.icon_name = "audio-input-microphone"
        analog-input-headset-mic: Headset Microphone (priority 8800, latency offset 0 usec, available: no)
            properties:
                device.icon_name = "audio-input-microphone"
        analog-output-speaker: Speakers (priority 10000, latency offset 0 usec, available: unknown)
            properties:
                device.icon_name = "audio-speakers"
        analog-output-headphones: Headphones (priority 9900, latency offset 0 usec, available: no)
            properties:
                device.icon_name = "audio-headphones"


alsa-info.sh: http://alsa-project.org/db/?f=350514013 … ba5e613870

Last edited by Slixe (2022-05-25 08:36:27)

Offline

Board footer

Powered by FluxBB