You are not logged in.

#1 2022-06-04 00:13:56

Salkay
Member
Registered: 2014-05-22
Posts: 571

vimdoc.hook error

I've tried installing a few vim plugins, e.g. vim-ctrlp from the official repos, vim-vimtex, vim-delimitmate-git, vim-csv from the AUR. In all cases, vimdoc.hook produced an error.

$ sudo pacman -S vim-ctrlp
...
:: Processing package changes...
(1/1) installing vim-ctrlp                                                           [################################################] 100%
Optional dependencies for vim-ctrlp
    ctags: for searching tags [installed]
:: Running post-transaction hooks...
(1/2) Arming ConditionNeedsUpdate...
(2/2) Updating Vim help tags...
error: command failed to execute correctly

I looked at the hook file at /usr/share/libalpm/hooks/vimdoc.hook, and ran the command manually.

sudo bash -c '/usr/bin/vim -es --cmd ":helptags /usr/share/vim/vimfiles/doc" --cmd ":q"'

but this did not produce an error.

EDIT: bug submitted

Last edited by Salkay (2022-06-04 00:23:00)

Offline

#2 2022-06-04 10:24:50

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 10,765
Website

Re: vimdoc.hook error

Mod note: moving to Pacman/upgrade issues.


Sakura:-
Mobo: MSI MEG B550 UNIFY // Processor: AMD Ryzen 9 5950X @4.9GHz // GFX: AMD Radeon RX 5700 XT // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 6x 1TB SSD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

Board footer

Powered by FluxBB