You are not logged in.

#1 2022-06-07 20:53:46

Heisenberg32
Member
Registered: 2022-04-18
Posts: 7

[Solved] Keyboard layout problem

Hi everyone,
I have a problem with keyboard layout, I set the layout for my keyboard, following the arc guide, but it won't load, keep using the US keyboard. What should I do to fix it?

Last edited by Heisenberg32 (2022-06-08 08:25:48)

Offline

#2 2022-06-07 21:04:36

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 30,050
Website

Re: [Solved] Keyboard layout problem

Heisenberg32 wrote:

What should I do to fix it?

Describe, in detail, the actual steps you took. Read How To Ask Questions The Smart Way.


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

#3 2022-06-07 22:36:08

Heisenberg32
Member
Registered: 2022-04-18
Posts: 7

Re: [Solved] Keyboard layout problem

I have install Arch  with Sway on thinkpad, the laptop have a it keyboard. I followed all steps of the arch guide . I wanted to continue to Sway configuration but I had issue to keyboard. I have configured the file 'vconsole.conf', I have add 'KEYMAP=it' at file, but nothing, the layout not change, remains US. I try to run 'localectl set-keymap --no-convert keymap' but nothing to do, layout not change. The output of 'localectl status', it is this:
System Locale: LANG=it_IT.UTF-8
    VC Keymap: it
     X11 Layout: it
The terminal is 'foot' and I installed Sway minimal without desktop envriovment.

Offline

#4 2022-06-07 23:25:20

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 26,877
Website

Re: [Solved] Keyboard layout problem

Heisenberg32 wrote:

I have configured the file 'vconsole.conf', I have add 'KEYMAP=it'

That's only for the tty, not for a wayland session.  Under wayland you must either configure the compositor itself (sway), or xkbcommon through environment variables.

So, either

A) Set the layout in your sway config

or

B) Set XKB_DEFAULT_LAYOUT prior to launching sway, e.g.:

export XKB_DEFAULT_LAYOUT=it
exec sway

Last edited by Trilby (2022-06-07 23:29:40)


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#5 2022-06-08 08:25:06

Heisenberg32
Member
Registered: 2022-04-18
Posts: 7

Re: [Solved] Keyboard layout problem

Trilby wrote:
Heisenberg32 wrote:

I have configured the file 'vconsole.conf', I have add 'KEYMAP=it'

That's only for the tty, not for a wayland session.  Under wayland you must either configure the compositor itself (sway), or xkbcommon through environment variables.

So, either

A) Set the layout in your sway config

or

B) Set XKB_DEFAULT_LAYOUT prior to launching sway, e.g.:

export XKB_DEFAULT_LAYOUT=it
exec sway

Thanks, I chose the option A) and it work.

Offline

Board footer

Powered by FluxBB