You are not logged in.

#1 2022-06-11 07:31:11

miles
Member
Registered: 2022-06-11
Posts: 4

Having issues getting xinit to run on a fresh install

running startx i get this

/etc/X11/xinit/xserverrc: line 2: /usr/bin/X: Is a directory
/etc/X11/xinit/xserverrc: line 2: exec: /usr/bin/X: cannot execute: Is a directory
xinit: giving up
xinit: unable to connect to the X server: Connection refused
xinit: server error

running with xinit i get this

xinit: unable to run server "X": No such file or directory
Use the --option, or make sure that /usr/bin is in your path and that "X" is a program or a link to the right type of server for your display

when i ls -l the x file

ls: cannot access 'usr/bin/x': No such file or directory

when i open the x file it says in nano

 [  "/usr/bin/X" is a directory ] 

Offline

#2 2022-06-11 07:48:00

jonno2002
Member
Registered: 2016-11-21
Posts: 343

Re: Having issues getting xinit to run on a fresh install

file /usr/bin/X
/usr/bin/X: symbolic link to Xorg

pacman -Qo /usr/bin/X
/usr/bin/X is owned by xorg-server 21.1.3-6

do you actually have xorg-server installed ?

Offline

#3 2022-06-11 07:53:59

miles
Member
Registered: 2022-06-11
Posts: 4

Re: Having issues getting xinit to run on a fresh install

jonno2002 wrote:
file /usr/bin/X
/usr/bin/X: symbolic link to Xorg

pacman -Qo /usr/bin/X
/usr/bin/X is owned by xorg-server 21.1.3-6

do you actually have xorg-server installed ?

when i do pacman -S it has a lot of conflicting packages and after i try to install it

error: failed to commit transaction (conflicting files)
xorg-server: /usr/bin/X exists in filesystem 
Errors occurred, no packages were upgraded.

Offline

#4 2022-06-11 07:56:58

jonno2002
Member
Registered: 2016-11-21
Posts: 343

Re: Having issues getting xinit to run on a fresh install

what is the output of

pacman -Qo /usr/bin/X

Offline

#5 2022-06-11 07:58:12

miles
Member
Registered: 2022-06-11
Posts: 4

Re: Having issues getting xinit to run on a fresh install

jonno2002 wrote:

what is the output of

pacman -Qo /usr/bin/X
error: No package owns /usr/bin/X

Offline

#6 2022-06-11 08:00:46

jonno2002
Member
Registered: 2016-11-21
Posts: 343

Re: Having issues getting xinit to run on a fresh install

ok then, as root run

rm -rf /usr/bin/X && pacman -S xorg-server

Offline

#7 2022-06-11 08:05:52

miles
Member
Registered: 2022-06-11
Posts: 4

Re: Having issues getting xinit to run on a fresh install

jonno2002 wrote:

ok then, as root run

rm -rf /usr/bin/X && pacman -S xorg-server

Okay that seems to have completely fixed any issues and i successfully booted into awesomewm, have a great day.

Last edited by miles (2022-06-11 08:06:06)

Offline

#8 2022-06-11 08:28:07

dogknowsnx
Member
Registered: 2021-04-12
Posts: 261

Re: Having issues getting xinit to run on a fresh install

Randomly creating system files (as a reaction to "No such file or directory" messages) is a no-no, bad idea jeans, a recipe for disaster...

Please always remember to mark solved topics with [SOLVED]


Wayland.

"We are eternal, all this pain is an illusion" - Maynard James Keenan

Offline

Board footer

Powered by FluxBB