You are not logged in.

#1 2022-06-15 02:46:52

eom.dev
Member
Registered: 2022-02-11
Posts: 30

pacstrap failing from local mirror

I have edited /etc/pacman.d/mirrorlist to include only the local mirror:

Server = file:///mnt/src/archlinux/$repo/os/$arch

At the location listed, I have a database containing some packages from core, community, and extra (with databases named respectively).  From the archiso, I can install some packages, such as git, from my repository; however, attempts to create a new system from the database fail with numerous missing dependencies (I cannot copy them all due to it being on a terminal, here is an example:)

warning: cannot resolve "iproute2", a dependency of base

iproute2 exists in my copy of the core database, though, so I am not sure why it isn't being found.  These errors list a number of missing dependencies in a number of packages, all of which can be located with:

pacman -Ss <missing-dependency>

It seems my configuration is incorrect, and I suspect it is due to my databases being separated as they are; however, the structure mimics kernel.org, so I would appreciate some advice on how to adjust.

Last edited by eom.dev (2022-06-16 00:07:33)

Offline

#2 2022-06-15 03:25:39

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 27,044
Website

Re: pacstrap failing from local mirror

eom.dev wrote:

I have a database containing some packages from core, community, and extra (with databases named respectively).  From the archiso, I can install some packages

This sounds about right.  You have some, and can install some, but not others ... because they aren't there

eom.dev wrote:

iproute2 exists in my copy of the core database, though...

Does it?  Which version, exactly?  Is the version pacstrap is trying to retreive the same one that is in your local repo?

If this suspicion isn't the problem, we'll need to see actual output...

eom.dev wrote:

I cannot copy them all due to it being on a terminal...

You can.  See here.

Last edited by Trilby (2022-06-15 03:28:13)


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Online

#3 2022-06-15 10:01:20

eom.dev
Member
Registered: 2022-02-11
Posts: 30

Re: pacstrap failing from local mirror

Here is the full output (thanks for the command):

$ pacstrap /mnt base
==> Creating install root at /mnt
==> Installing packages to /mnt
:: Synchronizing package databases...
 core downloading...
 extra downloading...
 community downloading...
resolving dependencies...
warning: cannot resolve "p11-kit>=0.24.0", a dependency of "ca-certificates-utils"
warning: cannot resolve "ca-certificates-utils>=20181109-3", a dependency of "ca-certificates-mozilla"
warning: cannot resolve "ca-certificates-mozilla", a dependency of "ca-certificates"
warning: cannot resolve "ca-certificates", a dependency of "curl"
warning: cannot resolve "curl", a dependency of "pacman"
warning: cannot resolve "p11-kit>=0.24.0", a dependency of "ca-certificates-utils"
warning: cannot resolve "ca-certificates-utils>=20181109-3", a dependency of "ca-certificates-mozilla"
warning: cannot resolve "ca-certificates-mozilla", a dependency of "ca-certificates"
warning: cannot resolve "ca-certificates", a dependency of "curl"
warning: cannot resolve "curl", a dependency of "tpm2-tss"
warning: cannot resolve "tpm2-tss", a dependency of "libsecret"
warning: cannot resolve "libsecret", a dependency of "pinentry"
warning: cannot resolve "p11-kit>=0.24.0", a dependency of "ca-certificates-utils"
warning: cannot resolve "ca-certificates-utils>=20181109-3", a dependency of "ca-certificates-mozilla"
warning: cannot resolve "ca-certificates-mozilla", a dependency of "ca-certificates"
warning: cannot resolve "ca-certificates", a dependency of "curl"
warning: cannot resolve "curl", a dependency of "tpm2-tss"
warning: cannot resolve "tpm2-tss", a dependency of "libsecret"
warning: cannot resolve "libsecret-1.so=0-64", a dependency of "pinentry"
warning: cannot resolve "pinentry", a dependency of "gnupg"
warning: cannot resolve "p11-kit", a dependency of "gnutls"
warning: cannot resolve "gnutls", a dependency of "gnupg"
warning: cannot resolve "gnupg>=2", a dependency of "gpgme"
warning: cannot resolve "gpgme", a dependency of "pacman"
warning: cannot resolve "pacman", a dependency of "base"
warning: cannot resolve "p11-kit>=0.24.0", a dependency of "ca-certificates-utils"
warning: cannot resolve "ca-certificates-utils>=20181109-3", a dependency of "ca-certificates-mozilla"
warning: cannot resolve "ca-certificates-mozilla", a dependency of "ca-certificates"
warning: cannot resolve "ca-certificates", a dependency of "curl"
warning: cannot resolve "libcurl.so=4-64", a dependency of "libelf"
warning: cannot resolve "libelf", a dependency of "systemd"
warning: cannot resolve "systemd", a dependency of "base"
warning: cannot resolve "p11-kit>=0.24.0", a dependency of "ca-certificates-utils"
warning: cannot resolve "ca-certificates-utils>=20181109-3", a dependency of "ca-certificates-mozilla"
warning: cannot resolve "ca-certificates-mozilla", a dependency of "ca-certificates"
warning: cannot resolve "ca-certificates", a dependency of "curl"
warning: cannot resolve "libcurl.so=4-64", a dependency of "libelf"
warning: cannot resolve "libelf", a dependency of "systemd"
warning: cannot resolve "systemd", a dependency of "systemd-sysvcompat"
warning: cannot resolve "systemd-sysvcompat", a dependency of "base"
warning: cannot resolve "p11-kit>=0.24.0", a dependency of "ca-certificates-utils"
warning: cannot resolve "ca-certificates-utils>=20181109-3", a dependency of "ca-certificates-mozilla"
warning: cannot resolve "ca-certificates-mozilla", a dependency of "ca-certificates"
warning: cannot resolve "ca-certificates", a dependency of "curl"
warning: cannot resolve "libcurl.so=4-64", a dependency of "libelf"
warning: cannot resolve "libelf", a dependency of "iproute2"
warning: cannot resolve "p11-kit>=0.24.0", a dependency of "ca-certificates-utils"
warning: cannot resolve "ca-certificates-utils>=20181109-3", a dependency of "ca-certificates-mozilla"
warning: cannot resolve "ca-certificates-mozilla", a dependency of "ca-certificates"
warning: cannot resolve "ca-certificates", a dependency of "curl"
warning: cannot resolve "libcurl.so=4-64", a dependency of "libelf"
warning: cannot resolve "libelf", a dependency of "libbpf"
warning: cannot resolve "libbpf", a dependency of "iproute2"
warning: cannot resolve "iproute2", a dependency of "base"
:: The following package cannot be upgraded due to unresolvable dependencies:
      base

:: Do you want to skip the above package for this upgrade? [y/N] error: failed to prepare transaction (could not satisfy dependencies)

:: unable to satisfy dependency 'p11-kit>=0.24.0' required by ca-certificates-utils
:: unable to satisfy dependency 'ca-certificates-utils>=20181109-3' required by ca-certificates-mozilla
:: unable to satisfy dependency 'ca-certificates-mozilla' required by ca-certificates
:: unable to satisfy dependency 'ca-certificates' required by curl
:: unable to satisfy dependency 'curl' required by pacman
:: unable to satisfy dependency 'p11-kit>=0.24.0' required by ca-certificates-utils
:: unable to satisfy dependency 'ca-certificates-utils>=20181109-3' required by ca-certificates-mozilla
:: unable to satisfy dependency 'ca-certificates-mozilla' required by ca-certificates
:: unable to satisfy dependency 'ca-certificates' required by curl
:: unable to satisfy dependency 'curl' required by tpm2-tss
:: unable to satisfy dependency 'tpm2-tss' required by libsecret
:: unable to satisfy dependency 'libsecret' required by pinentry
:: unable to satisfy dependency 'p11-kit>=0.24.0' required by ca-certificates-utils
:: unable to satisfy dependency 'ca-certificates-utils>=20181109-3' required by ca-certificates-mozilla
:: unable to satisfy dependency 'ca-certificates-mozilla' required by ca-certificates
:: unable to satisfy dependency 'ca-certificates' required by curl
:: unable to satisfy dependency 'curl' required by tpm2-tss
:: unable to satisfy dependency 'tpm2-tss' required by libsecret
:: unable to satisfy dependency 'libsecret-1.so=0-64' required by pinentry
:: unable to satisfy dependency 'pinentry' required by gnupg
:: unable to satisfy dependency 'p11-kit' required by gnutls
:: unable to satisfy dependency 'gnutls' required by gnupg
:: unable to satisfy dependency 'gnupg>=2' required by gpgme
:: unable to satisfy dependency 'gpgme' required by pacman
:: unable to satisfy dependency 'pacman' required by base
:: unable to satisfy dependency 'p11-kit>=0.24.0' required by ca-certificates-utils
:: unable to satisfy dependency 'ca-certificates-utils>=20181109-3' required by ca-certificates-mozilla
:: unable to satisfy dependency 'ca-certificates-mozilla' required by ca-certificates
:: unable to satisfy dependency 'ca-certificates' required by curl
:: unable to satisfy dependency 'libcurl.so=4-64' required by libelf
:: unable to satisfy dependency 'libelf' required by systemd
:: unable to satisfy dependency 'systemd' required by base
:: unable to satisfy dependency 'p11-kit>=0.24.0' required by ca-certificates-utils
:: unable to satisfy dependency 'ca-certificates-utils>=20181109-3' required by ca-certificates-mozilla
:: unable to satisfy dependency 'ca-certificates-mozilla' required by ca-certificates
:: unable to satisfy dependency 'ca-certificates' required by curl
:: unable to satisfy dependency 'libcurl.so=4-64' required by libelf
:: unable to satisfy dependency 'libelf' required by systemd
:: unable to satisfy dependency 'systemd' required by systemd-sysvcompat
:: unable to satisfy dependency 'systemd-sysvcompat' required by base
:: unable to satisfy dependency 'p11-kit>=0.24.0' required by ca-certificates-utils
:: unable to satisfy dependency 'ca-certificates-utils>=20181109-3' required by ca-certificates-mozilla
:: unable to satisfy dependency 'ca-certificates-mozilla' required by ca-certificates
:: unable to satisfy dependency 'ca-certificates' required by curl
:: unable to satisfy dependency 'libcurl.so=4-64' required by libelf
:: unable to satisfy dependency 'libelf' required by iproute2
:: unable to satisfy dependency 'p11-kit>=0.24.0' required by ca-certificates-utils
:: unable to satisfy dependency 'ca-certificates-utils>=20181109-3' required by ca-certificates-mozilla
:: unable to satisfy dependency 'ca-certificates-mozilla' required by ca-certificates
:: unable to satisfy dependency 'ca-certificates' required by curl
:: unable to satisfy dependency 'libcurl.so=4-64' required by libelf
:: unable to satisfy dependency 'libelf' required by libbpf
:: unable to satisfy dependency 'libbpf' required by iproute2
:: unable to satisfy dependency 'iproute2' required by base
==> ERROR: Failed to install packages to new root

Using iproute2 as an example, pacman -Ss:

core/iproute2 5.18.0-1 [installed: 5.16.0-1]
    IP Routing Utilities

I am not sure how to tell what version pacstrap is looking for.  To be clear, all of the listed packages have been downloaded and repo-added.

Last edited by eom.dev (2022-06-15 10:06:26)

Offline

#4 2022-06-15 10:24:59

eom.dev
Member
Registered: 2022-02-11
Posts: 30

Re: pacstrap failing from local mirror

Just because they were downloaded and repo-added doesn't mean they are in the database.  I double checked each package against pacman -Ss and lib11-kit did not resolve to anything.  Oddly, the file was there and repo-add warned me that there was already a database entry, but adding it again allowed me to pacstrap base.

Update:

This actually didn't fix the issue.  At some point the mirror list must have been regenerated as pacman started using the official mirrors rather than the local one.  lib11-kit is not the actual package name, either: it is p11-kit, which does resolve in pacman -Ss.

Last edited by eom.dev (2022-06-16 00:09:57)

Offline

Board footer

Powered by FluxBB