You are not logged in.

#1 2022-06-19 05:44:46

NoPreserveRoot
Member
Registered: 2022-06-19
Posts: 1

AMD SFH issues on Lenovo Ideapad Flex 5 14" with Ryzen CPU

Hey, everyone. I recently decided to try getting the accelerometer in my Lenovo Ideapad Flex 5 to work, but I've been running into some issues. The laptop uses an AMD sensor fusion hub to gather these readings, but I've never been able to get it working properly. About a year ago I managed to get monitor-sensor to display some output, but the accelerometer reading was "undefined" and it appeared that the driver/kernel module simply wasn't fully fleshed out yet. However, now when I run monitor-sensor it hangs at "Waiting for iio-sensor-proxy to appear." I've been searching for a few days now and still can't figure out what's going on. iio-sensor-proxy fails to start and doesn't detect any sensors. I've verified that the amd_sfh kernel module is loaded and I've tried setting the sensor_mask, but so far I've had no luck. If anyone has any ideas, please let me know! It would be great if I could get this convertible to actually function like one.

"/usr/libexec/iio-sensor-proxy -v" output:

** (iio-sensor-proxy:4083): DEBUG: 01:37:49.942: Starting iio-sensor-proxy version 3.3
** (iio-sensor-proxy:4083): DEBUG: 01:37:49.975: No sensors or missing kernel drivers for the sensors

"lspci -knn" output (with other device data removed):

04:00.7 Signal processing controller [1180]: Advanced Micro Devices, Inc. [AMD] Sensor Fusion Hub [1022:15e4]
	Subsystem: Advanced Micro Devices, Inc. [AMD] Sensor Fusion Hub [1022:15e4]
	Kernel driver in use: pcie_mp2_amd
	Kernel modules: amd_sfh

"iio_info" output:

Library version: 0.23 (git tag: v0.23)
Compiled with backends: local xml ip usb serial
Unable to create Local IIO context : No such file or directory (2)

"uname -r" output:

5.18.5-arch1-1

Offline

Board footer

Powered by FluxBB