You are not logged in.

#1 2022-06-18 08:23:27

deepfuchsia
Member
Registered: 2018-11-01
Posts: 10

laptop wakes up by itself after suspend

Hello. I originally had this issue with Manjaro, so I decided to install Arch, and now I have the same issue.

I use my laptop with an external monitor, and usually I disable laptop's display via randr, so that while I'm doing things on laptop - its lid is closed. Then I execute the `suspend` command and go away.
Today at 1am I noticed some noise in my flat, turned out it was laptop's fan. I didn't touch the laptop and it was closed, but for some reason it started working like this, and working hard enough to make fan spin. (right now I have a few apps opened and CPU temp is 38C, so fan is silent).

Here is what I found in `journalctl`

suspend.png

As you can see from the screenshot the system started entering sleep state 'suspend' at 23:55:09, but at 01:27:28 it suddenly woke up with message `Filesystems sync: 0.008`
and then it started doing even more things.

I don't want to install another distro since I don't know if it will fix anything, so please help me to debug and fix this issue.

Offline

#2 2022-06-18 09:19:16

deepfuchsia
Member
Registered: 2018-11-01
Posts: 10

Re: laptop wakes up by itself after suspend

Okay, I googled a little bit and it looks like there are some wake up triggers. I can list them with

lshw -businfo -numeric

and

lspci -DPPnn

commands, but there are so many triggers, how can I check what exactly triggered a wake up?

Offline

#3 2022-06-20 09:17:17

rep_movsd
Member
Registered: 2013-08-24
Posts: 115

Re: laptop wakes up by itself after suspend

I used to have this same issue

Run:

sudo powertop

Tab to the "Wakeup" screen and turn off all devices ( typically you don't want any device to wake the system from sleep)
On my system its always the wireless mouse, even picking it up to turn the mouse off when the laptop is suspended will wake it.

On a related note, some wireless mice dongles will go into powersave mode and take a couple of seconds to wakeup, which is annoying - you can turn that off in powertop too.

Offline

Board footer

Powered by FluxBB