You are not logged in.

#1 2022-04-29 07:53:17

From: Chicagoland
Registered: 2016-07-31
Posts: 29

Cannot Print Duplex on Brother MFC-9970CDW

I can print duplex from my phone, and from my Kubuntu Server (installed the driver via Brother's official install script), but for some reason on my Arch laptop with the AUR package, it absolutely will not print Duplex despite being set for Duplex in CUPS. Arch/KDE will not recognize that Duplex is an available option for the printer during print dialogs.

There must be something different between the official Brother installation script and this AUR package but I can't figure out what it is. I'm not a dev and can't read Bash well enough to understand what's going on in the official script.

Can't run the official script on Arch because it will error out with "requires dpkg or rpm", which of course Arch doesn't have.

Anyone got any ideas on what might be different between the official Brother script and the AUR package? Looking at the PKGBUILD it looks like it just invokes the installation of the RPM package; but when I ran the official script on my Kubuntu server, it asked extra questions at the end; but they were just related to the scanner and network settings, didn't appear to have anything to do with print settings.

Brother official Linux installation script w/ instructions: … &type3=625

AUR package: … ent-863119

And the worldly life is not but amusement and diversion; but the home of the Hereafter is best for those who fear Allah, so will you not reason? {6:32}


#2 2022-06-27 15:17:17

Registered: 2015-09-13
Posts: 1

Re: Cannot Print Duplex on Brother MFC-9970CDW

don't get your hopes up, I just wanted to say, I have the same problem with a MFC-J6920DW and would be very interested if you found a solution in the meantime. Duplex printing worked for me for many years until some weeks ago, then there was an upgrade (of the entire system) and since then it won't work any more. I've tried may things like installing the printer new in CUPS, no luck. The print job starts, i.e. it pulls in paper, but then it gets stuck, sits there for a few minutes, spits out the blank paper and that's it (there were about 30 pages to be printed).
BTW I run Manjaro with KDE, but I guess that doesn't make much of a difference. On the Manjaro side, there don't seem to be any experts on printing either, so I'm a bit frustrated. I need that urgently already for weeks and have wasted lots of paper in the meantime.

The logs say (error) the following:

W [27/Jun/2022:16:24:51 +0200] Printer drivers are deprecated and will stop working in a future version of CUPS. See [url][/url]

and (pages):

MFC-J6920DW_A5 username 662 [27/Jun/2022:17:02:59 +0200] total 0 - localhost A5-xxxxx.pdf iso_a5_148x210mm -

and (access):

localhost - root [27/Jun/2022:16:38:51 +0200] "POST / HTTP/1.1" 200 1347 CUPS-Get-Devices -
localhost - - [27/Jun/2022:16:39:47 +0200] "POST / HTTP/1.1" 200 566 Create-Printer-Subscriptions successful-ok
localhost - - [27/Jun/2022:17:02:01 +0200] "POST /printers/MFC-J6920DW_A5 HTTP/1.1" 200 10250270 Print-Job successful-ok

There were about 30 pages to be printed.


#3 2022-07-07 13:58:33

Registered: 2022-07-07
Posts: 1

Re: Cannot Print Duplex on Brother MFC-9970CDW

I have the same problem with a MFC-J6920DW  (Vanilla Arch and also Manjaro with KDE). After a day's research, I might have made some progress. I downgraded the package lib32-glibc from version 2.35-6 to 2.35-3.

 sudo pacman -U /var/cache/pacman/pkg/lib32-glibc-2.35-3-x86_64.pkg.tar.zst 

Now I can at least again print DIN-A4-PDFs (which I open with LibreOffice Draw) as a booklet on DIN A3 with duplex functionality smile

If this helps, don't forget to set the "ignore package from being upgraded" in pacman.conf


Board footer

Powered by FluxBB