You are not logged in.

#1 2022-06-28 11:46:28

Kabir
Member
From: India
Registered: 2016-12-06
Posts: 59

[SOLVED] Unable to access gnome-weather app

Hi,

The gnome-weather app fails to launch, and doesn't update itself with the current temperatures in the drop down gnome time and date dock. It was working fine until yesterday.

Trying to launch the app produces these lines in the journal:

Jun 28 16:55:42 kabirsarch dbus-daemon[822]: [session uid=1000 pid=822] Activating service name='org.gnome.Weather' requested by ':1.11' (uid=1000 pid=869 comm="/usr/bin/gnome-shell")
Jun 28 16:55:42 kabirsarch org.gnome.Weath[2650]: Error: Expected type object for argument 'boxed_type' but got type undefined
                                                  _init/GObject.ParamSpec.jsobject@resource:///org/gnome/gjs/modules/core/overrides/GObject.js:404:24
                                                  @resource:///org/gnome/Weather/js/app/thermometer.js:47:32
                                                    
Jun 28 16:55:42 kabirsarch dbus-daemon[822]: [session uid=1000 pid=822] Activated service 'org.gnome.Weather' failed: Process org.gnome.Weather exited with status 1

Any suggestions what I may try to fix this?
Thanks!

Edit: gnome-weather doesn't show as an installed app on the gnome software app if I install gnome-weather using pacman, which is how I installed it to begin with. But if I install weather from within the gnome software app, I'm able to launch the app. And now on launching the app the journal reads as:

Jun 28 17:34:19 kabirsarch dbus-daemon[5658]: [session uid=1000 pid=5658] Successfully activated service 'org.gnome.Weather'
Jun 28 17:34:20 kabirsarch gnome-shell[5705]: Could not create transient scope for PID 0: GDBus.Error:org.freedesktop.systemd1.UnitExists: Unit app-gnome-org.gnome.Weather-0.scope already exists.
Jun 28 17:34:20 kabirsarch gnome-shell[5705]: meta_window_set_stack_position_no_sync: assertion 'window->stack_position >= 0' failed
Jun 28 17:34:20 kabirsarch org.gnome.Weath[7403]: JS LOG: Failed to connect to GeoClue2 service: GDBus.Error:org.freedesktop.portal.Error.NotAllowed: Location services disabled

I don't understand why I've had to install the app from the gnome software center as well?

Last edited by Kabir (2022-07-04 06:40:54)

Offline

#2 2022-06-28 12:13:18

JoeyCorleone
Member
Registered: 2022-01-22
Posts: 84

Re: [SOLVED] Unable to access gnome-weather app

There seem to be more people reporting this issue. It is probably best for now if you follow this upstream ticket.

Offline

Board footer

Powered by FluxBB