You are not logged in.

#1 2022-07-04 17:58:50

davidbryant
Member
From: Canyon Lake, Texas
Registered: 2022-06-29
Posts: 6
Website

Odd colors with Gnome / xorg

So I recently installed ARCH Linux on my hard drive. I'm a Gentoo user, but interested in Linux more generally. At the moment I also have Windoze 10, Kubuntu, Artix, Endeavour, Manjaro, and openSUSE LEAP available on this machine. ARCH is the only distro where I have installed GNOME. I generally use KDE.

Anyway, i have installed the gnome and gnome-extras packages, and I have set up gdm. The Wayland protocol works well with either Gnome or Gnome Classic. But if I choose to use the xorg server, the black background in gdm turns bright yellow. When I log in, the yellow coloration persists, and the system is basically useless -- the fonts render as white letters, and are barely distinguishable from the bright yellow background.

Let's see ... I have a Dell XPS8930 PC, Intel I9 CPU, and an NVIDIA RTX 2060 gpu. Any suggestions about fixing the yellow coloraton are welcome.

An update: I swtched to the Nvidia video driver (instead of nouveau), and now the xorg options are no longer available on the gdm login screen.That seems odd to me. But at least it made the "yellow problem" go away. smile

Last edited by davidbryant (2022-07-04 19:28:41)


David Bryant
Canyon Lake, Texas
https://davidcbryant.net

Offline

#2 2022-07-04 20:53:26

seth
Member
Registered: 2012-09-03
Posts: 32,129

Re: Odd colors with Gnome / xorg

Are you on X11 by default now? (echo $XDG_SESSION_TYPE)
https://wiki.archlinux.org/title/NVIDIA … de_setting

Offline

#3 2022-07-04 23:37:59

davidbryant
Member
From: Canyon Lake, Texas
Registered: 2022-06-29
Posts: 6
Website

Re: Odd colors with Gnome / xorg

seth wrote:

Are you on X11 by default now? (echo $XDG_SESSION_TYPE)

The response depends on where I issue the command.

Outside of a desktop entironment (i.e., at an agetty prompt)
# echo $XDG_SESSION_TYPE
tty

In a regular Gnome session:
# echo $XDG_SESSION_TYPE
wayland

In a MATE session
# echo $XDG_SESSION_TYPE
x11

The kernel boot parameter (nvidia-drm.modeset=1) described in that reference has no discrnible effect on the bright yellow background.

I have tried starting an xorg Gnome session both from the gdm login screen (gear icon at the lower right when logging in) and manually (edit ~/.xinitrc, then say startx after disabling gdm.service and rebooting the system). Same result either way. Bright yelow background, illegible fonts.

This afternoon I installed the MATE desktop package. That works fine when I fire it up with startx. Also works OK with gdm (althoough gdm doesn;t give me an xorg option with MATE). I suspect that MATE only works with x11. I haven't tried any other DEs yet. Maybe tomorrow.


David Bryant
Canyon Lake, Texas
https://davidcbryant.net

Offline

#4 2022-07-05 06:10:51

seth
Member
Registered: 2012-09-03
Posts: 32,129

Re: Odd colors with Gnome / xorg

In a regular Gnome session:
# echo $XDG_SESSION_TYPE
wayland

So you're running gnome on wayland

The kernel boot parameter (nvidia-drm.modeset=1) described in that reference

would, if at all, only have impact on the gnome/wayland situation and not on the nouveau module anyway.

I have tried starting an xorg Gnome session both from the gdm login screen (gear icon at the lower right when logging in) and manually (edit ~/.xinitrc, then say startx after disabling gdm.service and rebooting the system). Same result either way. Bright yelow background, illegible fonts.

Even w/ the nvidia driver?

MATE desktop package. That works fine when I fire it up with startx

So it's a gnome exclusive thing, rather than the GPU driver or X11 server.
See https://wiki.archlinux.org/title/ICC_pr … or_Manager (whether it goes possibly on a tantrum) and try

xcalib -c

to possibly reset the gamma ramps.

Offline

#5 2022-07-05 16:09:13

davidbryant
Member
From: Canyon Lake, Texas
Registered: 2022-06-29
Posts: 6
Website

Re: Odd colors with Gnome / xorg

seth wrote:

I have tried starting an xorg Gnome session both from the gdm login screen (gear icon at the lower right when logging in) and manually (edit ~/.xinitrc, then say startx after disabling gdm.service and rebooting the system). Same result either way. Bright yelow background, illegible fonts.

Even w/ the nvidia driver?

Oddly enough, the GDM desktop manager no longer offers me the x11 options for Gnome / Gnome Classic. A bunch of Gnome stuff was updated on Sunday when I ran "pacman -Syu". I guess somebody else was having similar problems, maybe.

I just now reinstalled the nvidia driver, and now I get a decent Gnome desktop with startx. Here's some terminal output (from a terminal emulator running in the Gnome sesion I fired up with startx). And I'm posting this response from Firefox running under Gnome /X11.

[david@localhost ~]$ echo $XDG_SESSION_TYPE
x11

So it looks as if the problem was caused by the nouveau driver. I'm sure I had the same problem yesterday with the nvidia driver installed, but today it's fixed. Go figure. Thanks, Seth!


David Bryant
Canyon Lake, Texas
https://davidcbryant.net

Offline

Board footer

Powered by FluxBB