You are not logged in.

#1 2022-07-20 18:48:10

JaydenDev
Member
Registered: 2022-07-11
Posts: 122

[Solved] linux-rc outdated, can i release an updated pkg?

Said package 'linux-rc' is outdated, am I allowed to release an up-to-date version? It's already been marked as outdated.

Last edited by JaydenDev (2022-07-21 02:26:35)


System Specs:
Intel Core i5-2400 Nvidia GTX 1050ti Logitech G402 Hyperion Fury (Mouse) BestBuy Essentials USB Keyboard
Software Specifications:
Desktop Environment: KDE Plasma Window Manager: KWin Operating System: Arch Linux (btw)

Offline

#2 2022-07-20 18:52:59

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 30,135
Website

Re: [Solved] linux-rc outdated, can i release an updated pkg?

https://wiki.archlinux.org/title/Arch_U … ut-of-date

# edit: jesus wept, it was flagged out-of-date yesterday.

Last edited by jasonwryan (2022-07-20 18:54:50)


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Online

#3 2022-07-20 18:59:07

Slithery
Administrator
From: Norfolk, UK
Registered: 2013-12-01
Posts: 5,372

Re: [Solved] linux-rc outdated, can i release an updated pkg?

Graysky is usually fairly prompt updating their packages.
It was only marked as out of date earlier today so it's still far to early to get it orphaned and take over the package yourself.


No, it didn't "fix" anything. It just shifted the brokeness one space to the right. - jasonwryan
Closing -- for deletion; Banning -- for muppetry. - jasonwryan

aur - dotfiles

Offline

#4 2022-07-20 19:48:42

JaydenDev
Member
Registered: 2022-07-11
Posts: 122

Re: [Solved] linux-rc outdated, can i release an updated pkg?

Slithery wrote:

Graysky is usually fairly prompt updating their packages.
It was only marked as out of date earlier today so it's still far to early to get it orphaned and take over the package yourself.

Another question, when I marked it as outdated it instantly turned outdated. Isn't there supposed to be like a verification, or a mod reviewing first?


System Specs:
Intel Core i5-2400 Nvidia GTX 1050ti Logitech G402 Hyperion Fury (Mouse) BestBuy Essentials USB Keyboard
Software Specifications:
Desktop Environment: KDE Plasma Window Manager: KWin Operating System: Arch Linux (btw)

Offline

#5 2022-07-20 19:51:53

Slithery
Administrator
From: Norfolk, UK
Registered: 2013-12-01
Posts: 5,372

Re: [Solved] linux-rc outdated, can i release an updated pkg?

JaydenDev wrote:

[Another question, when I marked it as outdated it instantly turned outdated. Isn't there supposed to be like a verification, or a mod reviewing first?

No.
Anyone can revert the flag if it's incorrect (as has been done since your last post).


No, it didn't "fix" anything. It just shifted the brokeness one space to the right. - jasonwryan
Closing -- for deletion; Banning -- for muppetry. - jasonwryan

aur - dotfiles

Offline

#6 2022-07-20 23:13:29

JaydenDev
Member
Registered: 2022-07-11
Posts: 122

Re: [Solved] linux-rc outdated, can i release an updated pkg?

since linux-rc is the latest rc of 5.18.13, can I make linux-rc-bleeding or something of the like with 5.19-rc7?


System Specs:
Intel Core i5-2400 Nvidia GTX 1050ti Logitech G402 Hyperion Fury (Mouse) BestBuy Essentials USB Keyboard
Software Specifications:
Desktop Environment: KDE Plasma Window Manager: KWin Operating System: Arch Linux (btw)

Offline

#7 2022-07-20 23:30:49

Slithery
Administrator
From: Norfolk, UK
Registered: 2013-12-01
Posts: 5,372

Re: [Solved] linux-rc outdated, can i release an updated pkg?

JaydenDev wrote:

since linux-rc is the latest rc of 5.18.13, can I make linux-rc-bleeding or something of the like with 5.19-rc7?

You could but it will probably be deleted by a TU for providing the same package with just an updated version.
If you really can't wair a day or two for Graysky to update their package then just use your updated version locally in the meantime.
A better solution for your title would have just been to remove one or two of the meaningless words so you could fit [SOLVED] at the beginning.
Now it makes no sense at all...


No, it didn't "fix" anything. It just shifted the brokeness one space to the right. - jasonwryan
Closing -- for deletion; Banning -- for muppetry. - jasonwryan

aur - dotfiles

Offline

#8 2022-07-21 02:02:48

JaydenDev
Member
Registered: 2022-07-11
Posts: 122

Re: [Solved] linux-rc outdated, can i release an updated pkg?

Slithery wrote:
JaydenDev wrote:

since linux-rc is the latest rc of 5.18.13, can I make linux-rc-bleeding or something of the like with 5.19-rc7?

You could but it will probably be deleted by a TU for providing the same package with just an updated version.
If you really can't wair a day or two for Graysky to update their package then just use your updated version locally in the meantime.
A better solution for your title would have just been to remove one or two of the meaningless words so you could fit [SOLVED] at the beginning.
Now it makes no sense at all...

everything's solved now!


System Specs:
Intel Core i5-2400 Nvidia GTX 1050ti Logitech G402 Hyperion Fury (Mouse) BestBuy Essentials USB Keyboard
Software Specifications:
Desktop Environment: KDE Plasma Window Manager: KWin Operating System: Arch Linux (btw)

Offline

#9 2022-07-21 02:11:17

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 30,135
Website

Re: [Solved] linux-rc outdated, can i release an updated pkg?

JaydenDev wrote:
Slithery wrote:
JaydenDev wrote:

since linux-rc is the latest rc of 5.18.13, can I make linux-rc-bleeding or something of the like with 5.19-rc7?

You could but it will probably be deleted by a TU for providing the same package with just an updated version.
If you really can't wair a day or two for Graysky to update their package then just use your updated version locally in the meantime.
A better solution for your title would have just been to remove one or two of the meaningless words so you could fit [SOLVED] at the beginning.
Now it makes no sense at all...

everything's solved now!

No, the thread title is effectively useless... Fix it.


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Online

#10 2022-07-21 02:23:56

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 18,634

Re: [Solved] linux-rc outdated, can i release an updated pkg?

jasonwryan wrote:

No, the thread title is effectively useless... Fix it.

^^^ This.

Also, please check your email.  I sent you a message about your account status and would like to hear from you before I take action.


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

#11 2022-07-21 02:25:46

JaydenDev
Member
Registered: 2022-07-11
Posts: 122

Re: [Solved] linux-rc outdated, can i release an updated pkg?

ewaller wrote:
jasonwryan wrote:

No, the thread title is effectively useless... Fix it.

^^^ This.

Also, please check your email.  I sent you a message about your account status and would like to hear from you before I take action.

Can you forward it to jdev0894@gmail.com? I'm completely unsure what the email for TemporaryAccount is.
^ scratch that, JaydenDev account owns this topic. im not seeing an email in my main email.

Last edited by JaydenDev (2022-07-21 02:30:15)


System Specs:
Intel Core i5-2400 Nvidia GTX 1050ti Logitech G402 Hyperion Fury (Mouse) BestBuy Essentials USB Keyboard
Software Specifications:
Desktop Environment: KDE Plasma Window Manager: KWin Operating System: Arch Linux (btw)

Offline

#12 2022-07-21 02:33:09

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 18,634

Re: [Solved] linux-rc outdated, can i release an updated pkg?

I forwarded the message.  You may want to update the email for JaydenDev


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

#13 2022-07-21 02:43:01

JaydenDev
Member
Registered: 2022-07-11
Posts: 122

Re: [Solved] linux-rc outdated, can i release an updated pkg?

ewaller wrote:

I forwarded the message.  You may want to update the email for JaydenDev

My main email works, just I've added filters to prevent bad stuff from popping up in spam and inbox. And half the time those filters delete all the important ones and leave all the needed ones. Though it usually moves them to trash, not delete them entirely. Anyway, I responded to the email. This topic can now be considered solved as the title suggests.


System Specs:
Intel Core i5-2400 Nvidia GTX 1050ti Logitech G402 Hyperion Fury (Mouse) BestBuy Essentials USB Keyboard
Software Specifications:
Desktop Environment: KDE Plasma Window Manager: KWin Operating System: Arch Linux (btw)

Offline

#14 2022-07-21 03:20:06

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 27,053
Website

Re: [Solved] linux-rc outdated, can i release an updated pkg?

Slithery wrote:
JaydenDev wrote:

since linux-rc is the latest rc of 5.18.13, can I make linux-rc-bleeding or something of the like with 5.19-rc7?

You could but it will probably be deleted by a TU for providing the same package with just an updated version.

That wouldn't quite be accurate.  Graysky doesn't intend to update the linux-rc to the latest mainline kernels, just the latest stable release candidates.  So a package tracking the latest mainline could have a place in the AUR.  I'm quite confident of this last point as there is, and long has beeen, a linux-mainline package in the AUR.  And guess what version it's on currently: 5.19-rc7.

So a putative linux-rc-bleeding would not be removed for being a newer version of linux-rc, it would be deleted for being an exact duplicate of linux-mainline.

The above points are abundantly clear (and have been repeated several times and have been included in a pinned comment) on the AUR page of linux-rc.

Last edited by Trilby (2022-07-21 15:45:54)


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#15 2022-07-21 14:57:14

JaydenDev
Member
Registered: 2022-07-11
Posts: 122

Re: [Solved] linux-rc outdated, can i release an updated pkg?

Trilby wrote:
Slithery wrote:
JaydenDev wrote:

since linux-rc is the latest rc of 5.18.13, can I make linux-rc-bleeding or something of the like with 5.19-rc7?

You could but it will probably be deleted by a TU for providing the same package with just an updated version.

That wouldn't quite be accurate.  Graysky doesn't intend to update the linux-rc to the latest mainline kernels, just the latest stable release candidates.  So there a package tracking the latest mainline could have a place in the AUR.  I'm quite confident of this last point as there is, and long has beeen, a linux-mainline package in the AUR.  And guess what version it's on currently: 5.19-rc7.

So a putative linux-rc-bleeding would not be removed for being a newer version of linux-rc, it would be deleted for being an exact duplicate of linux-mainline.

The above points are abundantly clear (and have been repeated several times and have been included in a pinned comment) on the AUR page of linux-rc.

Alright! Understood.

Last edited by JaydenDev (2022-07-21 14:57:23)


System Specs:
Intel Core i5-2400 Nvidia GTX 1050ti Logitech G402 Hyperion Fury (Mouse) BestBuy Essentials USB Keyboard
Software Specifications:
Desktop Environment: KDE Plasma Window Manager: KWin Operating System: Arch Linux (btw)

Offline

Board footer

Powered by FluxBB