You are not logged in.

#1 2022-07-22 18:16:53

speedyx
Member
From: Italy
Registered: 2008-09-05
Posts: 95
Website

[SOLVED] Problems in KDE with suspend and hibernation

Dear Archers,
I cannot find a solution that works in the forum or in the wiki or on google.
At some point in the constant flow of upgrades, for sure since the 5.18 kernel, the sleep and hibernation function in KDE didn't work anymore. Simply lock the screen.
No useful information in the journalctl.
Would you like please to help me with some direction?

I have a Lenovo ThinkPad X1 Extreme 2nd Gen with only Arch and KDE.
I use the tlp utility and have disabled the Nvidia card to reduce heating and consumption.
The filesystem is an encrypted btrfs for root and home, but the swap is outside on a separate partition. I have a separate unencrypted /boot partition.
Everything is updated at the last version.

Last edited by speedyx (2022-08-08 10:46:09)


I love archlinux: the last STABLE kernel release + the last STABLE DE release + the last STABLE apps releases. The upstream developers decide what is STABLE.

Offline

#2 2022-07-22 18:34:29

JaydenDev
Member
Registered: 2022-07-11
Posts: 122

Re: [SOLVED] Problems in KDE with suspend and hibernation

Try replacing linux with linux-lts

sudo pacman -R linux
sudo pacman -S linux-lts
sudo pacman -Syu

this will at least work til this gets figured out

While you do think that the journalctl output you got was useless, its still useful. Paste it in code tags.

Last edited by JaydenDev (2022-07-22 18:35:00)


System Specs:
Intel Core i5-2400 Nvidia GTX 1050ti Logitech G402 Hyperion Fury (Mouse) BestBuy Essentials USB Keyboard
Software Specifications:
Desktop Environment: KDE Plasma Window Manager: KWin Operating System: Arch Linux (btw)

Offline

#3 2022-07-23 06:56:19

speedyx
Member
From: Italy
Registered: 2008-09-05
Posts: 95
Website

Re: [SOLVED] Problems in KDE with suspend and hibernation

Here you can find the result of journalctl -b -r -k after a sleep attempt

https://pastebin.com/4pjBsEZ9

Here is the boot loader systemd-boot:

title   Arch Linux - Zen Kernel
linux   /vmlinuz-linux-zen
initrd  /intel-ucode.img
initrd  /initramfs-linux-zen.img
options rd.luks.name=fc79a2f0-f3e2-45a9-8456-f80eb90a2e79=system root=UUID=aa6949b9-57b5-43dd-b3b8-da3df53703d5 rootflags=subvol=@ resume="PARTLABEL=SWAP" rw splash nowatchdog quiet psmouse.synaptics_intertouch=0

Here the blkid results:

/dev/loop1: TYPE="squashfs"
/dev/nvme0n1p3: UUID="fc79a2f0-f3e2-45a9-8456-f80eb90a2e79" TYPE="crypto_LUKS" PARTLABEL="system" PARTUUID="f6c9769b-72bc-e249-aec0-7f4fdfe837ca"
/dev/nvme0n1p1: LABEL_FATBOOT="EFI" LABEL="EFI" UUID="24C9-4F08" BLOCK_SIZE="512" TYPE="vfat" PARTLABEL="EFI" PARTUUID="279d5cd1-7384-3540-b5b7-84041b185248"
/dev/nvme0n1p2: LABEL="swap" UUID="a02ef11a-4434-41cb-bc68-e407e065d24d" TYPE="swap" PARTLABEL="SWAP" PARTUUID="34aef6a4-76fb-8a4c-bb3b-02cb70a695fe"
/dev/loop0: TYPE="squashfs"
/dev/mapper/system: LABEL="system" UUID="aa6949b9-57b5-43dd-b3b8-da3df53703d5" UUID_SUB="3f4c84f6-639e-4619-8f42-399de609c411" BLOCK_SIZE="4096" TYPE="btrfs"
/dev/nvme1n1: LABEL="system" UUID="aa6949b9-57b5-43dd-b3b8-da3df53703d5" UUID_SUB="0fc8b9cf-183e-4703-ab3f-d0255de75169" BLOCK_SIZE="4096" TYPE="btrfs"

And here fstab:

# Static information about the filesystems.
# See fstab(5) for details.

# <file system> <dir> <type> <options> <dump> <pass>

# /dev/nvme0n1p1 UUID=24C9-4F08
LABEL=EFI /boot vfat rw,noatime,fmask=0022,dmask=0022,codepage=437,iocharset=ascii,shortname=mixed,utf8,errors=remount-ro 0 2

# /dev/nvme0n1p2 UUID=a02ef11a-4434-41cb-bc68-e407e065d24d
LABEL=swap none swap defaults 0 0

# /dev/mapper/system UUID=aa6949b9-57b5-43dd-b3b8-da3df53703d5
LABEL=system / btrfs rw,noatime,autodefrag,discard=async,compress=zstd:3,subvolid=256,subvol=/@,subvol=@ 0 0

# /dev/mapper/system UUID=aa6949b9-57b5-43dd-b3b8-da3df53703d5
LABEL=system /home btrfs rw,noatime,autodefrag,discard=async,compress=zstd:3,subvolid=257,subvol=/@home,subvol=@home 0 0

# /dev/mapper/system UUID=aa6949b9-57b5-43dd-b3b8-da3df53703d5
LABEL=system /var btrfs rw,noatime,autodefrag,discard=async,nodatacow,subvolid=258,subvol=/@var,subvol=@var 0 0

Last edited by speedyx (2022-07-23 07:04:20)


I love archlinux: the last STABLE kernel release + the last STABLE DE release + the last STABLE apps releases. The upstream developers decide what is STABLE.

Offline

#4 2022-07-23 10:06:41

JoeyCorleone
Member
Registered: 2022-01-22
Posts: 84

Re: [SOLVED] Problems in KDE with suspend and hibernation

Jul 23 08:49:59 thinkbook kernel: NVRM: GPU 0000:01:00.0: PreserveVideoMemoryAllocations module parameter is set. System Power Management attempted without driver procfs suspend interface. Please refer to the 'Configuring Power Management Support' section in the driver README.

Does it work when you enable the corresponding NVIDIA services?

Last edited by JoeyCorleone (2022-07-23 10:06:56)

Offline

#5 2022-07-23 16:26:18

speedyx
Member
From: Italy
Registered: 2008-09-05
Posts: 95
Website

Re: [SOLVED] Problems in KDE with suspend and hibernation

Thank you very much for the hint!
I reactivated the Nvidia discreet Graphics Card and tried again without success.
But when I deactivated the Card again and tried to sleep or hibernate it worked well.

So how should I understand this behavior?
Maybe is it related to the new attempt to opensourcing the Nvidia drivers?


I love archlinux: the last STABLE kernel release + the last STABLE DE release + the last STABLE apps releases. The upstream developers decide what is STABLE.

Offline

#6 2022-07-26 07:37:14

JoeyCorleone
Member
Registered: 2022-01-22
Posts: 84

Re: [SOLVED] Problems in KDE with suspend and hibernation

According to your log, you had installed proprietary NVIDIA drivers for your system. As long as these drivers are installed and loaded into your kernel, you need to enable the services nvidia-suspend and nvidia-hibernate to be able to properly suspend/hibernate.

Alternatively, you could uninstall all proprietary NVIDIA stuff and fall back to the open-source Nouveau driver which should work out-of-the-box (but maybe not as performant).

Offline

#7 2022-07-27 06:11:24

speedyx
Member
From: Italy
Registered: 2008-09-05
Posts: 95
Website

Re: [SOLVED] Problems in KDE with suspend and hibernation

JoeyCorleone wrote:

Alternatively, you could uninstall all proprietary NVIDIA stuff and fall back to the open-source Nouveau driver which should work out-of-the-box (but maybe not as performant).

Thank you JoeyCorleone!
What do you think, will HDMI work with Nouveau?


I love archlinux: the last STABLE kernel release + the last STABLE DE release + the last STABLE apps releases. The upstream developers decide what is STABLE.

Offline

#8 2022-07-28 11:41:01

JoeyCorleone
Member
Registered: 2022-01-22
Posts: 84

Re: [SOLVED] Problems in KDE with suspend and hibernation

speedyx wrote:
JoeyCorleone wrote:

Alternatively, you could uninstall all proprietary NVIDIA stuff and fall back to the open-source Nouveau driver which should work out-of-the-box (but maybe not as performant).

Thank you JoeyCorleone!
What do you think, will HDMI work with Nouveau?

There is a feature matrix which you can look up. Personally, I would just read the corresponding wiki article and actually test if everything I need works.

Offline

#9 2022-07-28 17:44:36

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 16,718

Re: [SOLVED] Problems in KDE with suspend and hibernation

I doubt nouveau will properly work with anything remotely modern. How exactly did you try to apply the nvidia suspension hooks. Note you need to do quite a bit of setup to properly activate them correctly. https://wiki.archlinux.org/title/NVIDIA … er_suspend might summarise it more clearly.

Also maybe try the reverse and explicitly disable PreserveVideoMemoryAllocation to fall back to the older suspension method.

Last edited by V1del (2022-07-28 17:46:40)

Offline

#10 2022-08-08 10:45:23

speedyx
Member
From: Italy
Registered: 2008-09-05
Posts: 95
Website

Re: [SOLVED] Problems in KDE with suspend and hibernation

Even if I applied the above suggestions, the problem was there again.
But I found useful to solve the problems add to the kernel line acpi_osi keywords as mentioned here.


I love archlinux: the last STABLE kernel release + the last STABLE DE release + the last STABLE apps releases. The upstream developers decide what is STABLE.

Offline

Board footer

Powered by FluxBB