You are not logged in.

#1 2022-07-30 01:53:51

lyxzcx
Member
Registered: 2021-08-13
Posts: 32

[Solved]libtool: Version mismatch error.

I try to use yay to update celt. However,it always failed while make install.Here are some errors.

gcc -DHAVE_CONFIG_H -I. -I..     -march=x86-64 -mtune=generic -O2 -pipe -fno-plt -fexceptions         -Wp,-D_FORTIFY_SOURCE=2 -Wformat -Werror=format-security         -fstack-clash-protection -fcf-protection -fvisibility=hidden -W -Wstrict-prototypes -Wall -Wextra -Wcast-align -Wnested-externs -Wshadow -Wno-parentheses -Wno-unused-parameter -Wno-sign-compare -MT testcelt.o -MD -MP -MF .deps/testcelt.Tpo -c -o testcelt.o testcelt.c
mv -f .deps/testcelt.Tpo .deps/testcelt.Po
/bin/sh ../libtool  --tag=CC   --mode=compile gcc -DHAVE_CONFIG_H -I. -I..     -march=x86-64 -mtune=generic -O2 -pipe -fno-plt -fexceptions         -Wp,-D_FORTIFY_SOURCE=2 -Wformat -Werror=format-security         -fstack-clash-protection -fcf-protection -fvisibility=hidden -W -Wstrict-prototypes -Wall -Wextra -Wcast-align -Wnested-externs -Wshadow -Wno-parentheses -Wno-unused-parameter -Wno-sign-compare -MT bands.lo -MD -MP -MF .deps/bands.Tpo -c -o bands.lo bands.c
libtool: Version mismatch error.  This is libtool 2.4.6, but the
libtool: definition of this LT_INIT comes from libtool 2.4.7-dirty.
libtool: You should recreate aclocal.m4 with macros from libtool 2.4.6
libtool: and run autoconf again.

Last edited by lyxzcx (2022-07-31 10:28:08)

Offline

#2 2022-07-30 02:40:34

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 27,053
Website

Re: [Solved]libtool: Version mismatch error.

Read the comments on the aur page from the maintainer for this package ... and stop using yay.

Last edited by Trilby (2022-07-30 02:42:40)


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#3 2022-07-31 08:44:59

lyxzcx
Member
Registered: 2021-08-13
Posts: 32

Re: [Solved]libtool: Version mismatch error.

Trilby wrote:

Read the comments on the aur page from the maintainer for this package ... and stop using yay.

makepkg also lead to the same failure.

Offline

#4 2022-07-31 10:03:12

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 10,833
Website

Re: [Solved]libtool: Version mismatch error.

Mod note: moving to AUR Issues


Sakura:-
Mobo: MSI MEG B550 UNIFY // Processor: AMD Ryzen 9 5950X @4.9GHz // GFX: AMD Radeon RX 5700 XT // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 6x 1TB SSD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

Board footer

Powered by FluxBB