You are not logged in.

#26 2022-08-02 19:41:06

TheTS
Member
Registered: 2022-08-02
Posts: 22

Re: Xorg crashes when using a discrete video card

seth wrote:

An 80MB journal means you uploaded the entire journal (possibly even in binary form)
We basically only need the xorg log of the failing run.


Okay:
18:52:39 - Xorg.log
19:01:01 - Xorg.log

Offline

#27 2022-08-02 19:47:31

seth
Member
Registered: 2012-09-03
Posts: 30,948

Re: Xorg crashes when using a discrete video card

[   132.654] (EE) Problem parsing the config file
[   132.654] (EE) Error parsing the config file

The config file is invalid, so please post that.

Offline

#28 2022-08-02 20:07:21

TheTS
Member
Registered: 2022-08-02
Posts: 22

Re: Xorg crashes when using a discrete video card

seth wrote:
[   132.654] (EE) Problem parsing the config file
[   132.654] (EE) Error parsing the config file

The config file is invalid, so please post that.

18:52:39 - /etc/X11/xorg.conf.d/10-gpu.conf
19:01:01 - /etc/X11/xorg.conf.d/10-gpu.conf

P.S.: Unfortunately, my time zone is now 23:06. I will be able to reply to you for a while. And I will continue tomorrow. Don't consider it rude, I'm very grateful for your help

Offline

#29 2022-08-02 20:17:42

seth
Member
Registered: 2012-09-03
Posts: 30,948

Re: Xorg crashes when using a discrete video card

/etc/X11/xorg.conf.d/10-gpu.conf

Section "ServerLayout"
    Identifier "layout"
    Screen 0 "amdgpu" #Or modesetting
    Inactive "intel"
EndSection

Section "Device"
    Identifier  "amdgpu"
    Driver      "modesetting"
    BusID       "PCI:13:0:0" #Or PCI:0:13:0 or PCI:d:0:0 or PCI:0:d:0
EndSection

Section "Screen"
    Identifier "amdgpu"
    Device "amdgpu"
EndSection

Section "Device"
    Identifier  "intel"
    Driver      "modesetting"
    BusID       "PCI:0:2:0"
EndSection

Section "Screen"
    Identifier "intel"
    Device "intel"
EndSection

Don't worry - this is an asymmetric medium and everyone responds whenever they want to or can smile
Also I don't face any problem, so I'm not in a hurry smile

Last edited by seth (2022-08-02 20:17:59)

Offline

#30 2022-08-03 05:11:47

TheTS
Member
Registered: 2022-08-02
Posts: 22

Re: Xorg crashes when using a discrete video card

seth wrote:

/etc/X11/xorg.conf.d/10-gpu.conf

Section "ServerLayout"
    Identifier "layout"
    Screen 0 "amdgpu" #Or modesetting
    Inactive "intel"
EndSection

Section "Device"
    Identifier  "amdgpu"
    Driver      "modesetting"
    BusID       "PCI:13:0:0" #Or PCI:0:13:0 or PCI:d:0:0 or PCI:0:d:0
EndSection

Section "Screen"
    Identifier "amdgpu"
    Device "amdgpu"
EndSection

Section "Device"
    Identifier  "intel"
    Driver      "modesetting"
    BusID       "PCI:0:2:0"
EndSection

Section "Screen"
    Identifier "intel"
    Device "intel"
EndSection

Don't worry - this is an asymmetric medium and everyone responds whenever they want to or can smile
Also I don't face any problem, so I'm not in a hurry smile


Thanks, so, new day - new errors:

(EE) Screen(s) found, but none have a usable configuration.

Offline

#31 2022-08-03 06:11:38

seth
Member
Registered: 2012-09-03
Posts: 30,948

Re: Xorg crashes when using a discrete video card

[   201.844] (EE) Screen(s) found, but none have a usable configuration.
# results from previous
[   201.760] (WW) modeset(0): Unable to find connected outputs - setting 1024x768 initial framebuffer
[   201.760] (==) modeset(0): Using gamma correction (1.0, 1.0, 1.0)
[   201.760] (EE) modeset(0): No modes.
[   201.760] (II) UnloadModule: "modesetting"

The nvidia driver would have Option "AllowEmptyInitialConfiguration" for this, but I cannot find an enquivalent option for the other drivers

"DRI_PRIME=1 startx" will run the server on the intel chip but render all clients on the amd one, I'm less than sure that this is gonna be an improvement (certainly not for your battery life) but I'm not sure whether you can run the server on the AMD chip w/ this setup.
You can try to add a mode w/ a fake output, https://wiki.archlinux.org/title/Xrandr … esolutions - no idea whether that's gonna work.

Offline

#32 2022-08-03 06:51:52

TheTS
Member
Registered: 2022-08-02
Posts: 22

Re: Xorg crashes when using a discrete video card

seth wrote:
[   201.844] (EE) Screen(s) found, but none have a usable configuration.
# results from previous
[   201.760] (WW) modeset(0): Unable to find connected outputs - setting 1024x768 initial framebuffer
[   201.760] (==) modeset(0): Using gamma correction (1.0, 1.0, 1.0)
[   201.760] (EE) modeset(0): No modes.
[   201.760] (II) UnloadModule: "modesetting"

The nvidia driver would have Option "AllowEmptyInitialConfiguration" for this, but I cannot find an enquivalent option for the other drivers

"DRI_PRIME=1 startx" will run the server on the intel chip but render all clients on the amd one, I'm less than sure that this is gonna be an improvement (certainly not for your battery life) but I'm not sure whether you can run the server on the AMD chip w/ this setup.
You can try to add a mode w/ a fake output, https://wiki.archlinux.org/title/Xrandr … esolutions - no idea whether that's gonna work.

I'm sorry, I don't know anything about this at all. I don't understand how to do it. But it looks like a mode with a fake output?

Section "Monitor"
    Identifier "VGA1"
    Modeline "1920x1080_60.00"  109.00  1280 1368 1496 1712  1024 1027 1034 1063 -hsync +vsync
    Option "PreferredMode" "1920x1080_60.00"
EndSection

Section "Device"
     Identifier  "Device0"
     Driver      "amdgpu"
     BusID       "PCI:13:0:0"
EndSection

Section "Screen"
    Identifier    "Screen0"
    Device        "Device0"
    Monitor       "VGA1"
    DefaultDepth  24
    SubSection    "Display"
        Modes "1280x1024_60.00"
    EndSubSection
EndSection

Section "ServerLayout"
  Identifier     "X.org Configured"
  Screen         "Screen0"
EndSection

Last edited by TheTS (2022-08-03 07:22:02)

Offline

#33 2022-08-03 07:29:53

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 16,718

Re: Xorg crashes when using a discrete video card

I don't think this will generally work if you only mention the amdgpu device in the config. No matter how you slice it, your intel GPU has the display attached, you need to consider it and add it to the config in "some" form to have a chance of getting anything visible.

FWIW all these attempts directly go against the point of a PRIME like setup. What's your actual problem with dropping this config and using DRI_PRIME=1 on demand for the applications that need it?

Offline

#34 2022-08-03 08:32:26

TheTS
Member
Registered: 2022-08-02
Posts: 22

Re: Xorg crashes when using a discrete video card

V1del wrote:

I don't think this will generally work if you only mention the amdgpu device in the config. No matter how you slice it, your intel GPU has the display attached, you need to consider it and add it to the config in "some" form to have a chance of getting anything visible.

FWIW all these attempts directly go against the point of a PRIME like setup. What's your actual problem with dropping this config and using DRI_PRIME=1 on demand for the applications that need it?

The problem with using DRI_PRIME=1 is that I do it all to improve the overall stability and responsiveness of the system
Although it might be better to buy a new PC?

Offline

#35 2022-08-03 09:21:17

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 16,718

Re: Xorg crashes when using a discrete video card

What's your frame of reference? Performance for tasks that do not actually need the stronger GPU is generally going to be slower if you invoke the overhead of copying the image rendered by the amdgpu instead of doing them directly on the intel gpu. Why do you think your system is currently "unstable and slow" when running on the intel GPU for "normal usecases"? What are you doing exactly that you feel to be slow and that "might" get fixed by shoving everything to the amdgpu? Do these isolated cases actually benefit from DRI_PRIME=1 ?

FWIW looking at the specs this is ultimately an office low power laptop and you can generally not expect too much out of.

Last edited by V1del (2022-08-03 09:24:52)

Offline

#36 2022-08-03 09:30:12

TheTS
Member
Registered: 2022-08-02
Posts: 22

Re: Xorg crashes when using a discrete video card

V1del wrote:

What's your frame of reference?

FurMark Benchmark

Honestly, I was a little disappointed. Maybe it really doesn't help me at all. I think I should close the question.
Thank you V1del and seth, I am very grateful for your help

Offline

#37 2022-08-03 09:36:32

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 16,718

Re: Xorg crashes when using a discrete video card

Benchmarks do not make much/any statement over how something performs in a day to day usage. Chances that the benchmark will be slower if you went through with your plans are high. You should be able to see that you get better numbers with DRI_PRIME=1 for the benchmark in which case these logistics are working correctly.

Please don't use [CLOSED] mark as [SOLVED] or answered or so.

Last edited by V1del (2022-08-03 10:07:11)

Offline

#38 2022-08-03 12:04:29

seth
Member
Registered: 2012-09-03
Posts: 30,948

Re: Xorg crashes when using a discrete video card

FurMark Benchmark

That would be the usecase for prime, you run the desktop on the IGP and when you need more performance (for a game) invoke the GPU.

That being said, according to (random google)
https://gpu.userbenchmark.com/Compare/I … 0vsm329613
https://technical.city/de/video/Radeon- … phics-5500

The AMD chip seems to have only 30% over the intel one, iow. adding the inevitable redirection overhead and it's borderline useless sad

Offline

Board footer

Powered by FluxBB