You are not logged in.

#1 2022-08-02 11:10:46

nphuracm
Member
From: China
Registered: 2022-07-16
Posts: 24

Disable the mouse-over glow on XFCE

Reason: I just want to make Xfce look more 'legacy'-ish

Any way to do this?

Last edited by nphuracm (2022-08-02 12:36:28)

Offline

#2 2022-08-02 19:43:56

toz
Member
Registered: 2011-10-28
Posts: 473

Re: Disable the mouse-over glow on XFCE

Where exactly are you seeing this mouse-over glow?

To disable the GTK3 mouse-over glow, try adding:

* {-gtk-icon-effect: none }

to ~/.config/gtk-3.0/gtk.css (create the file if it doesn't exist). Log out and back in again.

Offline

#3 2022-08-03 04:50:24

nphuracm
Member
From: China
Registered: 2022-07-16
Posts: 24

Re: Disable the mouse-over glow on XFCE

toz wrote:

Where exactly are you seeing this mouse-over glow?

To disable the GTK3 mouse-over glow, try adding:

* {-gtk-icon-effect: none }

to ~/.config/gtk-3.0/gtk.css (create the file if it doesn't exist). Log out and back in again.

This did not work.
I am mainly seeing this glow on the desktop, Thunar's icon view, and some panel items.

Offline

#4 2022-08-03 21:16:07

toz
Member
Registered: 2011-10-28
Posts: 473

Re: Disable the mouse-over glow on XFCE

Sorry, forgot the hover:

*:hover { -gtk-icon-effect: none; }

Restart the panel.

This will remove the glow from all of the panel buttons. However, it doesn't seem to affect iconview elements (such as the ones in thunar iconview and desktop icons). I'm not sure how to affect those - I wonder if its baked into gtk.

Last edited by toz (2022-08-03 21:17:51)

Offline

Board footer

Powered by FluxBB