You are not logged in.

#1 2022-07-31 10:02:46

annebright
Member
Registered: 2022-07-06
Posts: 6

Package signature error when running pacstrap

In installation iso envrionment run the command "pacstrap /mnt base linux e2fsprogs grub lvm2 efibootmgr networkmanager nano man-db man-pages texinfo openssh", get the following error:

error: libcap: signature from "David Runge <dvzrv@archlinux.org>" is marginal trust
:: File /mnt/var/cache/pacman/pkg/libcap-2.65-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: failed to commit transaction (invalid or corrupted package)
Errors occurred, no packages were upgraded.
==> ERROR: Failed to install packages to new root

The full output is:

==> Creating install root at /mnt
==> Installing packages to /mnt
:: Synchronizing package databases...
 core                                  157.3 KiB  59.5 KiB/s 00:03 [#####################################] 100%
 extra                                1711.7 KiB  1214 KiB/s 00:01 [#####################################] 100%
 community                               6.7 MiB  3.60 MiB/s 00:02 [#####################################] 100%
resolving dependencies...
:: There are 3 providers available for initramfs:
:: Repository core
   1) mkinitcpio
:: Repository extra
   2) booster  3) dracut

Enter a number (default=1):
looking for conflicting packages...

Packages (155) acl-2.3.1-2  archlinux-keyring-20220727-1  argon2-20190702-4  attr-2.5.1-2  audit-3.0.8-1
               bash-5.1.016-1  binutils-2.38-6  bluez-libs-5.64-2  brotli-1.0.9-8  bzip2-1.0.8-4
               ca-certificates-20210603-1  ca-certificates-mozilla-3.81-1  ca-certificates-utils-20210603-1
               coreutils-9.1-1  cryptsetup-2.5.0-1  curl-7.84.0-2  db-5.3.28-5  dbus-1.14.0-1
               device-mapper-2.03.16-1  diffutils-3.8-1  dnssec-anchors-20190629-3  efivar-38-2  expat-2.4.8-1
               file-5.42-1  filesystem-2021.12.07-1  findutils-4.9.0-1  gawk-5.1.1-1  gcc-libs-12.1.0-3
               gdbm-1.23-1  gettext-0.21-2  glib2-2.72.3-1  glibc-2.35-6  gmp-6.2.1-2  gnupg-2.2.36-1
               gnutls-3.7.6-1  gpgme-1.17.1-1  gpm-1.20.7.r38.ge82d1a6-4  grep-3.7-1  groff-1.22.4-7
               gzip-1.12-1  hwdata-0.361-1  iana-etc-20220603-1  icu-71.1-1  iproute2-5.18.0-1
               iptables-1:1.8.8-1  iputils-20211215-1  jansson-2.14-2  json-c-0.16-1  kbd-2.5.1-1
               keyutils-1.6.3-1  kmod-30-1  krb5-1.19.3-3  ldns-1.8.1-1  less-1:590-1  libaio-0.3.113-1
               libarchive-3.6.1-1  libassuan-2.5.5-1  libbpf-0.8.1-1  libcap-2.65-1  libcap-ng-0.8.3-1
               libdaemon-0.14-5  libedit-20210910_3.1-1  libelf-0.187-1  libevent-2.1.12-1  libffi-3.4.2-5
               libgcrypt-1.10.1-1  libgpg-error-1.45-2  libidn2-2.3.3-1  libksba-1.6.0-1  libldap-2.6.3-1
               libmm-glib-1.18.10-2  libmnl-1.0.5-1  libndp-1.8-1  libnetfilter_conntrack-1.0.9-1
               libnewt-0.52.21-8  libnfnetlink-1.0.2-1  libnftnl-1.2.2-1  libnghttp2-1.48.0-1  libnl-3.7.0-1
               libnm-1.38.2-2  libp11-kit-0.24.1-1  libpcap-1.10.1-2  libpgm-5.3.128-2  libpipeline-1.5.6-1
               libpsl-0.21.1-1  libsasl-2.1.28-1  libseccomp-2.5.4-1  libsecret-0.20.5-2  libsodium-1.0.18-2
               libssh2-1.10.0-1  libsysprof-capture-3.44.0-1  libtasn1-4.18.0-1  libteam-1.31-5
               libtirpc-1.3.2-1  libunistring-1.0-1  libverto-0.3.2-4  libxcrypt-4.4.28-2  libxml2-2.9.14-1
               licenses-20220125-1  linux-api-headers-5.17.5-2  lz4-1:1.9.3-2  mkinitcpio-31-3
               mkinitcpio-busybox-1.35.0-1  mobile-broadband-provider-info-20220725-1  mpfr-4.1.0.p13-2
               ncurses-6.3-3  nettle-3.8-1  npth-1.6-3  nspr-4.34-1  nss-3.81-1  openssl-1.1.1.q-1
               p11-kit-0.24.1-1  pacman-6.0.1-7  pacman-mirrorlist-20220724-1  pam-1.5.2-1  pambase-20211210-1
               pciutils-3.8.0-2  pcre-8.45-1  pcre2-10.40-1  perl-5.36.0-1  pinentry-1.2.0-1  popt-1.18-3
               procps-ng-3.3.17-1  psmisc-23.5-1  readline-8.1.002-1  sed-4.8-1  shadow-4.11.1-1
               slang-2.3.2-2  sqlite-3.39.1-1  systemd-251.3-1  systemd-libs-251.3-1
               systemd-sysvcompat-251.3-1  tar-1.34-1  thin-provisioning-tools-0.9.0-1  tpm2-tss-3.2.0-1
               tzdata-2022a-1  util-linux-2.38-1  util-linux-libs-2.38-1  wpa_supplicant-2:2.10-4  xz-5.2.5-3
               zeromq-4.3.4-2  zlib-1:1.2.12-2  zstd-1.5.2-7  base-3-1  e2fsprogs-1.46.5-4  efibootmgr-18-1
               grub-2:2.06.r261.g2f4430cc0-1  linux-5.18.15.arch1-1  lvm2-2.03.16-1  man-db-2.10.2-1
               man-pages-5.13-1  nano-6.3-1  networkmanager-1.38.2-2  openssh-9.0p1-1  texinfo-6.8-2

Total Download Size:   351.54 MiB
Total Installed Size:  886.86 MiB

:: Proceed with installation? [Y/n]
:: Retrieving packages...
 linux-5.18.15.arch1-1-x86_64          176.1 MiB  6.23 MiB/s 00:28 [#####################################] 100%
 gcc-libs-12.1.0-3-x86_64               33.9 MiB  6.89 MiB/s 00:05 [#####################################] 100%
 perl-5.36.0-1-x86_64                   15.6 MiB  6.05 MiB/s 00:03 [#####################################] 100%
 icu-71.1-1-x86_64                      10.8 MiB  5.36 MiB/s 00:02 [#####################################] 100%
 glibc-2.35-6-x86_64                     9.9 MiB  4.82 MiB/s 00:02 [#####################################] 100%
 systemd-251.3-1-x86_64                  7.2 MiB  4.85 MiB/s 00:01 [#####################################] 100%
 grub-2:2.06.r261.g2f4430cc0-1-x86_64    6.8 MiB  3.62 MiB/s 00:02 [#####################################] 100%
 binutils-2.38-6-x86_64                  5.9 MiB  3.58 MiB/s 00:02 [#####################################] 100%
 man-pages-5.13-1-any                    5.9 MiB  3.16 MiB/s 00:02 [#####################################] 100%
 openssl-1.1.1.q-1-x86_64                3.6 MiB  2.68 MiB/s 00:01 [#####################################] 100%
 networkmanager-1.38.2-2-x86_64          3.5 MiB  2.20 MiB/s 00:02 [#####################################] 100%
 glib2-2.72.3-1-x86_64                   2.8 MiB  2.11 MiB/s 00:01 [#####################################] 100%
 gnutls-3.7.6-1-x86_64                   2.8 MiB  1934 KiB/s 00:01 [#####################################] 100%
 coreutils-9.1-1-x86_64                  2.6 MiB  1850 KiB/s 00:01 [#####################################] 100%
 util-linux-2.38-1-x86_64                2.4 MiB  1871 KiB/s 00:01 [#####################################] 100%
 gnupg-2.2.36-1-x86_64                   2.3 MiB  1803 KiB/s 00:01 [#####################################] 100%
 groff-1.22.4-7-x86_64                   2.2 MiB  1820 KiB/s 00:01 [#####################################] 100%
 lvm2-2.03.16-1-x86_64                1876.4 KiB  1581 KiB/s 00:01 [#####################################] 100%
 gettext-0.21-2-x86_64                1829.5 KiB  1715 KiB/s 00:01 [#####################################] 100%
 bash-5.1.016-1-x86_64                1667.7 KiB  1573 KiB/s 00:01 [#####################################] 100%
 wpa_supplicant-2:2.10-4-x86_64       1593.9 KiB  1504 KiB/s 00:01 [#####################################] 100%
 sqlite-3.39.1-1-x86_64               1586.5 KiB  1497 KiB/s 00:01 [#####################################] 100%
 nss-3.81-1-x86_64                    1579.4 KiB  1490 KiB/s 00:01 [#####################################] 100%
 texinfo-6.8-2-x86_64                 1418.4 KiB  1071 KiB/s 00:01 [#####################################] 100%
 libxml2-2.9.14-1-x86_64              1362.6 KiB  1285 KiB/s 00:01 [#####################################] 100%
 krb5-1.19.3-3-x86_64                 1272.0 KiB  1378 KiB/s 00:01 [#####################################] 100%
 kbd-2.5.1-1-x86_64                   1241.0 KiB  1345 KiB/s 00:01 [#####################################] 100%
 e2fsprogs-1.46.5-4-x86_64            1199.3 KiB  1492 KiB/s 00:01 [#####################################] 100%
 shadow-4.11.1-1-x86_64               1191.6 KiB  1490 KiB/s 00:01 [#####################################] 100%
 linux-api-headers-5.17.5-2-any       1187.5 KiB  1479 KiB/s 00:01 [#####################################] 100%
 gawk-5.1.1-1-x86_64                  1175.1 KiB  1469 KiB/s 00:01 [#####################################] 100%
 ncurses-6.3-3-x86_64                 1169.7 KiB  1481 KiB/s 00:01 [#####################################] 100%
 curl-7.84.0-2-x86_64                 1156.5 KiB  1458 KiB/s 00:01 [#####################################] 100%
 pcre2-10.40-1-x86_64                 1139.5 KiB  1435 KiB/s 00:01 [#####################################] 100%
 openssh-9.0p1-1-x86_64               1117.3 KiB  1660 KiB/s 00:01 [#####################################] 100%
 archlinux-keyring-20220727-1-any     1117.1 KiB  1414 KiB/s 00:01 [#####################################] 100%
 libnm-1.38.2-2-x86_64                1099.4 KiB  1399 KiB/s 00:01 [#####################################] 100%
 db-5.3.28-5-x86_64                   1098.0 KiB  1622 KiB/s 00:01 [#####################################] 100%
 iproute2-5.18.0-1-x86_64             1081.6 KiB  1605 KiB/s 00:01 [#####################################] 100%
 man-db-2.10.2-1-x86_64               1067.4 KiB  1577 KiB/s 00:01 [#####################################] 100%
 pcre-8.45-1-x86_64                    983.0 KiB  1483 KiB/s 00:01 [#####################################] 100%
 pacman-6.0.1-7-x86_64                 910.2 KiB  1152 KiB/s 00:01 [#####################################] 100%
 tpm2-tss-3.2.0-1-x86_64               838.3 KiB  1257 KiB/s 00:01 [#####################################] 100%
 tar-1.34-1-x86_64                     817.2 KiB  1209 KiB/s 00:01 [#####################################] 100%
 slang-2.3.2-2-x86_64                  759.5 KiB  1151 KiB/s 00:01 [#####################################] 100%
 libmm-glib-1.18.10-2-x86_64           710.8 KiB  1070 KiB/s 00:01 [#####################################] 100%
 cryptsetup-2.5.0-1-x86_64             666.3 KiB  1014 KiB/s 00:01 [#####################################] 100%
 libunistring-1.0-1-x86_64             662.0 KiB  1009 KiB/s 00:01 [#####################################] 100%
 zeromq-4.3.4-2-x86_64                 654.4 KiB   992 KiB/s 00:01 [#####################################] 100%
 systemd-libs-251.3-1-x86_64           631.0 KiB   962 KiB/s 00:01 [#####################################] 100%
 libgcrypt-1.10.1-1-x86_64             588.1 KiB   895 KiB/s 00:01 [#####################################] 100%
 nano-6.3-1-x86_64                     586.5 KiB   893 KiB/s 00:01 [#####################################] 100%
 pam-1.5.2-1-x86_64                    572.6 KiB   868 KiB/s 00:01 [#####################################] 100%
 libelf-0.187-1-x86_64                 536.1 KiB   812 KiB/s 00:01 [#####################################] 100%
 procps-ng-3.3.17-1-x86_64             516.6 KiB   791 KiB/s 00:01 [#####################################] 100%
 libarchive-3.6.1-1-x86_64             511.4 KiB   778 KiB/s 00:01 [#####################################] 100%
 thin-provisioning-tools-0.9.0-1-...   491.0 KiB   744 KiB/s 00:01 [#####################################] 100%
 hwdata-0.361-1-any                    475.7 KiB   724 KiB/s 00:01 [#####################################] 100%
 libp11-kit-0.24.1-1-x86_64            466.7 KiB   714 KiB/s 00:01 [#####################################] 100%
 brotli-1.0.9-8-x86_64                 462.8 KiB   706 KiB/s 00:01 [#####################################] 100%
 ldns-1.8.1-1-x86_64                   462.1 KiB   703 KiB/s 00:01 [#####################################] 100%
 findutils-4.9.0-1-x86_64              449.8 KiB   838 KiB/s 00:01 [#####################################] 100%
 nettle-3.8-1-x86_64                   443.1 KiB   836 KiB/s 00:01 [#####################################] 100%
 gpgme-1.17.1-1-x86_64                 441.1 KiB   832 KiB/s 00:01 [#####################################] 100%
 gmp-6.2.1-2-x86_64                    437.3 KiB   825 KiB/s 00:01 [#####################################] 100%
 iptables-1:1.8.8-1-x86_64             428.4 KiB   808 KiB/s 00:01 [#####################################] 100%
 libnl-3.7.0-1-x86_64                  409.0 KiB   772 KiB/s 00:01 [#####################################] 100%
 mpfr-4.1.0.p13-2-x86_64               404.9 KiB   760 KiB/s 00:01 [#####################################] 100%
 zstd-1.5.2-7-x86_64                   394.4 KiB   744 KiB/s 00:01 [#####################################] 100%
 tzdata-2022a-1-x86_64                 394.0 KiB   726 KiB/s 00:01 [#####################################] 100%
 iana-etc-20220603-1-any               394.0 KiB   603 KiB/s 00:01 [#####################################] 100%
 audit-3.0.8-1-x86_64                  383.4 KiB   685 KiB/s 00:01 [#####################################] 100%
 file-5.42-1-x86_64                    364.3 KiB   675 KiB/s 00:01 [#####################################] 100%
 diffutils-3.8-1-x86_64                363.1 KiB   556 KiB/s 00:01 [#####################################] 100%
 util-linux-libs-2.38-1-x86_64         360.4 KiB   636 KiB/s 00:01 [#####################################] 100%
 ca-certificates-mozilla-3.81-1-x...   358.9 KiB   677 KiB/s 00:01 [#####################################] 100%
 readline-8.1.002-1-x86_64             315.7 KiB   596 KiB/s 00:01 [#####################################] 100%
 dbus-1.14.0-1-x86_64                  305.3 KiB   576 KiB/s 00:01 [#####################################] 100%
 xz-5.2.5-3-x86_64                     301.1 KiB   568 KiB/s 00:01 [#####################################] 100%
 device-mapper-2.03.16-1-x86_64        297.0 KiB   565 KiB/s 00:01 [#####################################] 100%
 libldap-2.6.3-1-x86_64                281.0 KiB   524 KiB/s 00:01 [#####################################] 100%
 libpcap-1.10.1-2-x86_64               276.7 KiB   522 KiB/s 00:01 [#####################################] 100%
 mkinitcpio-busybox-1.35.0-1-x86_64    275.0 KiB   420 KiB/s 00:01 [#####################################] 100%
 libevent-2.1.12-1-x86_64              270.2 KiB   510 KiB/s 00:01 [#####################################] 100%
 gdbm-1.23-1-x86_64                    265.8 KiB   504 KiB/s 00:01 [#####################################] 100%
 grep-3.7-1-x86_64                     248.1 KiB   468 KiB/s 00:01 [#####################################] 100%
 libbpf-0.8.1-1-x86_64                 241.8 KiB   459 KiB/s 00:01 [#####################################] 100%
 libgpg-error-1.45-2-x86_64            241.6 KiB   456 KiB/s 00:01 [#####################################] 100%
 libteam-1.31-5-x86_64                 240.3 KiB   453 KiB/s 00:01 [#####################################] 100%
 sed-4.8-1-x86_64                      237.9 KiB   449 KiB/s 00:01 [#####################################] 100%
 libssh2-1.10.0-1-x86_64               213.4 KiB   408 KiB/s 00:01 [#####################################] 100%
 nspr-4.34-1-x86_64                    198.1 KiB   379 KiB/s 00:01 [#####################################] 100%
 libsecret-0.20.5-2-x86_64             191.9 KiB   364 KiB/s 00:01 [#####################################] 100%
 psmisc-23.5-1-x86_64                  190.9 KiB   362 KiB/s 00:01 [#####################################] 100%
 libpgm-5.3.128-2-x86_64               183.1 KiB   346 KiB/s 00:01 [#####################################] 100%
 libtirpc-1.3.2-1-x86_64               176.8 KiB   338 KiB/s 00:01 [#####################################] 100%
 libsodium-1.0.18-2-x86_64             175.0 KiB   334 KiB/s 00:01 [#####################################] 100%
 libsasl-2.1.28-1-x86_64               145.5 KiB   278 KiB/s 00:01 [#####################################] 100%
 efivar-38-2-x86_64                    145.5 KiB   276 KiB/s 00:01 [#####################################] 100%
 p11-kit-0.24.1-1-x86_64               140.5 KiB   268 KiB/s 00:01 [#####################################] 100%
 gpm-1.20.7.r38.ge82d1a6-4-x86_64      139.5 KiB   265 KiB/s 00:01 [#####################################] 100%
 libksba-1.6.0-1-x86_64                137.9 KiB   260 KiB/s 00:01 [#####################################] 100%
 libidn2-2.3.3-1-x86_64                135.8 KiB   260 KiB/s 00:01 [#####################################] 100%
 acl-2.3.1-2-x86_64                    135.7 KiB   256 KiB/s 00:01 [#####################################] 100%
 iputils-20211215-1-x86_64             134.3 KiB   255 KiB/s 00:01 [#####################################] 100%
 libtasn1-4.18.0-1-x86_64              126.6 KiB   239 KiB/s 00:01 [#####################################] 100%
 pinentry-1.2.0-1-x86_64               126.1 KiB   239 KiB/s 00:01 [#####################################] 100%
 lz4-1:1.9.3-2-x86_64                  120.2 KiB   229 KiB/s 00:01 [#####################################] 100%
 kmod-30-1-x86_64                      119.9 KiB   183 KiB/s 00:01 [#####################################] 100%
 expat-2.4.8-1-x86_64                  118.3 KiB   226 KiB/s 00:01 [#####################################] 100%
 less-1:590-1-x86_64                   115.1 KiB   220 KiB/s 00:01 [#####################################] 100%
 libedit-20210910_3.1-1-x86_64         110.0 KiB   210 KiB/s 00:01 [#####################################] 100%
 libassuan-2.5.5-1-x86_64              106.6 KiB   204 KiB/s 00:01 [#####################################] 100%
 pciutils-3.8.0-2-x86_64               103.1 KiB   197 KiB/s 00:01 [#####################################] 100%
 keyutils-1.6.3-1-x86_64               102.1 KiB   195 KiB/s 00:01 [#####################################] 100%
 libnghttp2-1.48.0-1-x86_64             95.1 KiB   182 KiB/s 00:01 [#####################################] 100%
 libnewt-0.52.21-8-x86_64               92.4 KiB   176 KiB/s 00:01 [#####################################] 100%
 bluez-libs-5.64-2-x86_64               92.2 KiB   141 KiB/s 00:01 [#####################################] 100%
 zlib-1:1.2.12-2-x86_64                 90.4 KiB   171 KiB/s 00:01 [#####################################] 100%
 libseccomp-2.5.4-1-x86_64              88.1 KiB   134 KiB/s 00:01 [#####################################] 100%
 libxcrypt-4.4.28-2-x86_64              84.0 KiB   159 KiB/s 00:01 [#####################################] 100%
 libcap-2.65-1-x86_64                   83.6 KiB   127 KiB/s 00:01 [#####################################] 100%
 gzip-1.12-1-x86_64                     79.6 KiB   151 KiB/s 00:01 [#####################################] 100%
 libpsl-0.21.1-1-x86_64                 79.6 KiB   121 KiB/s 00:01 [#####################################] 100%
 popt-1.18-3-x86_64                     70.6 KiB   135 KiB/s 00:01 [#####################################] 100%
 licenses-20220125-1-any                69.0 KiB   105 KiB/s 00:01 [#####################################] 100%
 libnftnl-1.2.2-1-x86_64                68.8 KiB   105 KiB/s 00:01 [#####################################] 100%
 attr-2.5.1-2-x86_64                    67.5 KiB   102 KiB/s 00:01 [#####################################] 100%
 mobile-broadband-provider-info-2...    63.0 KiB   119 KiB/s 00:01 [#####################################] 100%
 bzip2-1.0.8-4-x86_64                   57.2 KiB   109 KiB/s 00:01 [#####################################] 100%
 json-c-0.16-1-x86_64                   54.6 KiB   104 KiB/s 00:01 [#####################################] 100%
 jansson-2.14-2-x86_64                  51.7 KiB  98.9 KiB/s 00:01 [#####################################] 100%
 libnetfilter_conntrack-1.0.9-1-x...    49.0 KiB  92.4 KiB/s 00:01 [#####################################] 100%
 libsysprof-capture-3.44.0-1-x86_64     45.2 KiB  85.9 KiB/s 00:01 [#####################################] 100%
 libffi-3.4.2-5-x86_64                  45.1 KiB  68.7 KiB/s 00:01 [#####################################] 100%
 mkinitcpio-31-3-any                    44.6 KiB  67.5 KiB/s 00:01 [#####################################] 100%
 libcap-ng-0.8.3-1-x86_64               41.6 KiB  79.0 KiB/s 00:01 [#####################################] 100%
 libpipeline-1.5.6-1-x86_64             33.5 KiB  64.1 KiB/s 00:01 [#####################################] 100%
 argon2-20190702-4-x86_64               32.4 KiB  57.6 KiB/s 00:01 [#####################################] 100%
 efibootmgr-18-1-x86_64                 29.9 KiB  56.6 KiB/s 00:01 [#####################################] 100%
 npth-1.6-3-x86_64                      24.5 KiB  46.8 KiB/s 00:01 [#####################################] 100%
 libaio-0.3.113-1-x86_64                23.6 KiB  44.9 KiB/s 00:01 [#####################################] 100%
 libndp-1.8-1-x86_64                    19.2 KiB  36.7 KiB/s 00:01 [#####################################] 100%
 libdaemon-0.14-5-x86_64                19.2 KiB  36.7 KiB/s 00:01 [#####################################] 100%
 libverto-0.3.2-4-x86_64                18.4 KiB  35.2 KiB/s 00:01 [#####################################] 100%
 libnfnetlink-1.0.2-1-x86_64            17.1 KiB  31.3 KiB/s 00:01 [#####################################] 100%
 filesystem-2021.12.07-1-x86_64         14.5 KiB  27.5 KiB/s 00:01 [#####################################] 100%
 libmnl-1.0.5-1-x86_64                  11.2 KiB  28.8 KiB/s 00:00 [#####################################] 100%
 ca-certificates-utils-20210603-1-any    8.2 KiB  21.1 KiB/s 00:00 [#####################################] 100%
 pacman-mirrorlist-20220724-1-any        7.6 KiB  14.7 KiB/s 00:01 [#####################################] 100%
 systemd-sysvcompat-251.3-1-x86_64       5.7 KiB  14.5 KiB/s 00:00 [#####################################] 100%
 pambase-20211210-1-any                  3.1 KiB  7.55 KiB/s 00:00 [#####################################] 100%
 dnssec-anchors-20190629-3-any           3.0 KiB  7.68 KiB/s 00:00 [#####################################] 100%
 base-3-1-any                            2.2 KiB  5.72 KiB/s 00:00 [#####################################] 100%
 ca-certificates-20210603-1-any       2028.0   B  4.88 KiB/s 00:00 [#####################################] 100%
 Total (155/155)                       351.5 MiB  1760 KiB/s 03:24 [#####################################] 100%
(155/155) checking keys in keyring                                 [#####################################] 100%
downloading required keys...
:: Import PGP key 139B09DA5BF0D338, "David Runge <dvzrv@archlinux.org>"? [Y/n]
(155/155) checking package integrity                               [#####################################] 100%
error: libcap: signature from "David Runge <dvzrv@archlinux.org>" is marginal trust
:: File /mnt/var/cache/pacman/pkg/libcap-2.65-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: failed to commit transaction (invalid or corrupted package)
Errors occurred, no packages were upgraded.
==> ERROR: Failed to install packages to new root

How to fix the errors?

Last edited by annebright (2022-08-01 08:59:21)

Offline

#2 2022-07-31 10:10:39

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 10,837
Website

Re: Package signature error when running pacstrap

Please edit your post to use code tags around terminal output.

https://wiki.archlinux.org/title/Genera … s_and_code

Also, see https://wiki.archlinux.org/title/Pacman … ure_errors


Sakura:-
Mobo: MSI MEG B550 UNIFY // Processor: AMD Ryzen 9 5950X @4.9GHz // GFX: AMD Radeon RX 5700 XT // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 6x 1TB SSD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

#3 2022-07-31 10:46:17

daenney
Member
Registered: 2020-05-23
Posts: 2

Re: Package signature error when running pacstrap

I've just run into the same issue. Whichever mirror I try I get the

error: libcap: signature from "David Runge <dvzrv@archlinux.org>" is marginal trust
:: File /var/cache/pacman/pkg/libcap-2.65-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).

It's not a system clock issue. Resetting the keys doesn't work either:

:: Retrieving packages...
 libcap-2.65-1-x86_64   83.6 KiB   449 KiB/s 00:00 [######################] 100%
(41/41) checking keys in keyring                   [######################] 100%
downloading required keys...
:: Import PGP key 139B09DA5BF0D338, "David Runge <dvzrv@archlinux.org>"? [Y/n] 
(41/41) checking package integrity                 [######################] 100%
error: libcap: signature from "David Runge <dvzrv@archlinux.org>" is marginal trust
:: File /var/cache/pacman/pkg/libcap-2.65-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).

I got it fixed by

pacman -Sy archlinux-keyring

first. It seems in archlinux-keyring from the 27th of July contains whatever extra is needed to validate the libcap signature from the package of the 26th of July.

Offline

#4 2022-07-31 21:45:26

rek2
Member
Registered: 2015-02-12
Posts: 28

Re: Package signature error when running pacstrap

I am getting the same error but I am building my kvm/qemu images of Arch with packer and adding that package to be installed does not solve my problem… Any other idea? how can we reach out to libcap manteiner?

Offline

#5 2022-07-31 22:33:05

Scimmia
Fellow
Registered: 2012-09-01
Posts: 9,433

Re: Package signature error when running pacstrap

There's nothing to reach out to the libcap maintainer about. The problem is that your keyring isn't up to date, simple as that.

Offline

#6 2022-07-31 22:38:12

rek2
Member
Registered: 2015-02-12
Posts: 28

Re: Package signature error when running pacstrap

@Scimmial well then obviously something is **wrong** because is a fresh installed on a KVM/Qemu image

: Repository core
    qemu.archlinux:    1) archlinux-keyring  2) autoconf  3) automake  4) binutils  5) bison  6) fakeroot  7) file  8) findutils  9) flex  10) gawk  11) gcc  12) gettext  13) grep  14) groff  15) gzip  16) libtool  17) m4  18) make  19) pacman  20) patch  21) pkgconf  22) sed  23) sudo  24) texinfo  25) which
    qemu.archlinux:
    qemu.archlinux: Enter a selection (default=all):

then 1 m later in the base installation:

   qemu.archlinux: checking package integrity...
==> qemu.archlinux: error: libcap: signature from "David Runge <dvzrv@archlinux.org>" is marginal trust
==> qemu.archlinux: error: failed to commit transaction (invalid or corrupted package)
    qemu.archlinux: :: File /mnt/var/cache/pacman/pkg/libcap-2.65-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
    qemu.archlinux: Do you want to delete it? [Y/n]
    qemu.archlinux: Errors occurred, no packages were upgraded.
==> qemu.archlinux: ==> ERROR: Failed to install packages to new root
==> qemu.archlinux: Provisioning step had errors: Running the cleanup provisioner, if present...
==> qemu.archlinux: Deleting output directory...
Build 'qemu.archlinux' errored after 3 minutes 8 seconds: Script exited with non-zero exit status: 1. Allowed exit codes are: [0]

As you can see, the key ring is freshly downloaded and installed along with the core dev tools

Last edited by rek2 (2022-07-31 22:56:22)

Offline

#7 2022-07-31 22:49:57

Scimmia
Fellow
Registered: 2012-09-01
Posts: 9,433

Re: Package signature error when running pacstrap

Because, as has been explained, they keyring is too old and you have to update it.

Offline

#8 2022-07-31 22:57:16

rek2
Member
Registered: 2015-02-12
Posts: 28

Re: Package signature error when running pacstrap

I just told you I am pulling the LATEST package… "pacman -Sy archlinux-keyring" if upstream is not updated, there is nothing I can do. Such why contact the package maintainer to update the key in the keyring.

Last edited by rek2 (2022-07-31 22:58:49)

Offline

#9 2022-07-31 22:59:57

Scimmia
Fellow
Registered: 2012-09-01
Posts: 9,433

Re: Package signature error when running pacstrap

Except the error is happening when trying to *install* all of those things listed, including the keyring. You have to do it first.

Offline

#10 2022-07-31 23:05:26

rek2
Member
Registered: 2015-02-12
Posts: 28

Re: Package signature error when running pacstrap

ok I will try instead to update the actual livecd before I chroot and when I do the base linux install before the others see if that helps, I will update if it works

Last edited by rek2 (2022-07-31 23:07:38)

Offline

#11 2022-07-31 23:34:07

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 18,641

Re: Package signature error when running pacstrap

rek2 wrote:

ok I will try instead to update the actual livecd before I chroot and when I do the base linux install before the others see if that helps, I will update if it works

Huh?  How old is your install media?  Or do you mean you are going download the latest iso and rebuild your install media?


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

#12 2022-08-01 10:33:44

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 10,250

Re: Package signature error when running pacstrap

qemu.archlinux is not an archlinux package or group, are you using the guided installer ?


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.
Did you use the guided installer ? If yes, I can't help you.

(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Offline

#13 2022-08-01 17:16:57

rek2
Member
Registered: 2015-02-12
Posts: 28

Re: Package signature error when running pacstrap

@ewaller: is the one from July 1st the August 1st one I am waiting for it to hit the mirrors, should be at any moment, will try then. https://mirror.rackspace.com/archlinux/iso/
@Lone_Wolf: if you read better, you see I am using packer to create a Qemu/KVM image of arch GNU/linux. If curious: https://git.sr.ht/~rek2/rek2Hacklab/tre … em/builder

Last edited by rek2 (2022-08-01 17:19:13)

Offline

#14 2022-08-02 09:32:23

auyoq
Member
From: Switzerland
Registered: 2019-10-09
Posts: 4

Re: Package signature error when running pacstrap

I was running into the same issue and could only get around it by disabling all signature checking for the installation medium: https://wiki.archlinux.org/title/Pacman … e_checking

Offline

#15 2022-08-03 21:13:30

gschwarz
Member
Registered: 2022-08-03
Posts: 1

Re: Package signature error when running pacstrap

This is definitely a bug/inconsistency. I just installed Archlinux on a fresh VM using the ISO image obtained from the Magnet Link found at https://archlinux.org/download/.
I don't think it can be much more official than that.
I followed the procedure provided at https://wiki.archlinux.org/title/Installation_guide
pacstrap /mnt base linux linux-firmware led to the error.
Issuing pacman -Sy archlinux-keyring prior to that fixed the issue.

Offline

#16 2022-08-04 11:00:52

MarkZackie
Member
Registered: 2022-08-04
Posts: 1

Re: Package signature error when running pacstrap

Same here, using the latest bootstrap image, when initializing pacman keyring:
https://wiki.archlinux.org/title/Instal … an_keyring

bootstrap image used: https://archmirror.it/repos/iso/2022.07 … _64.tar.gz

Offline

#17 2022-08-05 08:28:34

lT-Tl
Member
Registered: 2022-08-05
Posts: 1

Re: Package signature error when running pacstrap

you should update the keyring

pacman -Syy

pacman -S archlinux-keyring

Offline

#18 2022-08-05 12:17:50

nl6720
Wiki Admin
Registered: 2016-07-02
Posts: 372

Re: Package signature error when running pacstrap

lT-Tl wrote:

pacman -Syy

pacman -S archlinux-keyring

No need to over-complicate it, just use:

pacman -Sy --needed archlinux-keyring

Also the 2022.08.05 release is out which has archlinux-keyring 20220727-1, so everything should work now (until archlinux-keyring in the repos gets updated again).

Last edited by nl6720 (2022-08-08 04:51:58)

Offline

#19 2022-08-05 15:49:58

wopfel
Member
Registered: 2013-11-13
Posts: 16

Re: Package signature error when running pacstrap

nl6720 wrote:

Also the 2022.08.05 release is out which has archlinux-keyring 20220727-1, so everything should work now (until archlinux-keyring in the repos gets updated again).

Hi,
I've tried the current 2022.08.05 ISO, but running pacstrap fails with some "error: key ... could not be imported" messages and finally "required key missing from keyring".

Reading "everything should work now" I assumed there's no need to run pacman -Sy archlinux-keyring right before pacstrap.

Please let me know if you need further information about this. I just thought I quickly let you know my findings so far.

Offline

#20 2022-08-05 15:52:00

Scimmia
Fellow
Registered: 2012-09-01
Posts: 9,433

Re: Package signature error when running pacstrap

"some" is not a specific error. That image has the latest keyring already, so there's no way you would get that error or reinstalling the keyring would do anything.

Offline

#21 2022-08-06 11:25:40

wopfel
Member
Registered: 2013-11-13
Posts: 16

Re: Package signature error when running pacstrap

Scimmia wrote:

"some" is not a specific error. That image has the latest keyring already, so there's no way you would get that error or reinstalling the keyring would do anything.

Thanks for confirming that the keyring is the latest version.

Here is the output of the pacstrap command (installing inside a VM).

root@archiso ~ # pacstrap /mnt base linux
==> Creating install root at /mnt
==> Installing packages to /mnt
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
resolving dependencies...
:: There are 3 providers available for initramfs:
:: Repository core
   1) mkinitcpio
:: Repository extra
   2) booster  3) dracut

Enter a number (default=1):
looking for conflicting packages...

Packages (119) acl-2.3.1-2  archlinux-keyring-20220727-1  argon2-20190702-4  attr-2.5.1-2
               audit-3.0.8-1  bash-5.1.016-1  binutils-2.38-7  brotli-1.0.9-8  bzip2-1.0.8-4
               ca-certificates-20210603-1  ca-certificates-mozilla-3.81-1
               ca-certificates-utils-20210603-1  coreutils-9.1-1  cryptsetup-2.5.0-1  curl-7.84.0-2
               dbus-1.14.0-1  device-mapper-2.03.16-1  diffutils-3.8-1  e2fsprogs-1.46.5-4
               expat-2.4.8-1  file-5.42-1  filesystem-2021.12.07-1  findutils-4.9.0-1  gawk-5.1.1-1
               gcc-libs-12.1.1-4  gdbm-1.23-1  gettext-0.21-2  glib2-2.72.3-1  glibc-2.36-1
               gmp-6.2.1-2  gnupg-2.2.36-1  gnutls-3.7.6-1  gpgme-1.17.1-1  grep-3.7-1  gzip-1.12-1
               hwdata-0.361-1  iana-etc-20220603-1  icu-71.1-1  iproute2-5.19.0-1
               iptables-1:1.8.8-2  iputils-20211215-1  json-c-0.16-1  kbd-2.5.1-1  keyutils-1.6.3-1
               kmod-30-1  krb5-1.19.3-3  less-1:590-1  libarchive-3.6.1-2  libassuan-2.5.5-1
               libbpf-0.8.1-1  libcap-2.65-1  libcap-ng-0.8.3-1  libelf-0.187-2  libevent-2.1.12-1
               libffi-3.4.2-5  libgcrypt-1.10.1-1  libgpg-error-1.45-2  libidn2-2.3.3-1
               libksba-1.6.0-1  libldap-2.6.3-1  libmnl-1.0.5-1  libnetfilter_conntrack-1.0.9-1
               libnfnetlink-1.0.2-1  libnftnl-1.2.2-1  libnghttp2-1.48.0-1  libnl-3.7.0-1
               libp11-kit-0.24.1-1  libpcap-1.10.1-2  libpsl-0.21.1-1  libsasl-2.1.28-1
               libseccomp-2.5.4-1  libsecret-0.20.5-2  libssh2-1.10.0-1
               libsysprof-capture-3.44.0-2  libtasn1-4.18.0-1  libtirpc-1.3.2-1  libunistring-1.0-1
               libverto-0.3.2-4  libxcrypt-4.4.28-2  libxml2-2.9.14-1  licenses-20220125-1
               linux-api-headers-5.18.15-1  lz4-1:1.9.3-2  mkinitcpio-31-3
               mkinitcpio-busybox-1.35.0-1  mpfr-4.1.0.p13-3  ncurses-6.3-3  nettle-3.8-1
               npth-1.6-3  openssl-1.1.1.q-1  p11-kit-0.24.1-1  pacman-6.0.1-7
               pacman-mirrorlist-20220724-1  pam-1.5.2-1  pambase-20211210-1  pciutils-3.8.0-2
               pcre-8.45-1  pcre2-10.40-1  pinentry-1.2.0-1  popt-1.18-3  procps-ng-3.3.17-1
               psmisc-23.5-1  readline-8.1.002-1  sed-4.8-1  shadow-4.11.1-1  sqlite-3.39.1-1
               systemd-251.3-1  systemd-libs-251.3-1  systemd-sysvcompat-251.3-1  tar-1.34-1
               tpm2-tss-3.2.0-1  tzdata-2022a-1  util-linux-2.38-1  util-linux-libs-2.38-1
               xz-5.2.5-3  zlib-1:1.2.12-2  zstd-1.5.2-7  base-3-1  linux-5.18.16.arch1-1

Total Installed Size:  683.72 MiB

:: Proceed with installation? [Y/n]
(119/119) checking keys in keyring                           [################################] 100%
downloading required keys...
:: Import PGP key C06086337C50773E, "Jelle van der Waa <jelle@archlinux.org>"? [Y/n]
error: key "Jelle van der Waa <jelle@vdwaa.nl>" could not be imported
:: Import PGP key 4A1AFC345EBE18F8, "Sébastien Luttringer <seblu@seblu.net>"? [Y/n]
error: key "Sébastien Luttringer <seblu@seblu.net>" could not be imported
:: Import PGP key 94657AB20F2A092B, "Andreas Radke <andyrtr@archlinux.org>"? [Y/n]
error: key "Andreas Radke <andyrtr@archlinux.org>" could not be imported
:: Import PGP key 7258734B41C31549, "David Runge <dvzrv@archlinux.org>"? [Y/n]
error: key "David Runge <dvzrv@archlinux.org>" could not be imported
:: Import PGP key 786C63F330D7CB92, "Felix Yan <felixonmars@archlinux.org>"? [Y/n]
error: key "Felix Yan <felixonmars@archlinux.org>" could not be imported
:: Import PGP key 7A4E76095D8A52E4, "Antonio Rojas <arojas@archlinux.org>"? [Y/n]
error: key "Antonio Rojas <arojas@archlinux.org>" could not be imported
:: Import PGP key 771DF6627EDF681F, "Tobias Powalowski <tpowa@archlinux.org>"? [Y/n]
error: key "Tobias Powalowski <tobias.powalowski@googlemail.com>" could not be imported
:: Import PGP key B02854ED753E0F1F, "Anatol Pomozov <anatol.pomozov@gmail.com>"? [Y/n]
error: key "Anatol Pomozov <anatol.pomozov@gmail.com>" could not be imported
:: Import PGP key 3B94A80E50A477C7, "Jan Alexander Steffens (heftig) <heftig@archlinux.org>"? [Y/n]
error: key "Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>" could not be imported
:: Import PGP key FC1B547C8D8172C8, "Levente Polyak <anthraxx@archlinux.org>"? [Y/n]
error: key "Levente Polyak (anthraxx) <levente@leventepolyak.net>" could not be imported
:: Import PGP key 139B09DA5BF0D338, "David Runge <dvzrv@archlinux.org>"? [Y/n]
error: key "David Runge <dvzrv@archlinux.org>" could not be imported
:: Import PGP key 51E8B148A9999C34, "Evangelos Foutras <foutrelis@archlinux.org>"? [Y/n]
error: key "Evangelos Foutras <evangelos@foutrelis.com>" could not be imported
:: Import PGP key 7F2D434B9741E8AC, "Pierre Schmitz <pierre@archlinux.de>"? [Y/n]
error: key "Pierre Schmitz <pierre@archlinux.de>" could not be imported
:: Import PGP key F99FFE0FEAE999BD, "Allan McRae <allan@archlinux.org>"? [Y/n]
error: key "Allan McRae <me@allanmcrae.com>" could not be imported
:: Import PGP key 686B063AC4BC0EC9, "Jonas Witschel <diabonas@archlinux.org>"? [Y/n]
error: key "Jonas Witschel <jonas.witschel@diabonas.de>" could not be imported
:: Import PGP key 6D1655C14CE1C13E, "Florian Pritz <bluewind@xinu.at>"? [Y/n]
error: key "Florian Pritz <bluewind@xinu.at>" could not be imported
:: Import PGP key F22FB1D78A77AEAB, "Giancarlo Razzolini <grazzolini@archlinux.org>"? [Y/n]
error: key "Giancarlo Razzolini (grazzolini) <grazzolini@archlinux.org>" could not be imported
error: required key missing from keyring
error: failed to commit transaction (unexpected error)
Errors occurred, no packages were upgraded.
==> ERROR: Failed to install packages to new root
pacstrap /mnt base linux  5.82s user 4.68s system 55% cpu 18.824 total

Offline

#22 2022-08-06 12:27:04

Scimmia
Fellow
Registered: 2012-09-01
Posts: 9,433

Re: Package signature error when running pacstrap

What does uname -a give you?

Offline

#23 2022-08-06 13:34:59

wopfel
Member
Registered: 2013-11-13
Posts: 16

Re: Package signature error when running pacstrap

uname -a output:

Linux archiso 5.18.16-arch1-1 #1 SMP PREEMPT_DYNAMIC Wed, 03 Aug 2022 11:25:04 +0000 x86_64 GNU/Linux

/proc/cmdline reports current ISO (excerpt): archisolabel=ARCH_202208

Offline

#24 2022-08-06 13:43:20

Scimmia
Fellow
Registered: 2012-09-01
Posts: 9,433

Re: Package signature error when running pacstrap

You're not just getting errors for new keys, which is what this thread was about, you're getting errors for all keys. Something has gone wrong with pacman-init.service. What does the journal say about it?

Offline

#25 2022-08-06 13:57:27

wopfel
Member
Registered: 2013-11-13
Posts: 16

Re: Package signature error when running pacstrap

Scimmia wrote:

You're not just getting errors for new keys, which is what this thread was about, you're getting errors for all keys. Something has gone wrong with pacman-init.service. What does the journal say about it?

Oh, I'm sorry. I thought it would be best to directly reply to your message about the new ISO. My fault, I thought it might be the same cause. Too late for a separate thread?

root@archiso ~ # systemctl status pacman-init.service
× pacman-init.service - Initializes Pacman keyring
     Loaded: loaded (/etc/systemd/system/pacman-init.service; enabled; preset: disabled)
     Active: failed (Result: exit-code) since Sat 2022-08-06 10:35:42 UTC; 2h 53min ago
    Process: 250 ExecStart=/usr/bin/pacman-key --init (code=exited, status=0/SUCCESS)
    Process: 421 ExecStart=/usr/bin/pacman-key --populate (code=exited, status=1/FAILURE)
   Main PID: 421 (code=exited, status=1/FAILURE)
        CPU: 3min 51.902s

Aug 06 10:35:42 archiso pacman-key[1104]: gpg: marginals needed: 3  completes needed: 1  trust mode>
Aug 06 10:35:42 archiso pacman-key[1104]: gpg: [don't know]: invalid packet (ctb=00)
Aug 06 10:35:42 archiso pacman-key[1104]: gpg: keyring_get_keyblock: read error: Invalid packet
Aug 06 10:35:42 archiso pacman-key[1104]: gpg: keydb_get_keyblock failed: Invalid keyring
Aug 06 10:35:42 archiso pacman-key[1104]: gpg: validate_key_list failed
Aug 06 10:35:42 archiso pacman-key[421]: ==> ERROR: Trust database could not be updated.
Aug 06 10:35:42 archiso systemd[1]: pacman-init.service: Main process exited, code=exited, status=1>
Aug 06 10:35:42 archiso systemd[1]: pacman-init.service: Failed with result 'exit-code'.
Aug 06 10:35:42 archiso systemd[1]: Failed to start Initializes Pacman keyring.
Aug 06 10:35:42 archiso systemd[1]: pacman-init.service: Consumed 3min 51.902s CPU time.

Output of journalctl is very long:

Aug 06 10:29:42 archiso systemd[1]: Starting Initializes Pacman keyring...
Aug 06 10:29:46 archiso pacman-key[283]: gpg: /etc/pacman.d/gnupg/trustdb.gpg: trustdb created
Aug 06 10:29:46 archiso pacman-key[283]: gpg: no ultimately trusted keys found
Aug 06 10:29:49 archiso pacman-key[362]: gpg: starting migration from earlier GnuPG versions
Aug 06 10:29:49 archiso pacman-key[362]: gpg: porting secret keys from '/etc/pacman.d/gnupg/secring.gpg' to gpg-agent
Aug 06 10:29:49 archiso pacman-key[362]: gpg: migration succeeded
Aug 06 10:29:50 archiso pacman-key[250]: ==> Generating pacman master key. This may take some time.
Aug 06 10:29:50 archiso pacman-key[382]: gpg: Generating pacman keyring master key...
Aug 06 10:30:04 archiso pacman-key[382]: gpg: directory '/etc/pacman.d/gnupg/openpgp-revocs.d' created
Aug 06 10:30:04 archiso pacman-key[382]: gpg: revocation certificate stored as '/etc/pacman.d/gnupg/openpgp-revocs.d/CA7F84D37149D1EB20E5C0C7B>
Aug 06 10:30:04 archiso pacman-key[382]: gpg: Done
Aug 06 10:30:04 archiso pacman-key[250]: ==> Updating trust database...
Aug 06 10:30:04 archiso pacman-key[420]: gpg: marginals needed: 3  completes needed: 1  trust model: pgp
Aug 06 10:30:04 archiso pacman-key[420]: gpg: depth: 0  valid:   1  signed:   0  trust: 0-, 0q, 0n, 0m, 0f, 1u
Aug 06 10:30:05 archiso pacman-key[421]: ==> Appending keys from archlinux.gpg...
Aug 06 10:30:36 archiso pacman-key[421]: ==> Locally signing trusted keys in keyring...
Aug 06 10:30:59 archiso pacman-key[421]:   -> Locally signed 6 keys.
Aug 06 10:31:00 archiso pacman-key[421]: ==> Importing owner trust values...
Aug 06 10:31:00 archiso pacman-key[634]: gpg: setting ownertrust to 4
Aug 06 10:31:00 archiso pacman-key[634]: gpg: setting ownertrust to 4
Aug 06 10:31:00 archiso pacman-key[634]: gpg: setting ownertrust to 4
Aug 06 10:31:00 archiso pacman-key[634]: gpg: setting ownertrust to 4
Aug 06 10:31:00 archiso pacman-key[634]: gpg: inserting ownertrust of 4
Aug 06 10:31:00 archiso pacman-key[634]: gpg: setting ownertrust to 4
Aug 06 10:31:00 archiso pacman-key[421]: ==> Disabling revoked keys in keyring...
Aug 06 10:35:42 archiso pacman-key[421]:   -> Disabled 51 keys.
Aug 06 10:35:42 archiso pacman-key[421]: ==> Updating trust database...
Aug 06 10:35:42 archiso pacman-key[1104]: gpg: [don't know]: invalid packet (ctb=00)
Aug 06 10:35:42 archiso pacman-key[1104]: gpg: keydb_search failed: Invalid packet
...
Aug 06 10:35:42 archiso pacman-key[1104]: gpg: keyring_get_keyblock: read error: Invalid packet
Aug 06 10:35:42 archiso pacman-key[1104]: gpg: keyring_get_keyblock failed: Invalid keyring
Aug 06 10:35:42 archiso pacman-key[1104]: gpg: failed to rebuild keyring cache: Invalid keyring
Aug 06 10:35:42 archiso pacman-key[1104]: gpg: marginals needed: 3  completes needed: 1  trust model: pgp
Aug 06 10:35:42 archiso pacman-key[1104]: gpg: [don't know]: invalid packet (ctb=00)
Aug 06 10:35:42 archiso pacman-key[1104]: gpg: keyring_get_keyblock: read error: Invalid packet
Aug 06 10:35:42 archiso pacman-key[1104]: gpg: keydb_get_keyblock failed: Invalid keyring
Aug 06 10:35:42 archiso pacman-key[1104]: gpg: validate_key_list failed
Aug 06 10:35:42 archiso pacman-key[421]: ==> ERROR: Trust database could not be updated.
Aug 06 10:35:42 archiso systemd[1]: pacman-init.service: Main process exited, code=exited, status=1/FAILURE
Aug 06 10:35:42 archiso systemd[1]: pacman-init.service: Failed with result 'exit-code'.
Aug 06 10:35:42 archiso systemd[1]: Failed to start Initializes Pacman keyring.
Aug 06 10:35:42 archiso systemd[1]: pacman-init.service: Consumed 3min 51.902s CPU time.

Restarting the service fails too.

Offline

Board footer

Powered by FluxBB