You are not logged in.

#1 2022-08-24 02:30:34

ectospasm
Member
Registered: 2015-08-28
Posts: 119

[SOLVED] Packager not displaying properly

SOLVED:  This is in /etc/makepkg.conf.  I wouldn't have thought to look there.

When I go to the AUR package I've submitted, it shows my nick as the Maintainer and Last Packager.  However, when I search for the installed package in pacman/pikaur, I get the following results:

Name            : asterisk-lts-18
Version         : 18.14.0-1
Description     : A complete open source PBX toolkit - Long Term Support release 18
Architecture    : x86_64
URL             : https://www.asterisk.org
Licenses        : GPL
Groups          : None
Provides        : asterisk=18.14.0
Depends On      : alsa-lib  curl  gsm  imap  jansson  libedit  libsrtp  libvorbis  libxml2  libvpx  libx11  libxslt  lua53  opus  popt  postgresql-libs
                  python  speex
Optional Deps   : dahdi
                  libpri
                  libss7
                  openr2
                  postgresql
                  sqlite3 [installed]
                  unixodbc
Required By     : None
Optional For    : None
Conflicts With  : asterisk
Replaces        : None
Installed Size  : 42.40 MiB
Packager        : Unknown Packager
Build Date      : Thu 18 Aug 2022 08:48:16 PM EDT
Install Date    : Thu 18 Aug 2022 08:49:44 PM EDT
Install Reason  : Explicitly installed
Install Script  : No
Validated By    : None

My concern is the "Packager    :Unknown Packager".  I did install this via the makepkg -srf in my PKGBUILD source directory, and then pikaur -U asterisk-lts-18-18.14.0-1-x86_64.pkg.tar.zst (I use pikaur as my AUR helper, and I believe it's a drop-in replacement for pacman).  Is this a problem with my Git config, or do I need to enable something on the AUR website?  I've seen other packages that list the full name of the package maintainer and/or packager, so I'm just curious as to why mine says "Uknown Packager".

Last edited by ectospasm (2022-08-24 03:24:37)

Offline

#2 2022-08-24 02:32:21

Scimmia
Fellow
Registered: 2012-09-01
Posts: 9,555

Re: [SOLVED] Packager not displaying properly

You set the packager in makepkg.conf.

Offline

#3 2022-08-24 03:25:12

ectospasm
Member
Registered: 2015-08-28
Posts: 119

Re: [SOLVED] Packager not displaying properly

Scimmia wrote:

You set the packager in makepkg.conf.

OK, thanks!  I wouldn't have thought to look there.

Offline

Board footer

Powered by FluxBB