You are not logged in.

#1 2022-09-03 14:41:50

keen4e
Member
Registered: 2022-09-03
Posts: 1

How to prevent Systemd to look for swap partitions on a dual boot?

I have the following situation on one of my disks:

/dev/sdc1-sdc5 contain stuff relevant to my encrypted linux Mint with /dev/sdc5 being an encrypted swap partition.

On /dev/sdc6 I have a very minimalist Arch that is not crypted and has almost nothing on it so I don't need a swap for it. My fstab is very simple and only contains instructions on how to mount the root partition. For some reason however when my arch linux starts and before I can login systemd detects the encrypted swap on /dev/sdc5 and asks me for a decryption passphrase.

How can I prevent this behavior and simply boot the Arch without a swap?

EDIT:
After reading a bit more on it, lot of people seem to be fairly insistent on having swap space, so I gave the system a swap file and it stopped that asking me to mount the encrypted partition.

Still though, in case I didn't want to do that, would it be possible to just force my system to run without swap?

Last edited by keen4e (2022-09-03 15:28:37)

Offline

#2 2022-09-03 19:38:43

loqs
Member
Registered: 2014-03-06
Posts: 15,331

Re: How to prevent Systemd to look for swap partitions on a dual boot?

Was it being mounted using GPT_partition_automounting?

Offline

#3 2022-09-04 11:05:56

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 10,408

Re: How to prevent Systemd to look for swap partitions on a dual boot?

https://man.archlinux.org/man/systemd-gpt-auto-generator.8 wrote:

All swap partitions located on the disk the root partition is located on are enabled.

This generator it started by default, but it can be disabled.


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.


(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Offline

Board footer

Powered by FluxBB