You are not logged in.

#1 2022-09-04 14:27:25

Rommy
Member
Registered: 2014-10-17
Posts: 46

[SOLVED] Pipewire does not save internal mic boost

Hello,

when I start my laptop, the internal mic boost is set to 20db gain. This results into my voice sounding weird.
When I start alsamixer and reduce the internal mic boost to 0db, everything is fine.
This is kinda annoying, is there a way so pipewire will save/set the internal mic boost to 0db?

Thanks

Last edited by Rommy (2022-09-05 23:03:21)

Offline

#2 2022-09-05 14:57:36

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 17,664

Re: [SOLVED] Pipewire does not save internal mic boost

Pipewire does normally not adjust mic boosts so this is only up to ALSA state, try running

sudo alsactl store

with the boost disabled and check whether it still reenables on reboot.

Offline

#3 2022-09-05 23:11:54

Rommy
Member
Registered: 2014-10-17
Posts: 46

Re: [SOLVED] Pipewire does not save internal mic boost

@V1del
Thank you very much! After alsactl store executed by alsa-restore.service and a new boot, the boost is set to 0.
When I restart pipewire and pipewire-pulse, the mic boost is set again to 20db.

systemctl --user restart pipewire.service pipewire-pulse.service

Since I usually dont restart pipewire manually, it is okay for me to adjust the boost after the restart and then save it again via alsactl.

Offline

#4 2022-09-15 23:18:55

Rommy
Member
Registered: 2014-10-17
Posts: 46

Re: [SOLVED] Pipewire does not save internal mic boost

Since the problem was also still there sometimes (after switching tty or suspend), I used alsamixer to disable the boost, then looked at the volume for the mic with pactl list sinks and then used pactl set-source-volume to set the volume of the mic again. Now pipewire remembered the volume.

Offline

Board footer

Powered by FluxBB