You are not logged in.

#1 2022-09-04 21:48:23

leomeinel
Member
Registered: 2022-08-01
Posts: 17

[SOLVED] GRUB doesn't boot after unlocking encrypted root partition

Hello everybody,

I am currently setting up an install script that has 2 encrypted partitions.

When I reboot after running setup.sh I can decrypt the boot partition and the efi partition is read correctly. After that I can enter the passphrase for the root partition. It manages to decrypt but won't boot after doing so.

When setting loglevel=5 as kernel parameter I get this output:

Kernel not booting after decrypting

It uses this partition layout:
partition_layout

It uses btrfs and LUKS2 encryption for the boot partition and the efi partition. I am using grub-improved-luks2-git to achieve this.
Other unofficial packages I am using are: cryptboot.
I didn't yet come to implement cryptboot or sign any keys so that should definetly not be the issue.
I am almost certain that GRUB isn't the issue aswell since I managed to boot without a seperate boot partition using LUKS2 and the same GRUB.

I think the easiest way to link my setup is just linking the scripts.
I of course understand that you probably aren't interested in reading everything but I am not sure where the issue actually is.
I might add code here that explains my setup later if no one can give me an answer by then.

Encrypted boot partition (having this issue)
Encrypted /boot on the root partition (working)
Unencrypted boot partition (working)

More info on this issue and how I came to my current setup

I should probably add that I am currently trying this in a VM since I don't have a spare computer to try this on.
I am also using the official linux-zen kernel. On other kernels the behaviour is the same.

If anyone has experienced this before, has a solution or notices that something is wrong with my approach, please let me know!
I'd greatly appreciate any help with this since I am pretty new to encrypted installs and don't really have a lot of experience.

Thanks in advance for your time smile

Last edited by leomeinel (2022-09-05 15:08:22)

Offline

#2 2022-09-05 15:08:08

leomeinel
Member
Registered: 2022-08-01
Posts: 17

Re: [SOLVED] GRUB doesn't boot after unlocking encrypted root partition

I solved the issue.
I had /dev/mapper/md0_crypt not set to noauto in /etc/crypttab.

Offline

Board footer

Powered by FluxBB