You are not logged in.

#1 2022-09-04 14:17:25

m6556
Banned
Registered: 2022-09-04
Posts: 1

Grub boots in rescue mode after update

Hi,
I updated grub yersterday and I read about the intervention on the Arch Linux site and the pacman output. After mounting the efi partition to /boot/EFI, I executed the two commands as stated. I did not saw any errors during the process. However, after rebooting, I get the error message

error: symbol `grub_debug_malloc` not found.

and grub enters into the rescue mode after that. After some research, I found out that the issue might be related to os-prober. However, I am inexperienced how the grub rescue mode shell works. Hence, my attempts to fix this issue by myself were unsuccessful.

Offline

#2 2022-09-04 17:21:56

trumpetrespas
Member
Registered: 2022-08-29
Posts: 14

Re: Grub boots in rescue mode after update

In my experience the EFI directory is in /boot/esp. Maybe try re-installing grub while mounting  the EFI partition to that directory.

Last edited by trumpetrespas (2022-09-04 17:23:11)

Offline

#3 2022-09-04 18:47:25

Scimmia
Fellow
Registered: 2012-09-01
Posts: 9,555

Re: Grub boots in rescue mode after update

The EFI directory is wherever you mount it. I have never, ever heard of someone using /boot/esp.

Online

#4 2022-09-04 19:09:41

trumpetrespas
Member
Registered: 2022-08-29
Posts: 14

Re: Grub boots in rescue mode after update

Oh... looks like my weird mount point was due to me not reading the wiki correctly, I missed the line that said "Mount the EFI system partition and in the remainder of this section, substitute esp with its mount point." I just ran the commands and so I ended up mounting my Efi stuff on /boot/esp (which does work perfectly fine).

Offline

#5 2022-09-04 20:27:43

Akas
Member
From: Germany
Registered: 2020-08-02
Posts: 13

Re: Grub boots in rescue mode after update

Hi,
I am the OP. Sorry, for making another account. I could not access my keepass storage as my daily driver was affected by this issue.
I successfully managed to boot to the OS by changing the boot order in UEFI. For some strange reason, the first entry was comprised of the same character which I could not identify. I would describe them as a stacked wave if someone has a clue about this issue. The second entry was named "arch" and I placed that entry to the first position. This solved my issue for now.
I assume that the former first boot entry is a corrupted GRUB. Is it possible to remove this corrupted version?

Offline

#6 2022-09-05 15:15:40

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 17,032

Re: Grub boots in rescue mode after update

Look at the -d option of efibootmgr.

I'l lock the secondary account you've created to ask for help with this, in general we do not allow secondary accounts.

Last edited by V1del (2022-09-05 15:39:29)

Offline

#7 2022-09-08 14:30:23

millus
Member
Registered: 2019-07-21
Posts: 122

Re: Grub boots in rescue mode after update

Hi, I have the same problem but no working solution.
Actually at first I made another thread when the grub update bricked my desktop pc, but that will have to wait because meanwhile I made the mistake of restarting my laptop (after having executed the non-working/vague instructions on archlinux.org for reinstalling grub) bricking it too, just even worse, now I must fix it first.

Laptop info:
BIOS is set (and always was) to non-fastboot and non-secure boot, it's an Asus UX330CA. One SATA SSD sda in it, boot partition sda1 and luks volume sda2 which contains a swap partition and a partition with the rest (/ and /home).
(There is also a /dev/sda5 partition which I don't use.)
I got the latest arch iso and booted from USB stick (which is then /dev/sdb), then the usual

#cryptsetup luksOpen /dev/sda2 myvol
#mount /dev/volume/archlinux /mnt
#mount /dev/sda1 /mnt/boot
#arch-chroot /mnt

Trying to reinstall grub for non-EFI failed like this, warnings and an error that I never got before:

#grub-install --target=i386-pc /dev/sda
Installing for i386-pc platform.
grub-install: warning: this GPT partition label contains mo BIOS Boot Partition; embedding won't be possible.
grub-install: warning: Embedding is not possible.  GRUB can only be installed in this setup by using blocklists.  However, blocklists are UNRELIABLE and their use discouraged--
grub-install: error: will not proceed with blocklists.

Now I was pretty sure this was a non-EFI system but since this error happened I thought maybe I remembered wrong, so I tried EFI install next (the boot partition sda1 at the same time has the EFI folder, contents are also listed in the BIOS actually) :

#grub-install --target=x86_64-efi --efi-directory=/boot/EFI
Installing for x86_64-efi platform.
Installation finished. No error reported.
#grub-mkconfig -o /boot/grub/grub.cfg
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-linux+
Found initrd image: /boot/intel-ucode.img /boot/initramfs-linux.img
Found fallback initrd image(s) in /boot:  intel-ucode.img initramfs-linux-fallback.img
Warning: os-prober will be executed to detect other bootable partitions.
Its output will be used to detect bootable binaries on them and create new boot entries.
grub-probe: error: cannot find a GRUB drive for /dev/sdb1.   Check your device.map.
Found Ubuntu 17.04 (17.04) on /dev/sda5
Adding boot menu entry for UEFI Firmware Settings ...
done

The "finished + no error reported" messages looked good, but on reboot instead of my usual grub menu I just get

                              Welcome to GRUB!
error: symbol `grub_debug_malloc' not found.
Entering rescue mode---
grub rescue> _

And that's it.

Offline

#8 2022-09-08 16:08:58

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 17,032

Re: Grub boots in rescue mode after update

Did you do that with the latest grub release 2:2.06.r322.gd9b4638c5-4 ? There was an actual bug with LVM and certain mainboards there that you need this particular release for. So chroot in update make sure you get the version I mentioned and reinstall GRUB again. FWIW from this progression it's more likely that your --efi-directory= should be /boot and not /boot/EFI (... you don't need to pass the EFI directory but the mount point of your ESP.

If that doesn't help, post

mount 
tree /boot

from the chroot.

Also you should generally not hijack solved posts and create your own threads for new issues.

Offline

#9 2022-09-08 16:34:35

millus
Member
Registered: 2019-07-21
Posts: 122

Re: Grub boots in rescue mode after update

V1del wrote:

FWIW from this progression it's more likely that your --efi-directory= should be /boot and not /boot/EFI

QQ  thanks, it works!

V1del wrote:

Also you should generally not hijack solved posts and create your own threads for new issues.

sowwy, same topic isn't same solution, of course..

Offline

Board footer

Powered by FluxBB