You are not logged in.

#1 2022-08-22 13:37:19

Scooby Doo
Member
Registered: 2022-05-04
Posts: 3

Wanted: Kodi 18.9 "Leia" package - unable to find anywhere.

Due to problems with kodi 19 "Matrix" with addons and custom builds, I would like to install a previous version of kodi. Namely kodi 18.9 'Leia'.
I have tried downgrading to version 18.9 but this brings issues and problems.
I have also tried building Leia from source, again yet more problems.

I am hoping someone has a link to  the arch kodi 18.9 Leia package and its dependencies.
If so, thank you.
David.

Last edited by Scooby Doo (2022-08-22 13:38:28)

Offline

#2 2022-08-22 18:00:36

TheSgtBilko
Member
Registered: 2013-08-13
Posts: 74

Re: Wanted: Kodi 18.9 "Leia" package - unable to find anywhere.

Reverting all dependencies to older version seems like trouble (for other applications depending on those dependencies)

Maybe go the other way around and solve the issues with "Matrix" addons. Many of the addons do not work well with python 3.10, which can be resolved by installing python 3.9 from aur (which will work fine alongside 3.10) and then start kodi with python 3.9 as preferred version.

Offline

#3 2022-08-23 14:37:12

Scooby Doo
Member
Registered: 2022-05-04
Posts: 3

Re: Wanted: Kodi 18.9 "Leia" package - unable to find anywhere.

@TheSgtBilko

"..and then start kodi with python 3.9 as preferred version"

Hate to sound like an idiot, but how is this done?
David.

Offline

#4 2022-08-23 19:17:16

TheSgtBilko
Member
Registered: 2013-08-13
Posts: 74

Re: Wanted: Kodi 18.9 "Leia" package - unable to find anywhere.

I was lazy and in a hurry. I'm sure there are other better ways.

Installed python39 from aur
Created a folder in my home named: mybin
Created links in mybin pointing to relevant py3.9 files:

ln -s /usr/bin/python3.9 ~/mybin/python
ln -s /usr/bin/python3.9 ~/mybin/python3
ln -s /usr/bin/python3.9-config ~/mybin/python-config
ln -s /usr/bin/python3.9-config ~/mybin/python3-config

Created a start script for kodi where I export mybin folder at the beginning of $PATH, then start kodi (alternatively you could probably change kodi.desktop):

export PATH=~/mybin:$PATH
/usr/bin/kodi

This way current python 3.10+ is used as normal for all applications except for kodi when starting kodi via the script.

Offline

#5 2022-08-25 14:43:45

Scooby Doo
Member
Registered: 2022-05-04
Posts: 3

Re: Wanted: Kodi 18.9 "Leia" package - unable to find anywhere.

@TheSgtBilko

Thanks.
David.

Last edited by Scooby Doo (2022-08-27 12:38:07)

Offline

#6 2022-09-14 20:32:07

piratebill
Member
From: Sol System
Registered: 2011-10-20
Posts: 128

Re: Wanted: Kodi 18.9 "Leia" package - unable to find anywhere.

You could always run Kodi Leia from docker. This way you don't have to downgrade any system packages

Looks like you can run

docker pull celedhrim/kodi-server:leia

Found on https://hub.docker.com/r/celedhrim/kodi-server/tags

Last edited by piratebill (2022-09-14 20:51:27)

Offline

Board footer

Powered by FluxBB