You are not logged in.

#1 2022-04-30 13:42:43

Xenfo
Member
From: Montreal
Registered: 2021-11-06
Posts: 12
Website

Failed to open extra directory of loaded image during boot

I've recently setup secure boot so I can dual boot Windows. I'm using sbctl with Grub 2 for secure boot. When I boot I get the error

Failed to open extra directory of loaded image: Invalid Parameter

but it still ends up booting. Is this something to worry about, and how do I fix it?

EFI bundle:

/boot/EFI/Linux/Arch-linux.efi
        Signed:         ✓ Signed
        ESP Location:   /boot
        Output:         └─/EFI/Linux/Arch-linux.efi
        EFI Stub Image:   └─/usr/lib/systemd/boot/efi/linuxx64.efi.stub
        Cmdline:            ├─/proc/cmdline
        OS Release:         ├─/usr/lib/os-release
        Kernel Image:       ├─/boot/vmlinuz-linux
        Initramfs Image:    └─/boot/initramfs-linux.img
        Intel Microcode:      └─/boot/intel-ucode.img

Grub config, 05_linux_signed:

#!/bin/sh
exec tail -n +3 $0

menuentry "Arch Linux (signed)" --class arch --class gnu-linux --class gnu --class os $menuentry_id_option 'arch-linux-signed' {
        load_video
        set gfxpayload=keep
        insmod gzio
        insmod part_gpt
        insmod fat
        insmod chain
        search --no-floppy --set=root --fs-uuid <UUID>
        echo    'Loading Linux linux ...'
        chainloader /EFI/Linux/Arch-linux.efi
}

Offline

#2 2022-09-18 16:23:11

bluscandth
Member
Registered: 2022-07-07
Posts: 7

Re: Failed to open extra directory of loaded image during boot

Did you ever solve this?

Offline

#3 2022-09-18 21:04:06

Xenfo
Member
From: Montreal
Registered: 2021-11-06
Posts: 12
Website

Re: Failed to open extra directory of loaded image during boot

Unfortunately no but I don’t think it’s anything important, I haven’t noticed anything wrong.

Offline

Board footer

Powered by FluxBB