You are not logged in.

#1 2022-09-22 23:07:28

Registered: 2021-12-15
Posts: 9

[SOLVED] No temperature directory located in /sys/class/thermal

I am using Waybar and the temperature module is failing because the /sys/class/thermal directory does not exist. I have gone ahead and run `sensors detect` and it does find the proper modules for my hardware. Additionally, the `sensors` command does accurately report temps across the board. For reference, I am using an Asus X570 board. I have also confirmed that proper modules are loaded with `lsmod`, including `nct6775` and `asus_ec_sensors` (the modules listed when running the sensors detect command.

What could be preventing the creation of this directory?


I could not find a solution regarding the missing directory for thermals. But the solution of using `hwmon` in the Waybar temperature module config did resolve the issue enough to give me a functional module again. Since that was my primary concern, I am marking this as solved.

Last edited by deltaQuadrantTux (2022-09-22 23:37:01)


Board footer

Powered by FluxBB