You are not logged in.

#1 2006-11-06 15:37:44

From: Australia
Registered: 2005-02-10
Posts: 138

Two kernels, an Audigy 4 and alsa.

First off, I have compiled two vanilla kernels. One with alsa, one without. The one without still has soundcore and was the first Kernel I used when everything seemed to be working fine.

I had installed alsa from source, from the alsaproject website. This included alsalib, alsadriver and alsautils. Sound was working great, with hardware mixing, games sounding better than ever and all seemed fine. Except for one thing. I could not for the life of me, record voice via the mic jack.

So I decided to uninstall the source compiled modules and drivers, only to install alsa packages with pacman. I followed the archwiki instructions, yet when I ran alsamixer:

23:12:18 ~$ alsamixer 

alsamixer: function snd_ctl_open failed for default: No such device
23:36:47 ~$ 

I googled didn't seem to find any solution. I searched this forum and same result.

Then out of desperation I made another kernel entry in grub, and compiled another kernel with ALSA compiled into the kernel. Ok fine now alsaconf picks up my sound card but still no sound. It even lets me set volume and play audio with aplay yet I hear nothing. My guess is that the alsa drivers in the kernel are older and therefore less compatible.

Anyone have any insight as to what could be wrong?

"The ecological crisis is a moral issue."


Board footer

Powered by FluxBB