You are not logged in.

#1 2022-10-27 14:48:32

lenovolobo933
Member
Registered: 2018-12-12
Posts: 57

[SOLVED]"signature is unknown trust" error when upgrading system

yay -Syu
warning: config file /etc/pacman.conf, line 34: directive 'TotalDownload' in section 'options' not recognized.
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
 archlinuxcn is up to date
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...

warning: insufficient columns available for table display
Packages (61) bluedevil-1:5.26.2-1  breeze-5.26.2-1  breeze-gtk-5.26.2-1  curl-7.86.0-1
              drkonqi-5.26.2-1  expat-2.5.0-1  jre-openjdk-headless-19.0.1.u10-3
              kactivitymanagerd-5.26.2-1  kde-cli-tools-5.26.2-1  kde-gtk-config-5.26.2-1
              kdecoration-5.26.2-1  kdeplasma-addons-5.26.2-1  kgamma5-5.26.2-1
              khotkeys-5.26.2-1  kinfocenter-5.26.2-1  kmenuedit-5.26.2-1
              kpipewire-5.26.2-1  kscreen-5.26.2-1  kscreenlocker-5.26.2-1
              ksshaskpass-5.26.2-1  ksystemstats-5.26.2-1  kwallet-pam-5.26.2-1
              kwayland-integration-5.26.2-1  kwin-5.26.2.1-1  kwrited-5.26.2-1
              layer-shell-qt-5.26.2-1  libkscreen-5.26.2-1  libksysguard-5.26.2-1
              libmbim-1.28.0-1  libqmi-1.32.0-1  linux-lts-5.15.75-1
              linux-lts-headers-5.15.75-1  milou-5.26.2-1  mkinitcpio-32-2
              oh-my-zsh-git-r6674.49691b58b3-1  oxygen-5.26.2-1  oxygen-sounds-5.26.2-1
              pacman-static-6.0.1-47  perl-http-message-6.41-1
              plasma-browser-integration-5.26.2-1  plasma-desktop-5.26.2-1
              plasma-disks-5.26.2-1  plasma-integration-5.26.2-1  plasma-nm-5.26.2-1
              plasma-pa-5.26.2-1  plasma-sdk-5.26.2-1  plasma-thunderbolt-5.26.2-1
              plasma-vault-5.26.2-1  plasma-workspace-5.26.2-1
              plasma-workspace-wallpapers-5.26.2-1  polkit-kde-agent-5.26.2-1
              powerdevil-5.26.2-1  qt5-script-5.15.11-1  qt5-webengine-5.15.11-1
              sddm-kcm-5.26.2-1  systemsettings-5.26.2-1  taglib-1.13-1  tracker3-3.4.1-1
              vim-9.0.0814-1  vim-runtime-9.0.0814-1  xdg-desktop-portal-kde-5.26.2-1

Total Download Size:      3.64 MiB
Total Installed Size:  1030.83 MiB
Net Upgrade Size:        27.57 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
 pacman-static-6.0.1-...     2.8 MiB  1803 KiB/s 00:02 [----------------------------] 100%
 oh-my-zsh-git-r6674....   826.6 KiB  2.69 MiB/s 00:00 [----------------------------] 100%
 Total (2/2)                 3.6 MiB  1614 KiB/s 00:02 [----------------------------] 100%
(61/61) checking keys in keyring                       [----------------------------] 100%
(61/61) checking package integrity                     [----------------------------] 100%
error: oh-my-zsh-git: signature from "lilac (build machine) <lilac@build.archlinuxcn.org>" is unknown trust
:: File /var/cache/pacman/pkg/oh-my-zsh-git-r6674.49691b58b3-1-any.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]

i have tried

sudo rm -R /etc/pacman.d/gnupg/
sudo rm -R /root/.gnupg/ 
sudo gpg --refresh-keys
sudo pacman-key --init 
sudo pacman-key --populate archlinux
sudo pacman-key --refresh-keys

Last edited by lenovolobo933 (2022-10-28 14:53:03)

Offline

#2 2022-10-27 15:01:39

d.ALT
Member
Registered: 2019-05-10
Posts: 327

Re: [SOLVED]"signature is unknown trust" error when upgrading system

lenovolobo933 wrote:
warning: insufficient columns available for table display

[...]

:: File /var/cache/pacman/pkg/oh-my-zsh-git-r6674.49691b58b3-1-any.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).

? Is this SteamDeck / SteamOS?


<49,17,III,I>    Fama di loro il mondo esser non lassa;
<50,17,III,I>    misericordia e giustizia li sdegna:
<51,17,III,I>    non ragioniam di lor, ma guarda e passa.

Offline

#3 2022-10-27 15:02:41

seth
Member
Registered: 2012-09-03
Posts: 33,338

Re: [SOLVED]"signature is unknown trust" error when upgrading system

error: oh-my-zsh-git: signature from "lilac (build machine) <lilac@build.archlinuxcn.org>" is unknown trust
:: File /var/cache/pacman/pkg/oh-my-zsh-git-r6674.49691b58b3-1-any.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]

The problem is archlinuxcn, install/update the archlinuxcn-keyring package, https://wiki.archlinux.org/title/Unoffi … rchlinuxcn

Offline

#4 2022-10-27 15:24:11

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 10,939
Website

Re: [SOLVED]"signature is unknown trust" error when upgrading system

Mod note:moving to AUR Issues


Sakura:-
Mobo: MSI MAG X570S TORPEDO MAX // Processor: AMD Ryzen 9 5950X @4.9GHz // GFX: AMD Radeon RX 5700 XT // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 6x 1TB SSD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

#5 2022-10-28 14:54:07

lenovolobo933
Member
Registered: 2018-12-12
Posts: 57

Re: [SOLVED]"signature is unknown trust" error when upgrading system

seth wrote:

The problem is archlinuxcn, install/update the archlinuxcn-keyring package, https://wiki.archlinux.org/title/Unoffi … rchlinuxcn

thanks, did the trick

Offline

Board footer

Powered by FluxBB