You are not logged in.

#1 2022-11-05 01:16:22

iestynapmwg
Member
Registered: 2021-09-27
Posts: 24

openssl upgrade removed 1.1, now dkms doesn't work

I ran a system upgrade this evening and ran into the following problem:
One of the first packages upgraded was openssl, which instead of updating openssl-1.1.1 to the latest 1.1.1s (i previously had 1.1.1q), actually replaced it with openssl-3.0.7. The problem comes when in the same upgrade, virtualbox-host-dkms is also updated  (7.0.2-1 -> 7.0.2-2). After that, the dkms-install.hook runs and i get errors:

==> dkms install --no-depmod vboxhost/7.0.2_OSE -k 5.19.13-zen1-1-zen
/usr/lib/modules/5.19.13-zen1-1-zen/build/scripts/sign-file: error while loading shared libraries: libcrypto.so.1.1: cannot open shared object file: No such file or directory
/usr/lib/modules/5.19.13-zen1-1-zen/build/scripts/sign-file: error while loading shared libraries: libcrypto.so.1.1: cannot open shared object file: No such file or directory
/usr/lib/modules/5.19.13-zen1-1-zen/build/scripts/sign-file: error while loading shared libraries: libcrypto.so.1.1: cannot open shared object file: No such file or directory

And, indeed:

$ ldd sign-file
	linux-vdso.so.1 (0x00007ffd9e994000)
	libcrypto.so.1.1 => not found
	libc.so.6 => /usr/lib/libc.so.6 (0x00007ff201f41000)
	/lib64/ld-linux-x86-64.so.2 => /usr/lib64/ld-linux-x86-64.so.2 (0x00007ff202165000)

Is this a packaging/dependency problem? Should i upgrade to something with newer dkms binaries or re-install openssl-1.1.1?

Offline

#2 2022-11-05 01:18:32

Scimmia
Fellow
Registered: 2012-09-01
Posts: 9,830

Re: openssl upgrade removed 1.1, now dkms doesn't work

Partial update problem. You're holding back some package, namely the kernel and headers, and they're no longer compatible with the rest of your system.

Partial updates are not supported for exactly this reason.

Offline

#3 2022-11-05 06:17:09

iestynapmwg
Member
Registered: 2021-09-27
Posts: 24

Re: openssl upgrade removed 1.1, now dkms doesn't work

Unfortunately, rolling back to a previous kernel is the only option until Nvidia releases a compatible driver in the 390-xx series.

To solve this particular problem in the mean time... Is there any problem installing openssl-1.1.1 alongside -3.0.7? Is there a "best practice" method of doing this that can be reverted once the video driver issue has been taken care of?

Thanks!

Offline

#4 2022-11-05 06:19:55

Scimmia
Fellow
Registered: 2012-09-01
Posts: 9,830

Re: openssl upgrade removed 1.1, now dkms doesn't work

It's not the only option. The -lts kernel exists for a reason.

Offline

#5 2022-11-05 09:40:21

mouseman
Member
From: Outta nowhere
Registered: 2014-04-04
Posts: 286

Re: openssl upgrade removed 1.1, now dkms doesn't work

I seem to have the same or similar issue with zfs. I am on lts with dkms for zfs from archzfs user repo.

linux-lts 5.15.77-1
linux-lts-headers 5.15.77-1

I checked my pacman.log there seem to be no issues, i am holding back one package because it upgrades itself, its called roonserver.

openssl was upgraded though:

[2022-11-05T09:59:10+0100] [ALPM] upgraded openssl (1.1.1.q-1 -> 3.0.7-2)

zfs and zpool commands throw the error

zfs: error while loading shared libraries: libcrypto.so.1.1: cannot open shared object file: No such file or directory

I've been checking zfs github issues and discussions but it doesn't seem to be mentioned there as of yet.

When I try a downgrade:

# pacman -U /var/cache/pacman/pkg/openssl-1.1.1.q-1-x86_64.pkg.tar.zst
loading packages...
warning: downgrading package openssl (3.0.7-2 => 1.1.1.q-1)
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing openssl (1.1.1.q-1) breaks dependency 'libcrypto.so=3-64' required by libarchive
:: installing openssl (1.1.1.q-1) breaks dependency 'libcrypto.so=3-64' required by sudo
:: installing openssl (1.1.1.q-1) breaks dependency 'libssl.so=3-64' required by sudo
:: installing openssl (1.1.1.q-1) breaks dependency 'libcrypto.so=3-64' required by systemd
:: installing openssl (1.1.1.q-1) breaks dependency 'libssl.so=3-64' required by systemd

I'm not sure how to proceed, any suggestions?

Last edited by mouseman (2022-11-05 09:43:26)

Offline

#6 2022-11-05 10:56:35

ugjka
Member
From: Latvia
Registered: 2014-04-01
Posts: 1,715
Website

Re: openssl upgrade removed 1.1, now dkms doesn't work

sudo pacman -S openssl-1.1 ?

Offline

#7 2022-11-05 11:33:34

a821
Member
Registered: 2012-10-31
Posts: 355

Re: openssl upgrade removed 1.1, now dkms doesn't work

mouseman wrote:

When I try a downgrade:

My guess is full downgrade using the ALA (Edit: previous comment was better )

Edit: Missed this part

mouseman wrote:

zfs and zpool commands throw the error...

These are AUR packages so i'st your responsibility; you need to recompile them with the new openssl.

Last edited by a821 (2022-11-05 11:46:42)

Offline

#8 2022-11-05 11:40:48

mouseman
Member
From: Outta nowhere
Registered: 2014-04-04
Posts: 286

Re: openssl upgrade removed 1.1, now dkms doesn't work

ugjka wrote:

sudo pacman -S openssl-1.1 ?

Cool, that works.

I didn't think of it because it got upgraded and replaced, I didnt think it would as simple as that.

Thanks.

Offline

#9 2022-11-05 13:33:12

Scimmia
Fellow
Registered: 2012-09-01
Posts: 9,830

Re: openssl upgrade removed 1.1, now dkms doesn't work

That's a workaround, not a fix. See a821's post, it's your responsibility to rebuild AUR packages when they need to be.

Offline

Board footer

Powered by FluxBB