You are not logged in.

#1 2003-02-08 19:49:44

Registered: 2002-12-01
Posts: 113

internet not working or just pacman?

when I try pacman -S 'name' he goes trough the list of servers incredibly fast, saying that he couldn't connect to them...

So I must conclude that internet is not working for me?

I tried ifconfig, and saw that only my localhost was up and running... Nevertheless rc.conf did have the correct values - I've setup a lot of distros so the problem shouldn't have been caused by something I did wrong...

In the installation he made me believe that kernel sources were installed but in the kernel source folder there were only a few .h files...
So I copied over my gentoo kernel to arch and booted it with thatone... now ifconfig did return my eth0 configuration and marked it as working...

However pacman still doesn't know how to access its servers... I've only installed the base system...

Any ideas?

Also am I the only one with the limited kernel that doesn't recognize my (realtec rtl8139) network card??


#2 2003-02-08 22:13:23

From: Middle of Canada
Registered: 2002-08-20
Posts: 2,975

Re: internet not working or just pacman?

hmm well it is rather hard to trouble shoot this with out a little more specific information.
such as:

1. you say rc.conf is "set properly" . But how can we be sure if you don't let us know your connection type and how you entered the data in rc.conf.

2. do you have the 8139too module loaded? in the kernel all ethernet cards are listed as modules and therefore require loading via modprobe or insmod, if you are already up or via modules.conf or rc.local at boot.

3. you did not give a very good idea of what ifconfig -a shows, such as does your ethx card show up? if it does what is it's status?

4. What limited kernel? the arch kernel is quite monolithic in nature actually. when i was working with build ing a kernel for my brief crux venture it took the better part of an hour to go through the config file for the arch kernel. And no the kernel source is not installed during an install. you can get it very easily post install or off of the disc if need be.

5. did you sync with the pacman servers first (pacman -Syu)?

Sorry but to really get at the root of the problem you just need to give a little more information

AKA uknowme

I am not your friend


#3 2003-02-09 19:01:43

Registered: 2002-12-01
Posts: 113

Re: internet not working or just pacman?

"<sarah31> well ask your question here then xirus
<sarah31> xirus?"

well... you were the reason I wanted to visit this (temporary down) site wink

I'm locally connected to a router, wich is connected with cable


eth0="eth0 netmask broadcast"
INTERFACES=(lo eth0)

gateway="default gw"

The manual didn't mention anything about doing anything that you had to load extra modules so I figured it would work from the beginning?

I'll boot in arch now and post this later

yes I did, it didn't respond, just gave a new prompt


#4 2003-02-09 19:11:26

From: Victoria, BC, Canada
Registered: 2002-08-12
Posts: 771

Re: internet not working or just pacman?

Arch servers were mostly inaccessible yesterday, as I had to rebuild a couple nameservers that we use.


#5 2003-02-09 20:02:17

Registered: 2002-12-01
Posts: 113

Re: internet not working or just pacman?

Ok, I've got internet working... seems like the dns server I used was down - in gentoo I've put a reserve dns in the resolv.conf file, that's why it WAS working here wink

(and to be honoust I also forgot to put alias eth0 8139too in the modules.conf file - that's why the default kernel would only show me my localhost connection)

thx for all the help though - arch has the nicest community there is imho


Board footer

Powered by FluxBB