You are not logged in.

#1 2022-11-11 17:10:29

mauropt78
Member
Registered: 2016-04-10
Posts: 19

[SOLVED] Alsa not working on new installation

Hello, I have no sound on new install,

 lspci -k
00:00.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) Root Complex
	Subsystem: ASUSTeK Computer Inc. Device 8747
00:00.2 IOMMU: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) I/O Memory Management Unit
	Subsystem: ASUSTeK Computer Inc. Device 8747
00:01.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-1fh) PCIe Dummy Host Bridge
00:01.1 PCI bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) PCIe GPP Bridge
	Subsystem: ASUSTeK Computer Inc. Device 8747
	Kernel driver in use: pcieport
00:01.3 PCI bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) PCIe GPP Bridge
	Subsystem: ASUSTeK Computer Inc. Device 8747
	Kernel driver in use: pcieport
00:02.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-1fh) PCIe Dummy Host Bridge
	DeviceName:  Onboard IGD
00:03.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-1fh) PCIe Dummy Host Bridge
00:03.1 PCI bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) PCIe GPP Bridge
	Subsystem: ASUSTeK Computer Inc. Device 8747
	Kernel driver in use: pcieport
00:03.4 PCI bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) PCIe GPP Bridge
	Subsystem: ASUSTeK Computer Inc. Device 8747
	Kernel driver in use: pcieport
00:04.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-1fh) PCIe Dummy Host Bridge
00:07.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-1fh) PCIe Dummy Host Bridge
00:07.1 PCI bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) Internal PCIe GPP Bridge 0 to Bus B
	Subsystem: ASUSTeK Computer Inc. Device 8747
	Kernel driver in use: pcieport
00:08.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-1fh) PCIe Dummy Host Bridge
00:08.1 PCI bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) Internal PCIe GPP Bridge 0 to Bus B
	Subsystem: ASUSTeK Computer Inc. Device 8747
	Kernel driver in use: pcieport
00:14.0 SMBus: Advanced Micro Devices, Inc. [AMD] FCH SMBus Controller (rev 59)
	Subsystem: ASUSTeK Computer Inc. Device 8747
	Kernel driver in use: piix4_smbus
	Kernel modules: i2c_piix4, sp5100_tco
00:14.3 ISA bridge: Advanced Micro Devices, Inc. [AMD] FCH LPC Bridge (rev 51)
	Subsystem: ASUSTeK Computer Inc. Device 8747
00:18.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) Data Fabric: Device 18h; Function 0
00:18.1 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) Data Fabric: Device 18h; Function 1
00:18.2 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) Data Fabric: Device 18h; Function 2
00:18.3 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) Data Fabric: Device 18h; Function 3
	Kernel driver in use: k10temp
	Kernel modules: k10temp
00:18.4 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) Data Fabric: Device 18h; Function 4
00:18.5 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) Data Fabric: Device 18h; Function 5
00:18.6 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) Data Fabric: Device 18h; Function 6
00:18.7 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) Data Fabric: Device 18h; Function 7
01:00.0 Non-Volatile memory controller: Phison Electronics Corporation E12 NVMe Controller (rev 01)
	Subsystem: Phison Electronics Corporation E12 NVMe Controller
	Kernel driver in use: nvme
	Kernel modules: nvme
02:00.0 USB controller: Advanced Micro Devices, Inc. [AMD] 400 Series Chipset USB 3.1 XHCI Controller (rev 01)
	Subsystem: ASMedia Technology Inc. Device 1142
	Kernel driver in use: xhci_hcd
	Kernel modules: xhci_pci
02:00.1 SATA controller: Advanced Micro Devices, Inc. [AMD] 400 Series Chipset SATA Controller (rev 01)
	Subsystem: ASMedia Technology Inc. Device 1062
	Kernel driver in use: ahci
02:00.2 PCI bridge: Advanced Micro Devices, Inc. [AMD] 400 Series Chipset PCIe Bridge (rev 01)
	Subsystem: ASMedia Technology Inc. Device 0201
	Kernel driver in use: pcieport
03:00.0 PCI bridge: Advanced Micro Devices, Inc. [AMD] 400 Series Chipset PCIe Port (rev 01)
	Subsystem: ASMedia Technology Inc. Device 3306
	Kernel driver in use: pcieport
03:01.0 PCI bridge: Advanced Micro Devices, Inc. [AMD] 400 Series Chipset PCIe Port (rev 01)
	Subsystem: ASMedia Technology Inc. Device 3306
	Kernel driver in use: pcieport
03:04.0 PCI bridge: Advanced Micro Devices, Inc. [AMD] 400 Series Chipset PCIe Port (rev 01)
	Subsystem: ASMedia Technology Inc. Device 3306
	Kernel driver in use: pcieport
03:06.0 PCI bridge: Advanced Micro Devices, Inc. [AMD] 400 Series Chipset PCIe Port (rev 01)
	Subsystem: ASMedia Technology Inc. Device 3306
	Kernel driver in use: pcieport
03:07.0 PCI bridge: Advanced Micro Devices, Inc. [AMD] 400 Series Chipset PCIe Port (rev 01)
	Subsystem: ASMedia Technology Inc. Device 3306
	Kernel driver in use: pcieport
04:00.0 Ethernet controller: Intel Corporation I211 Gigabit Network Connection (rev 03)
	Subsystem: ASUSTeK Computer Inc. Device 85f0
	Kernel driver in use: igb
	Kernel modules: igb
08:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8812AE 802.11ac PCIe Wireless Network Adapter (rev 01)
	Subsystem: Realtek Semiconductor Co., Ltd. Device 8203
	Kernel driver in use: rtl8821ae
	Kernel modules: rtl8821ae
09:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] (rev ef)
	Subsystem: ASUSTeK Computer Inc. Device 04c2
	Kernel driver in use: amdgpu
	Kernel modules: amdgpu
09:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
	Subsystem: ASUSTeK Computer Inc. Device aaf0
	Kernel driver in use: snd_hda_intel
	Kernel modules: snd_hda_intel
0a:00.0 Non-Volatile memory controller: Phison Electronics Corporation E12 NVMe Controller (rev 01)
	Subsystem: Phison Electronics Corporation E12 NVMe Controller
	Kernel driver in use: nvme
	Kernel modules: nvme
0b:00.0 Non-Essential Instrumentation [1300]: Advanced Micro Devices, Inc. [AMD] Zeppelin/Raven/Raven2 PCIe Dummy Function
	Subsystem: ASUSTeK Computer Inc. Device 8747
0b:00.2 Encryption controller: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) Platform Security Processor
	Subsystem: ASUSTeK Computer Inc. Device 8747
	Kernel driver in use: ccp
	Kernel modules: ccp
0b:00.3 USB controller: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) USB 3.0 Host Controller
	Subsystem: ASUSTeK Computer Inc. Device 8747
	Kernel driver in use: xhci_hcd
	Kernel modules: xhci_pci
0c:00.0 Non-Essential Instrumentation [1300]: Advanced Micro Devices, Inc. [AMD] Zeppelin/Renoir PCIe Dummy Function
	Subsystem: ASUSTeK Computer Inc. Device 8747
0c:00.2 SATA controller: Advanced Micro Devices, Inc. [AMD] FCH SATA Controller [AHCI mode] (rev 51)
	Subsystem: ASUSTeK Computer Inc. Device 8747
	Kernel driver in use: ahci
0c:00.3 Audio device: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) HD Audio Controller
	Subsystem: ASUSTeK Computer Inc. Device 8723
	Kernel driver in use: snd_hda_intel
	Kernel modules: snd_hda_intel

I see two audio devices here?
09:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
and
0c:00.3 Audio device: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) HD Audio Controller

My ~/.asoundrc:

defaults.ctl.card 0;
defaults.pcm.card 0;

speaker-test:

$ speaker-test

speaker-test 1.2.8

Playback device is default
Stream parameters are 48000Hz, S16_LE, 1 channels
Using 16 octaves of pink noise
ALSA lib pcm_dmix.c:999:(snd_pcm_dmix_open) unable to open slave
Playback open error: -2,No such file or directory

amixer:

$ amixer
Simple mixer control 'IEC958',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
Simple mixer control 'IEC958',1
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
Simple mixer control 'IEC958',2
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
Simple mixer control 'IEC958',3
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
Simple mixer control 'IEC958',4
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
Simple mixer control 'IEC958',5
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
$ aplay -L | grep :CARD
hdmi:CARD=HDMI,DEV=0
hdmi:CARD=HDMI,DEV=1
hdmi:CARD=HDMI,DEV=2
hdmi:CARD=HDMI,DEV=3
hdmi:CARD=HDMI,DEV=4
hdmi:CARD=HDMI,DEV=5
usbstream:CARD=HDMI
default:CARD=Generic
sysdefault:CARD=Generic
front:CARD=Generic,DEV=0
surround21:CARD=Generic,DEV=0
surround40:CARD=Generic,DEV=0
surround41:CARD=Generic,DEV=0
surround50:CARD=Generic,DEV=0
surround51:CARD=Generic,DEV=0
surround71:CARD=Generic,DEV=0
iec958:CARD=Generic,DEV=0
usbstream:CARD=Generic

Thanks,
Maurizio.

Last edited by mauropt78 (2022-11-14 10:03:04)

Offline

#2 2022-11-11 17:17:25

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 18,900

Re: [SOLVED] Alsa not working on new installation

You had posted this topic twice.  Assuming it was an error, I deleted the other thread.


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

#3 2022-11-11 17:44:03

mauropt78
Member
Registered: 2016-04-10
Posts: 19

Re: [SOLVED] Alsa not working on new installation

thanks, yes it was

Offline

#4 2022-11-13 19:30:42

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 10,516

Re: [SOLVED] Alsa not working on new installation

$ aplay -L | grep :CARD

That grep filters away very useful info, like which device alsa sees as the default card.
post full output of aplay -lL please.


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.


(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Offline

#5 2022-11-13 19:48:21

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 17,745

Re: [SOLVED] Alsa not working on new installation

From logistics of the output your actual card is at least on index 1, but yes post the full output, safe guess

speaker-test -Dhw:1,0 -c2

Offline

#6 2022-11-14 10:05:28

mauropt78
Member
Registered: 2016-04-10
Posts: 19

Re: [SOLVED] Alsa not working on new installation

Hi,
I changed my ~/.asoundrc to:

defaults.ctl.card 1;
defaults.pcm.card 1;

and it worked smile.

So many thanks for your help,
I marked this post as solved.

Offline

Board footer

Powered by FluxBB