You are not logged in.

#1 2022-11-18 15:32:58

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 18,899

Pipewire issues with media playback controls

I tried pipewire and was relatively pleased with it, but I ran into one showstopper.

The configuration is  listening to music over Bluetooth (either headset in H2DP mode or with Bluetooth speaker) using mpd on Plasma with Cantata as the front end.

All is well until I attempt to use the next track or previous track functions.  When I do, the audio dies and goes mute.  Bluetooth controls indicate everything is still connected, the connected devices give no indication of signal loss.  The player shows the playlist location changed as expected, playback clocks and progress bars indicate audio is playing.  Just no sound.  Pavucontrol shows the audio paths are all set, but the level meters show no activity.

To reestablish audio, one has to drop the Bluetooth link and then start it again.   Happens every time and is independent of using the controls in Cantatampc, the Plasma tray, or KDE connect from my phone.

Went back to Pulseaudio, and problem does not persist.   Ideas?

Edit:  In playing with this, it is looking like it might be Cantata.  KDE connect and the tray controls all seem to direct Cantata. mpc actually does not cause the issue when using the prev and next subcommands.

Last edited by ewaller (2022-11-18 18:03:08)


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

Board footer

Powered by FluxBB