You are not logged in.

#1 2022-11-08 07:03:56

MsFrips
Member
Registered: 2022-11-08
Posts: 1

Unable to boot on installation medium with Hyper-V Gen2

Hello everyone !

I have been running into a problem while trying to install an Arch Hyper-V VM.

My VM config is as follow :
     Secure Boot Disabled
     12Go RAM
     8 virtual processor

While trying to boot on the latest Arch ISO version (archlinux-2022.11.01-x86_64.iso), it loops into a black screen (I tried waiting 15+ mins to no avail)

However, if the number of virtual processors is reduced to 1, we finally see some text, but it is a kernel panic backtrace.
We'll get a console eventually, but it's frozen and the install medium is not even mounted. (screenshot here)
I also tried turning the TPU on/off but this doesn't change anything.

Is anyone able to reproduce this issue, and is there a solution to this ?

Offline

#2 2022-11-08 09:06:34

d.ALT
Member
Registered: 2019-05-10
Posts: 383

Re: Unable to boot on installation medium with Hyper-V Gen2

Is this your problem?

For Generation 2 machines, booting from a physical CD/DVD drive is not supported.

(https://wiki.archlinux.org/title/Hyper- … e_creation)

Last edited by d.ALT (2022-11-08 09:06:45)


<49,17,III,I>    Fama di loro il mondo esser non lassa;
<50,17,III,I>    misericordia e giustizia li sdegna:
<51,17,III,I>    non ragioniam di lor, ma guarda e passa.

Offline

#3 2022-11-16 19:24:27

k247tEK
Member
Registered: 2022-06-25
Posts: 6
Website

Re: Unable to boot on installation medium with Hyper-V Gen2

hi MsFrips,

MsFrips wrote:
My VM config is as follow :
   Secure Boot Disabled
   12Go RAM
   8 virtual processor

I'm new to arch and have only been using it in Hyper-V VM since June 2022..

using.. old aging Host h/w

     Lenovo Ideapad G560-M274YGE
     Intel Core i5-450M (2.40GHz, 2 cores - 4 threads)
     8GB (DDR3 1066MHz)
     NVIDIA GeForce 310M

& Host s/w

     Windows 10 Pro 22H2 OS Build 19045.2251
     Windows Feature Experience Pack 120.2212.4180.0
     WSL2 / Hypervisor Platform & Hyper-V enabled

setting up Client.. disabled Secure Boot & disabled Dynamic Memory when Specifying RAM..
also.. setting up Host..  disabled Server NUMA Spanning..
& Configured the hypervisor scheduler type to Classic..

more info..
Arch Linux virtual machine on Windows10 Hyper-V with Enhanced Session Mode

used the guided installer, archinstall, X11, XFCE, pulseAudio with systemd-bootctl or GRUB boot loader..

hope it helps,
k,

Last edited by k247tEK (2022-11-18 18:53:36)


(tEK_Newbie)
we live & learn..]]]....

Offline

#4 2022-11-22 02:26:37

PaulSamways
Member
From: Canberra, Australia
Registered: 2011-10-04
Posts: 8

Re: Unable to boot on installation medium with Hyper-V Gen2

Hi MsFrips,

I've run into this problem as well and it looks to be an open issue: https://bugs.archlinux.org/task/75178

Disabling indirect branch tracking allows the machine to boot for me.

Offline

Board footer

Powered by FluxBB