You are not logged in.

#1 2022-12-01 00:13:29

lenhuppe
Member
From: New Hampshire USA
Registered: 2018-12-10
Posts: 239
Website

SOLVED Disabling GDM renders system unusable

I use Gnome and today I disabled GDM so that I could log in and do something from the console without any desktop running. The command was 'sudo systemctl disable gdm' as I have been doing for some time now. When I logged in it stated when my last login was and then it locked up. I never got any user prompt. Upon rebooting the kernel was unable to load. I am getting the following message:

dbus-daemon[17566]: Cannot initialize inotify: too many open files
dbus-daemon[17577]: Cannot initialize inotify: too many open files
dbus-daemon[17588]: Cannot initialize inotify: too many open files
...

I can reinstall and get running again but as soon as I run 'sudo systemctl disable gdm' the cycle repeats.

Last edited by lenhuppe (2022-12-02 03:15:40)


Whenever I try to eat healthy a chocolate bar looks at me and snickers

Offline

#2 2022-12-01 02:10:53

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 7,127

Re: SOLVED Disabling GDM renders system unusable

Why don't you either (1) boot to the multi-user.target or (2) switch to a tty and use

systemctl isolate multi-user.target

?

In any case, I don't know why you'd reinstall if you mean reinstall Arch. Just boot to multi-user.target or, failing that, rescue.target or, failing that boot into the live environment to fix your existing system.

Edit: Why do you think the kernel was unable to load? The errors you posted suggest nothing of the sort. I'm no expert on Linux, but you can't get errors from dbus-daemon and inotify if the kernel hasn't loaded.

Last edited by cfr (2022-12-01 02:15:15)


CLI Paste | How To Ask Questions

Arch Linux | x86_64 | GPT | EFI boot | refind | stub loader | systemd | LVM2 on LUKS
Lenovo x270 | Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz | Intel Wireless 8265/8275 | US keyboard w/ Euro | 512G NVMe INTEL SSDPEKKF512G7L

Offline

#3 2022-12-01 03:02:23

lenhuppe
Member
From: New Hampshire USA
Registered: 2018-12-10
Posts: 239
Website

Re: SOLVED Disabling GDM renders system unusable

cfr wrote:

Why don't you either (1) boot to the multi-user.target or (2) switch to a tty and use

systemctl isolate multi-user.target

?

On the first reboot I get a login prompt but I never get to a command line. The system locks up.

If I reboot from there the kernel does not load. Instead I get the error message in my original post.


Whenever I try to eat healthy a chocolate bar looks at me and snickers

Offline

#4 2022-12-01 20:20:20

lenhuppe
Member
From: New Hampshire USA
Registered: 2018-12-10
Posts: 239
Website

Re: SOLVED Disabling GDM renders system unusable

SOLUTION:

The XDG_SESSION_TYPE variable was not being set correctly.

I was following instructions here : https://wiki.archlinux.org/title/GNOME#Wayland_sessions
I never copy and paste from the wiki and transcribing was where I made my mistake.

if [[ -z $DISPLAY && $(tty) == /dev/tty1 && $XDG_SESSION_TYPE == tty ]]; then
    export XDG_SESSION_TYPE=wayland exec dbus-run-session gnome-session
fi

Please read that section very carefully as setting XDG_SESSION_TYPE incorrectly can leave your system unusable !!!

Last edited by lenhuppe (2022-12-02 14:22:56)


Whenever I try to eat healthy a chocolate bar looks at me and snickers

Offline

Board footer

Powered by FluxBB