You are not logged in.

#1 2022-12-24 08:32:26

NickGeek
Member
Registered: 2022-12-24
Posts: 6

Linux 6.1.1 causes system hangs with AMDGPU

After updating to Linux 6.1 my system became incredibly slow and unresponsive if anything graphical was happening. Some other users on /r/archlinux assumed their system would never start (but it does if you wait a couple minutes). Starting DM took a while, and the system was largely unusable. I switched to a tty and saw a kernel task from amdgpu eating up the whole CPU: https://i.imgur.com/0S9FeEA.jpg. I also intermittently got kernel panics from AMDGPU.

I downgraded to Linux 6.0.12 which fixed the issue.

CPU: Intel Core i7 8700k
GPU: AMD Radeon 5700 XT
DM: LightDM (X11)
WM: i3

The slowness occurs as soon as LightDM tries to start (alongside X)

Last edited by NickGeek (2022-12-24 09:01:17)

Offline

#2 2022-12-24 12:44:18

sandstorm
Member
From: Zurich [CH] & Mannheim [DE]
Registered: 2005-08-13
Posts: 166

Re: Linux 6.1.1 causes system hangs with AMDGPU

I can confirm the issue. Downgrading to a previous kernel resolves the issue.

CPU: AMD Ryzen™ 7 4800U with Radeon™ Graphics × 16
GPU: AMD Radeon
DM: GDM
WM: Gnome

Offline

#3 2022-12-26 14:42:57

bitterhalt
Member
Registered: 2022-06-19
Posts: 19

Re: Linux 6.1.1 causes system hangs with AMDGPU

Yeah I've had many freezes after 6.1.1. Usually happens on desktop while browsing web. In this case process was Picom but sometimes it happens even with Picom disabled.

amdgpu 0000:28:00.0: amdgpu: [gfxhub] page fault (src_id:0 ring:24 vmid:5 pasid:32780, for process picom pid 72562 thread picom:cs0 pid 72563)
amdgpu 0000:28:00.0: amdgpu:   in page starting at address 0x0000800118bdf000 from client 0x1b (UTCL2)
amdgpu 0000:28:00.0: amdgpu: GCVM_L2_PROTECTION_FAULT_STATUS:0x00501031
amdgpu 0000:28:00.0: amdgpu:          Faulty UTCL2 client ID: TCP (0x8)
amdgpu 0000:28:00.0: amdgpu:          MORE_FAULTS: 0x1
amdgpu 0000:28:00.0: amdgpu:          WALKER_ERROR: 0x0
amdgpu 0000:28:00.0: amdgpu:          PERMISSION_FAULTS: 0x3
amdgpu 0000:28:00.0: amdgpu:          MAPPING_ERROR: 0x0
amdgpu 0000:28:00.0: amdgpu:          RW: 0x0
amdgpu 0000:28:00.0: amdgpu: [gfxhub] page fault (src_id:0 ring:24 vmid:5 pasid:32780, for process picom pid 72562 thread picom:cs0 pid 72563)
amdgpu 0000:28:00.0: amdgpu:   in page starting at address 0x000080011a88e000 from client 0x1b (UTCL2)
amdgpu 0000:28:00.0: amdgpu: GCVM_L2_PROTECTION_FAULT_STATUS:0x00000000
amdgpu 0000:28:00.0: amdgpu:          Faulty UTCL2 client ID: CB/DB (0x0)
amdgpu 0000:28:00.0: amdgpu:          MORE_FAULTS: 0x0
amdgpu 0000:28:00.0: amdgpu:          WALKER_ERROR: 0x0
amdgpu 0000:28:00.0: amdgpu:          PERMISSION_FAULTS: 0x0
amdgpu 0000:28:00.0: amdgpu:          MAPPING_ERROR: 0x0
amdgpu 0000:28:00.0: amdgpu:          RW: 0x0
amdgpu 0000:28:00.0: amdgpu: [gfxhub] page fault (src_id:0 ring:24 vmid:5 pasid:32780, for process picom pid 72562 thread picom:cs0 pid 72563)
amdgpu 0000:28:00.0: amdgpu:   in page starting at address 0x0000800118a9e000 from client 0x1b (UTCL2)
amdgpu 0000:28:00.0: amdgpu: GCVM_L2_PROTECTION_FAULT_STATUS:0x00000000
amdgpu 0000:28:00.0: amdgpu:          Faulty UTCL2 client ID: CB/DB (0x0)
amdgpu 0000:28:00.0: amdgpu:          MORE_FAULTS: 0x0
amdgpu 0000:28:00.0: amdgpu:          WALKER_ERROR: 0x0
amdgpu 0000:28:00.0: amdgpu:          PERMISSION_FAULTS: 0x0
amdgpu 0000:28:00.0: amdgpu:          MAPPING_ERROR: 0x0
amdgpu 0000:28:00.0: amdgpu:          RW: 0x0
amdgpu 0000:28:00.0: amdgpu: [gfxhub] page fault (src_id:0 ring:24 vmid:5 pasid:32780, for process picom pid 72562 thread picom:cs0 pid 72563)
amdgpu 0000:28:00.0: amdgpu:   in page starting at address 0x0000800117f79000 from client 0x1b (UTCL2)
amdgpu 0000:28:00.0: amdgpu: GCVM_L2_PROTECTION_FAULT_STATUS:0x00000000
amdgpu 0000:28:00.0: amdgpu:          Faulty UTCL2 client ID: CB/DB (0x0)
amdgpu 0000:28:00.0: amdgpu:          MORE_FAULTS: 0x0
amdgpu 0000:28:00.0: amdgpu:          WALKER_ERROR: 0x0
amdgpu 0000:28:00.0: amdgpu:          PERMISSION_FAULTS: 0x0
amdgpu 0000:28:00.0: amdgpu:          MAPPING_ERROR: 0x0
amdgpu 0000:28:00.0: amdgpu:          RW: 0x0
[drm:amdgpu_job_timedout [amdgpu]] *ERROR* ring gfx_0.0.0 timeout, but soft recovered


edit: Maybe this is different problem since I do not have any slowness, only those soft resets...

Last edited by bitterhalt (2022-12-26 14:53:30)

Offline

#4 2022-12-26 14:44:51

Head_on_a_Stick
Member
From: London
Registered: 2014-02-20
Posts: 6,992
Website

Re: Linux 6.1.1 causes system hangs with AMDGPU

+1 posts don't really help anybody.

Has a bug report on this been filed yet?

I'm running amdgpu with a Cezanne iGPU, no problems here with kernel 6.1.1.

Offline

#5 2022-12-26 14:50:45

bitterhalt
Member
Registered: 2022-06-19
Posts: 19

Re: Linux 6.1.1 causes system hangs with AMDGPU

Has anyone else encountered soft resets like in my post above or is it just general slowness?

Last edited by bitterhalt (2022-12-26 14:52:19)

Offline

#6 2022-12-27 04:14:16

NickGeek
Member
Registered: 2022-12-24
Posts: 6

Re: Linux 6.1.1 causes system hangs with AMDGPU

bitterhalt wrote:

Has anyone else encountered soft resets like in my post above or is it just general slowness?

Only when I did a restart after downgrading my kernel, it'd kernel paic from amdgpu everytime. The general slowness might be a bit of an understatement on my PC, mouse movements literally take minutes in i3wm on 6.1.1.
I haven't filed a bug report yet, I was hoping posting here would raise attention to the issue and give a more accurate root-cause to include in a report.

Offline

#7 2023-01-14 05:53:45

NickGeek
Member
Registered: 2022-12-24
Posts: 6

Re: Linux 6.1.1 causes system hangs with AMDGPU

After updating to Linux 6.1.4 I found that the problem has gotten even worse, with it taking about a minute to show the decryption prompt (from the encrypt kernel hook). It appears to be when the kernel hands over rendering from the nomodeset view to the amdgpu view when the issue starts.

Offline

#8 2023-02-13 10:15:12

NickGeek
Member
Registered: 2022-12-24
Posts: 6

Re: Linux 6.1.1 causes system hangs with AMDGPU

Just updating to say that I installed Linux 6.1.11 and the issue appears to have gone away.

Offline

#9 2023-04-08 15:50:39

hendry
Member
From: Singapore
Registered: 2009-09-08
Posts: 156
Website

Re: Linux 6.1.1 causes system hangs with AMDGPU

Just hit this issue on 6.2.9 on my T14 Gen 3

Offline

Board footer

Powered by FluxBB