You are not logged in.

#1 2023-01-07 18:54:47

Registered: 2022-12-19
Posts: 71

[SOLVED] Not being able to change renderer on steam games

Hello, the past week I used to play Dota 2 on my laptop with Arch. My laptop has both an Intel integrated card and a Nvidia card, I used Nvidia Prime to manage their use. I used to run Dota 2 with Vulkan and get about 100fps. Now I'm using a clean installation of Arch and after installing the packages nvidia, nvidia-utils, nvidia-settigns and nvidia-prime, I installed Steam just like is indicated here. After loggin in, I installed Dota 2 and after launching it, it launched in windowed mode with a resolution of 1280x720 and It was using also OpenGL as renderer and not Vulkan. I changed all those settings in the in-game options; however, after I lrelaunched the game, none of my changes were saved. I tried adding -vulkan -fullscreen  in the launch options, but when I launched the game, only the fullscreen parameter seemed to work. The game was still saying that the renderer is OpenGL, which gives me about 15fps. I don't know why it is not changing the renderer. I'll be glad to read your answers.

How the game launches with just the -vulkan parameter

Edit: I managed to solve it by reinstalling nvidia packages. It turned out Vulkan wasn't installed

Last edited by LeonN (2023-01-08 01:32:07)


Board footer

Powered by FluxBB