You are not logged in.

#1 2023-01-08 14:37:04

marcoz
Member
Registered: 2021-07-05
Posts: 3

[SOLVED] Microphone not working on Dell Latitude E5430

Hello everybody :-). I'm asking for help for my internal mic.
My internal mic not working since I installed Arch. I don't use pulseaudio but if it helps I might.

user@artx-> lspci  | grep -i audio
00:1b.0 Audio device: Intel Corporation 7 Series/C216 Chipset Family High Definition Audio Controller (rev 04)

Alsamixer input channels are unmuted but strangely sometimes they change on it's own.

# Here's output of udevadm 
user@artx-> udevadm info -a -n $(readlink -f /dev/snd/by-path/pci-0000\:00\:1b.0)
  looking at device '/devices/pci0000:00/0000:00:1b.0/sound/card0/controlC0':
    KERNEL=="controlC0"
    SUBSYSTEM=="sound"
    DRIVER==""
    ATTR{power/control}=="auto"
    ATTR{power/runtime_active_time}=="0"
    ATTR{power/runtime_status}=="unsupported"
    ATTR{power/runtime_suspended_time}=="0"

  looking at parent device '/devices/pci0000:00/0000:00:1b.0/sound/card0':
    KERNELS=="card0"
    SUBSYSTEMS=="sound"
    DRIVERS==""
    ATTRS{id}=="PCH"
    ATTRS{number}=="0"
    ATTRS{power/control}=="auto"
    ATTRS{power/runtime_active_time}=="0"
    ATTRS{power/runtime_status}=="unsupported"
    ATTRS{power/runtime_suspended_time}=="0"

  looking at parent device '/devices/pci0000:00/0000:00:1b.0':
    KERNELS=="0000:00:1b.0"
    SUBSYSTEMS=="pci"
    DRIVERS=="snd_hda_intel"
    ATTRS{ari_enabled}=="0"
    ATTRS{broken_parity_status}=="0"
    ATTRS{class}=="0x040300"
    ATTRS{consistent_dma_mask_bits}=="64"
    ATTRS{current_link_speed}=="Unknown"
    ATTRS{current_link_width}=="0"
    ATTRS{d3cold_allowed}=="1"
    ATTRS{device}=="0x1e20"
    ATTRS{dma_mask_bits}=="64"
    ATTRS{driver_override}=="(null)"

    ATTRS{enable}=="1"
    ATTRS{irq}=="30"
    ATTRS{local_cpulist}=="0-3"
    ATTRS{local_cpus}=="f"
    ATTRS{max_link_speed}=="Unknown"
    ATTRS{max_link_width}=="255"
    ATTRS{msi_bus}=="1"
    ATTRS{msi_irqs/30}=="msi"
    ATTRS{numa_node}=="-1"

Here's the commands I used to test the audio without getting any sound :

arecord --duration=5 --format=dat test-mic.wav
aplay test-mic.wav

In snd-hda-intel I have this option because I think the microphone worked
one time with this option

user@artx-> cat /etc/modprobe.d/snd-hda-intel.conf
options snd-hda-intel enable_msi=1

# this is my alsa configuration. It's a particular configuration
# with pre-amp created from this topic :
# https://bbs.archlinux.org/viewtopic.php?id=252542

cat /etc/asound.conf 
pcm.!default {
            type hw
            card 0
}
ctl.!default {
            type hw
            card 0
}
pcm.!default {
           type plug
            slave.pcm "duplex"
}

   pcm.duplex {
       type asym
       playback.pcm "softvol"
       capture.pcm "dsnoop"
   }

pcm.softvol {
            type softvol
            slave {
                    pcm "dmix"
            }
            control {
                    name "Pre-Amp"
                    card 0
            }
            min_dB -5.0
            max_dB 20.0
            resolution 6
}

Thanks!!

Last edited by marcoz (2023-01-09 21:10:32)

Offline

#2 2023-01-08 16:34:12

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 18,288

Re: [SOLVED] Microphone not working on Dell Latitude E5430

Please wrap outputs in code tags.

Post

arecord -lL
sudo dmesg | grep -iE 'snd|sof'

Offline

#3 2023-01-09 17:29:13

marcoz
Member
Registered: 2021-07-05
Posts: 3

Re: [SOLVED] Microphone not working on Dell Latitude E5430

It seems I solved it. I enabled pulseaudio by running pulseaudio -D in my .xinitrc and I
cleaned my config files /etc/modprobe.d/snd-hda-intel.conf and /etc/asound.conf.
Since I really don't know much about alsa I couldn't have investigated much further anyway.
Do I mark it solved ? How ?
Also I wonder if I should have posted under Kernel & Hardware.

Last edited by marcoz (2023-01-09 17:32:58)

Offline

#4 2023-01-09 20:02:02

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 18,288

Re: [SOLVED] Microphone not working on Dell Latitude E5430

You can mark it solved by editing the title in your first post. FWIW you don't need either of these ALSA config files now and can substitute them for the pulseaudio-alsa package.

Offline

Board footer

Powered by FluxBB