You are not logged in.

#1 2023-01-10 15:40:39

jr_west
Member
Registered: 2022-09-13
Posts: 6

OBS-Studio, dependency not met

OBS worked fine until recently.
Now I get this error when running it.

obs: error while loading shared libraries: libkvazaar.so.6: cannot open shared object file: No such file or directory

removing/re-installing obs has no effect.

I have that lib installed, but it's a newer version

❯ ls -altr /usr/lib/libkvaz*
-rwxr-xr-x 1 root root 554800 Jan  5 10:27 /usr/lib/libkvazaar.so.7.2.0
lrwxrwxrwx 1 root root     19 Jan  5 10:27 /usr/lib/libkvazaar.so.7 -> libkvazaar.so.7.2.0
lrwxrwxrwx 1 root root     19 Jan  5 10:27 /usr/lib/libkvazaar.so -> libkvazaar.so.7.2.0

and it does look like obs is looking for that specific version.

❯ ldd /usr/bin/obs
	linux-vdso.so.1 (0x00007ffce5690000)
	libcurl.so.4 => /usr/lib/libcurl.so.4 (0x00007f4f37407000)
....
       libkvazaar.so.6 => not found

I assume something is messed up w/ my pacmad DB? but I have no idea how to fix it. pacman thinks that version is already installed somehow? or else why would it install obs w/o adding it?

Any idea how to address?

Thanks

Offline

#2 2023-01-10 15:53:21

Scimmia
Fellow
Registered: 2012-09-01
Posts: 10,046

Re: OBS-Studio, dependency not met

This is likely a partial update of some sort. First thing, make sure you're fully updated against packages in the repos. If that doesn't do it, it's likely an AUR package that's the problem, use lddtree from the pax-utils package to see where the actual problem is.

Offline

#3 2023-01-10 17:47:37

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 10,652

Re: OBS-Studio, dependency not met

OBS-studio was updated an hour ago .

run pacman -Syu .


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.


(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Offline

#4 2023-01-10 18:39:11

loqs
Member
Registered: 2014-03-06
Posts: 15,645

Re: OBS-Studio, dependency not met

Lone_Wolf wrote:

OBS-studio was updated an hour ago .

Nothing in the repos links to kvazaar likely a custom ffpeg as Scimmia said the same as in https://bugs.archlinux.org/task/77024?

Offline

#5 2023-01-10 18:52:35

jr_west
Member
Registered: 2022-09-13
Posts: 6

Re: OBS-Studio, dependency not met

loqs wrote:

Nothing in the repos links to kvazaar likely a custom ffpeg as Scimmia said the same as in https://bugs.archlinux.org/task/77024?

Yep. This was it. I had

ffmpeg-amd-full

installed. Just replaced it w/ the stock. Everything works fine now.

Thanks!

Offline

Board footer

Powered by FluxBB