You are not logged in.

#1 2023-01-10 20:57:15

leou
Member
From: Westminster, CO
Registered: 2020-08-06
Posts: 7

Error while installing vim-pandoc-syntax-git

I was unable to install vim-pandoc-syntax-git with yay. Below is the console output I received. The error says it failed to connect to github.com but I can ping github.com successfully.  I don't know what I can do to resolve this issue, all the mirrors are up to date.
Any suggestions or help is appreciated.
Thanks, Leo

$ yay -S vim-pandoc-syntax-git
:: Checking for conflicts...
:: Checking for inner conflicts...
[Aur:1]  vim-pandoc-syntax-git-1434938917-1

  1 vim-pandoc-syntax-git            (Build Files Exist)
==> Packages to cleanBuild?
==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
==> A
:: Deleting (1/1): /home/leou/.cache/yay/vim-pandoc-syntax-git
:: (1/1) Downloaded PKGBUILD: vim-pandoc-syntax-git
  1 vim-pandoc-syntax-git            (Build Files Exist)
==> Diffs to show?
==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
==> 
:: (1/1) Parsing SRCINFO: vim-pandoc-syntax-git
==> Making package: vim-pandoc-syntax-git 1434938917-1 (Tue 10 Jan 2023 01:22:48 PM MST)
==> Retrieving sources...
  -> Cloning vim-pandoc-syntax git repo...
Cloning into bare repository '/home/leou/.cache/yay/vim-pandoc-syntax-git/vim-pandoc-syntax'...
fatal: unable to connect to github.com:
github.com[0: 140.82.113.4]: errno=Connection timed out

==> ERROR: Failure while downloading vim-pandoc-syntax git repo
    Aborting...
 -> error downloading sources: vim-pandoc-syntax-git 
	 context: exit status 1 
	 

==> Making package: vim-pandoc-syntax-git 1434938917-1 (Tue 10 Jan 2023 01:24:59 PM MST)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Cloning vim-pandoc-syntax git repo...
Cloning into bare repository '/home/leou/.cache/yay/vim-pandoc-syntax-git/vim-pandoc-syntax'...
fatal: unable to connect to github.com:
github.com[0: 140.82.114.3]: errno=Connection timed out

==> ERROR: Failure while downloading vim-pandoc-syntax git repo
    Aborting...
 -> error making: vim-pandoc-syntax-git

Offline

#2 2023-01-10 21:08:20

d.ALT
Member
Registered: 2019-05-10
Posts: 508

Re: Error while installing vim-pandoc-syntax-git

Cloning into bare repository '/home/leou/.cache/yay/vim-pandoc-syntax-git/vim-pandoc-syntax'...
fatal: unable to connect to github.com:
github.com[0: 140.82.114.3]: errno=Connection timed out

I'm successfully cloning from GitHub, though:

$ LC_ALL=C git clone https://github.com/vim-pandoc/vim-pandoc-syntax.git
Cloning into 'vim-pandoc-syntax'...
remote: Enumerating objects: 1664, done.
remote: Counting objects: 100% (58/58), done.
remote: Compressing objects: 100% (41/41), done.
remote: Total 1664 (delta 24), reused 34 (delta 12), pack-reused 1606
Receiving objects: 100% (1664/1664), 431.74 KiB | 1.28 MiB/s, done.
Resolving deltas: 100% (755/755), done.

<49,17,III,I>    Fama di loro il mondo esser non lassa;
<50,17,III,I>    misericordia e giustizia li sdegna:
<51,17,III,I>    non ragioniam di lor, ma guarda e passa.

Offline

#3 2023-01-10 21:20:33

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 27,786
Website

Re: Error while installing vim-pandoc-syntax-git

Replace the "git://" url in the source array with "git+https://".


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#4 2023-01-10 21:20:55

leou
Member
From: Westminster, CO
Registered: 2020-08-06
Posts: 7

Re: Error while installing vim-pandoc-syntax-git

I can also manually clone it from GitHub but I don't know how that helps me getting it installed.

Offline

#5 2023-01-10 21:24:46

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 27,786
Website

Re: Error while installing vim-pandoc-syntax-git

Github no longer responds to git:// urls.  Fix the PKGBUILD as noted in my previous post.  You may also want to comment on the package page or otherwise let the maintainer know so they can fix the source url.


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#6 2023-01-10 21:44:44

leou
Member
From: Westminster, CO
Registered: 2020-08-06
Posts: 7

Re: Error while installing vim-pandoc-syntax-git

Thanks, I fixed ~/.cache/yay/vim-pandoc-syntax-git/PKGBUILD as you suggested and reran yay, this time selecting None for cleanBuild but yay retrieves & clones package again from GitHub and wipes the fix. How can I tell yay not to clone it and just proceed?

Offline

#7 2023-01-10 22:15:04

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 27,786
Website

Re: Error while installing vim-pandoc-syntax-git

I have no idea.  You really shouldn't be using yay.  Just use makepkg.


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

Board footer

Powered by FluxBB