You are not logged in.

#1 2023-01-14 02:46:03

tetreur
Member
Registered: 2023-01-14
Posts: 10

[SOLVED] mount : /new_root: unknown filesystem type 'ext4'

Hello,
I'm having trouble installing ArchLinux since 2 days (my first install, so i'm bad at this)
Everything is fine and boot correctly until the nvidia + wayland part
I follow this guide : https://wiki.archlinux.org/title/NVIDIA … de_setting

so i first added a kernel parameter in /etc/etc/default/grub

GRUB_CMDLINE_LINUX="nvidia-drm.modeset=1"

And it's the only line in this file
(i use GRUB as you can see)

Then regenerated /boot/grub/grub.cfg:

grub-mkconfig -o /boot/grub/grub.cfg

i also created a new file in /etc/modprobe.d/nvidia.conf
which contains ..

options nvidia-drm modeset=1

I have Nvidia GPU and i generated initframes with mkinitconfig :

# mkinitcpio --config /etc/mkinitcpio.conf --generate /boot/initramfs-custom.img

I only added modules in my /etc/mkinitcpio.conf, changed nothing else
which are -> nvidia nvidia_modeset nvidia_uvm and nvidia_drm
content of the file :

MODULES=(nvidia nvidia_modeset nvidia_uvm nvidia_drm)
BINARIES=()
FILES=()
HOOKS=(base udev autodetect keyboard keymap modconf block filesystems fsck)

i installed the corresponding modules with pacman
i installed linux & linux-headers

i did a

sudo ]pacman -Syu

but, after a reboot, here i am at 4am with this doomed error message  : 'mount : /new_root: unknown filesystem type 'ext4''

Fortunately i can still boot with the live media and mount my partitions then

arch-chroot /mnt

into them
i checked other solved thread with similar issue and here is the result of ..

lsmod | grep ext

(in the live media)
>> ext 4 1019904 2

(in arch-root /mnt)
>> nothing ^^

lsblk -f

(in the liveMedia)
>> FileSystem for my UEFI partition was vfat32
>> FileSystem for my root/ and home/ partitions was ext4
(in arch-chroot /mnt)
>> No FileSytem specified for all partitions (don't know if it's normal)

Ask me anything, i want this to work ^^

Last edited by tetreur (2023-01-15 10:31:24)

Offline

#2 2023-01-14 06:18:01

Scimmia
Fellow
Registered: 2012-09-01
Posts: 10,892

Re: [SOLVED] mount : /new_root: unknown filesystem type 'ext4'

The error usually means that the initramfs doesn't match the kernel. Why did you use /boot/initramfs-custom.img? What is grub actually loading?

Offline

#3 2023-01-14 11:42:15

tetreur
Member
Registered: 2023-01-14
Posts: 10

Re: [SOLVED] mount : /new_root: unknown filesystem type 'ext4'

Sorry, i copied a line from this external guide for using Hyprland https://wiki.hyprland.org/Nvidia/
I think my line was ..

# mkinitcpio --config /etc/mkinitcpio.conf --generate /boot/initframes-linux.img

I'm not sure of what i did ^^

Offline

#4 2023-01-14 12:09:24

seth
Member
Registered: 2012-09-03
Posts: 45,213

Re: [SOLVED] mount : /new_root: unknown filesystem type 'ext4'

https://wiki.archlinux.org/title/Mkinit … generation

lsblk -f

Don't paraphrase, post the actual output.

arch-chroot /mnt

Did you forget to mount the /boot partition?

From the emergency shell

uname -a
cat /proc/cmdline

and also post your grub.cfg

Offline

#5 2023-01-14 12:11:26

tetreur
Member
Registered: 2023-01-14
Posts: 10

Re: [SOLVED] mount : /new_root: unknown filesystem type 'ext4'

In the GRUB i pressed "e" on my archlinux installation and here is the output :

setparams 'Arch Linux'

  load_video
  set gfxpayload=keep
  insmod gzio
  insmode part_gpt
  insmod fat
  search --no-floppy --fs-uuid --set=root FCF0-0FDA
  echo 'Loading Linux linux-lts ...'
  linux /vmlinuz-linux-lts root=UUID=5f7cfd6b-d51f-4ecb-b88f-50c2c538e7ac rw rootfstype=ext4 nvidia-drm.modeset=1 loglevel=3 quiet
  echo 'Loading initial ramdisk ...'
  initrd /amd-ucode.img /initframs-linux-lts.img

Offline

#6 2023-01-14 12:13:31

seth
Member
Registered: 2012-09-03
Posts: 45,213

Re: [SOLVED] mount : /new_root: unknown filesystem type 'ext4'

So you do have a boot partition and "initframes-linux.img" is utterly irrelevant.

Offline

#7 2023-01-14 12:43:35

tetreur
Member
Registered: 2023-01-14
Posts: 10

Re: [SOLVED] mount : /new_root: unknown filesystem type 'ext4'

seth wrote:

lsblk -f

Don't paraphrase, post the actual output.

I would like too but i'm on a different computer, and i can't copy clipboard here
i will try to reproduce the output of this command as best as I can here ..

in livemedia before mounting and arch-chrooting :

NAME                FSTYPE  FSVER  LABEL  UUID                                                                    FSAVAIL FSUSE% MOUNTPOINTS
nvme0n1
├nvme0n1p1  vfat        FAT32                FCF-0FDA
├nvme0n1p2  ext4       1.0                     5f7cfd6b-d51f-4ecb-b88f-50c2c538e7ac
└nvme0n1p3  ext4       1.0                     a811edc1-5106-4b93-9ec6-c9369dba40ec

In livemedia after mounting and arch-chrooting :

NAME                FSTYPE  FSVER  LABEL  UUID  FSAVAIL  FSUSE%  MOUNTPOINTS
nvme0n1
├nvme0n1p1  
├nvme0n1p2                                                       12G         32%         /
└nvme0n1p3                                                       1.7T           0%         /boot
seth wrote:

arch-chroot /mnt

Did you forget to mount the /boot partition?

i dont think so ? maybe ? here is what i did before arch-chroot :

mount /dev/nvme0n1p2 /mnt
mount /dev/nvme0n1p3 /mnt/boot

then

arch-chroot /mnt
seth wrote:

From the emergency shell

uname -a
cat /proc/cmdline

Here is the trick : my keyboard don't work in emergency shell ^^

but if you want, here is the output in livemedia arch-chroot

uname -a

Linux archiso 6.1.1-arch-1 #1 SMP PREEMPT_DYNAMIC Wed, 21 Dec 2022 22:27:55 +0000 x86_64 GNU/Linux
cat /proc/cmdline

BOOT_IMAGE=/arch/boot/x86_64/vmlinuz-linux archisobasedir=arch archisolabel=ARCH_202301 initrd=/arch/boot/intel-ucode.img,/arch/boot/amd-ucode.img,/arch/boot/x86_64/initramfs-linux.img
seth wrote:

and also post your grub.cfg

I believe this file is in /boot/grub/grub.conf but i don't seem to have a grub folder to start with (in livemedia arch-chrooted at least)
I hope my previous post will be useful to you, if not, can you please point me to the right directory ?

Last edited by tetreur (2023-01-14 12:45:34)

Offline

#8 2023-01-14 12:46:50

seth
Member
Registered: 2012-09-03
Posts: 45,213

Re: [SOLVED] mount : /new_root: unknown filesystem type 'ext4'

but if you want, here is the output in livemedia arch-chroot

That's useless.

can you please point me to the right directory ?

"Direction" - and the 1.7TB ext4 partition is very most likely NOT your boot partition…

Offline

#9 2023-01-14 12:57:50

tetreur
Member
Registered: 2023-01-14
Posts: 10

Re: [SOLVED] mount : /new_root: unknown filesystem type 'ext4'

Exact, it's my "usr" partition, so how do i tell my grub to boot on the correct boot partition (with the vfat32 filesystem) since my OS is completly broken ?

Offline

#10 2023-01-14 12:59:57

seth
Member
Registered: 2012-09-03
Posts: 45,213

Re: [SOLVED] mount : /new_root: unknown filesystem type 'ext4'

First of all, by not mounting it at /boot
mount the *proper* partitions, arch-chroot, reinstall the kernel(s) and grub.

Edit:

I'm having trouble installing ArchLinux since 2 days (my first install, so i'm bad at this)

Sorry, i copied a line from this external guide for using Hyprland https://wiki.hyprland.org/Nvidia/

D'oooh.
https://wiki.archlinux.org/title/Installation_guide
Don't follow silly tutorials across the internet and/or youtube.

Last edited by seth (2023-01-14 13:01:53)

Offline

#11 2023-01-14 13:29:11

tetreur
Member
Registered: 2023-01-14
Posts: 10

Re: [SOLVED] mount : /new_root: unknown filesystem type 'ext4'

First of all, by not mounting it at /boot
mount the *proper* partitions, arch-chroot, reinstall the kernel(s) and grub.

Ok i feel extremly dumb right now ...

So i mounted my root partition in mnt/
mounted my CORRECT boot partition in mnt/boot
And my user partition in  mnt/home (not sure about this one)

reinstalled linux kernel, llinux-headers and grub with

sudo pacman -S linux linux-headers grub

no errors
reboot

But the ' unknow filesystem type 'ext4'. ' error is still here

D'oooh.
https://wiki.archlinux.org/title/Installation_guide
Don't follow silly tutorials across the internet and/or youtube.

Ok i will try to avoid that in the future, i got a little carried on haha

Sooo maybe i fucked up too much and now i need to do a fresh reinstall of arch following the official guide ?

Last edited by tetreur (2023-01-14 13:29:35)

Offline

#12 2023-01-14 13:34:45

seth
Member
Registered: 2012-09-03
Posts: 45,213

Re: [SOLVED] mount : /new_root: unknown filesystem type 'ext4'

But the ' unknow filesystem type 'ext4'. ' error is still here

"Where"?
What is the actual complete boot messages?

sudo pacman -S linux linux-headers grub

By "install grub" I meant "grub-install" and "grub-mkconfig".

Also remove "rootfstype=ext4" from the commandline.

Offline

#13 2023-01-14 14:10:50

tetreur
Member
Registered: 2023-01-14
Posts: 10

Re: [SOLVED] mount : /new_root: unknown filesystem type 'ext4'

seth wrote:

But the ' unknow filesystem type 'ext4'. ' error is still here

"Where"?
What is the actual complete boot messages?

Warning: /lib/modules/5.15.87-1-lts/modules.devname not found - ignoring
Starting systemd-udevd version 252.4-2-arch
/dev/nvme0n1p2: clean, 127470/1277952 files, 1712218/5111552 blocks
mount: /new_root: unknown filesystem type 'ext4'.
       dmesg(1) may have more information after failed mount system call.
You are being dropped into an emergency shell.
sh: can't access tty: job control turned off

sudo pacman -S linux linux-headers grub

By "install grub" I meant "grub-install" and "grub-mkconfig".

Ok i did a grub-install but grub didn't knew where my EFI directory was
>> "grub-install: error: cannot find EFI directory."
so i had to do this :

grub-install --efi-directory=/boot

output :

Installing for x86_64-efi platform
Installation finished. No error reported.

then grub-mkconfig -o /boot/grub/grub.cfg

I rebooted but it's still broken with the same ext4 unknown filesystem error

Also remove "rootfstype=ext4" from the commandline.
cat /proc/cmdline
BOOT_IMAGE=/arch/boot/x86_64/vmlinuz-linux archisobasedir=arch archisolabel=ARCH_202301

didn't see the rootfstype=ext4 that you mentionned so i'm not sure if we talk about the same thing
Edit : oooh i see what you mean, at the grub step by pressing 'e' i removed it then booted but nothing changed hmm

Last edited by tetreur (2023-01-14 14:44:56)

Offline

#14 2023-01-14 14:44:44

seth
Member
Registered: 2012-09-03
Posts: 45,213

Re: [SOLVED] mount : /new_root: unknown filesystem type 'ext4'

BOOT_IMAGE=/arch/boot/x86_64/vmlinuz-linux archisobasedir=arch archisolabel=ARCH_202301

The commandline of the installation iso is completely pointless here, "rootfstype=ext4" is/was in your grub.cfg

Warning: /lib/modules/5.15.87-1-lts/modules.devname not found - ignoring

But you did

sudo pacman -S linux linux-headers grub

Should have been

sudo pacman -S linux-lts linux-lts-headers

Offline

#15 2023-01-14 15:01:01

tetreur
Member
Registered: 2023-01-14
Posts: 10

Re: [SOLVED] mount : /new_root: unknown filesystem type 'ext4'

Yeeees i did what you said and it kinda works now (the ext4 filesystem unknown disapeared)
But it seem to "stop" after booting and telling me

Starting systemd-udevd version 252.4-2-arch
/dev/nvme0n1p2: clean, 145679/1277952 files, 1762504/5111552 blocks

i can still switch to a new tty and enter command so i think i will repair my mess from here smile

Thank you so much seth !

Offline

Board footer

Powered by FluxBB