You are not logged in.

#1 2023-01-14 22:15:17

walteweiss
Member
Registered: 2019-09-07
Posts: 32

[Solved] Backlight doesn’t work and /sys/class/backlight is empty

My brightness control suddenly stopped working, when it did just a couple of days or week ago. I didn’t do much changes to my system, so I suspect there’s a recent kernel change, or anything else of a similar kind (e.g. a systemd update) that broke it. However I’ll try to journal that here.

My issue is basically the same as in the thread [SOLVED] /sys/class/backlight empty], but I have a laptop screen indeed, not an external display. And, again, everything worked just days ago.

What I’ve tried? Things written in that forum post: I tried all possible backlights kernel parameters:

`acpi_backlight=video` and `none` and `native` and `vendor`.

Note: there should be just one string of these 4 variants, not all at the same time. It was unclear to me from the ArchWiki’s interface, but Gentoo wiki helped me here.

I did `sudo mkinitcpio -p linux` as well.

My config is: MacBookPro 8,1 (Sandy Bridge) with Intel GPU (6th gen).

More details:

OS: Arch Linux x86_64 
Host: MacBookPro8,1 1.0 
Kernel: 6.1.5-arch2-1 
WM: sway 
Terminal: foot 
CPU: Intel i5-2415M (4) @ 2.900GHz 
GPU: Intel 2nd Generation Core Processor Family 
Memory: 1689MiB / 15913MiB 

Neofetch outputs my GPU as 2nd gen, but it’s clearly not correct, as Sandy Bridge GPU is 6th gen (2011) according to the Intel’s wiki and Wikipedia.

Last edited by walteweiss (2023-01-16 13:17:47)


Russia is committing genocide on Ukraine right now (2022—2023), please help Ukraine as much as you can. That’s the turning point of the democracy vs tyranny war, and if Ukraine loses, everyone in the democracy world will. You can donate to Ukraine here: savelife.in.ua/en/donate or help with spreading the information about the ongoing events.

Offline

#2 2023-01-14 23:32:18

schard
Forum Moderator
From: Hannover
Registered: 2016-05-06
Posts: 2,022
Website

Re: [Solved] Backlight doesn’t work and /sys/class/backlight is empty

If it worked until recently, try a kernel and / or a firmware download grade first to narrow down the perp.

Last edited by schard (2023-01-14 23:32:36)


macro_rules! yolo { { $($tokens:tt)* } => { unsafe { $($tokens)* } }; }

Offline

#3 2023-01-15 00:55:32

loqs
Member
Registered: 2014-03-06
Posts: 17,714

Re: [Solved] Backlight doesn’t work and /sys/class/backlight is empty

Offline

#4 2023-01-15 08:40:18

walteweiss
Member
Registered: 2019-09-07
Posts: 32

Re: [Solved] Backlight doesn’t work and /sys/class/backlight is empty

Thank you guys for your input, now I see that’s a bug and I‘m not alone in this.

I’ll try to downgrade my kernel and will report back. Since I use the laptop not too often, that may take some time to report back.


Russia is committing genocide on Ukraine right now (2022—2023), please help Ukraine as much as you can. That’s the turning point of the democracy vs tyranny war, and if Ukraine loses, everyone in the democracy world will. You can donate to Ukraine here: savelife.in.ua/en/donate or help with spreading the information about the ongoing events.

Offline

#5 2023-01-15 13:23:40

loqs
Member
Registered: 2014-03-06
Posts: 17,714

Re: [Solved] Backlight doesn’t work and /sys/class/backlight is empty

Please read through the bug report which was closed as not a bug and see how those affected resolved the issue without having to downgrade.

Offline

#6 2023-01-16 13:16:01

walteweiss
Member
Registered: 2019-09-07
Posts: 32

Re: [Solved] Backlight doesn’t work and /sys/class/backlight is empty

I found the issue, it’s not the kernel, it’s me not knowing how to add kernel parameters with systemd-boot.

When I tried, my systemd-boot config — /boot/loader/entries/arch.conf — was as follows:

title   Arch Linux
linux   /vmlinuz-linux
initrd  /intel-ucode.img
initrd  /initramfs-linux.img
options root="LABEL=arch_os" rw 
acpi_backlight=native

The mistake was with me adding options with single lines, while it needed to be added with spaces, not new lines. So the correct config is:

title   Arch Linux
linux   /vmlinuz-linux
initrd  /intel-ucode.img
initrd  /initramfs-linux.img
options root="LABEL=arch_os" rw acpi_backlight=native

----

I tried all three different options for : `video`, `vendor`, `native` once again, as when I wrote the post my attempts was incorrect and did nothing.

When set as `acpi_backlight=` as`video`, I had brightness, but my wifi stopped existing.

$ ls /sys/class/backlight/
acpi_video0

$ ls /sys/class/backlight/acpi_video0
actual_brightness  brightness  max_brightness  scale      type
bl_power           device      power           subsystem  uevent

$ iwctl station wlan0 show
Device wlan0 not found.
Device wlan0 not found.
No station on device: 'wlan0

- `vendor` did nothing for brightness, and I forgot to check Wi-Fi
- `native` helped: I have brightness back again, and Wi-Fi also works

----

I’m closing this thread with editing the title to [Solved].


Russia is committing genocide on Ukraine right now (2022—2023), please help Ukraine as much as you can. That’s the turning point of the democracy vs tyranny war, and if Ukraine loses, everyone in the democracy world will. You can donate to Ukraine here: savelife.in.ua/en/donate or help with spreading the information about the ongoing events.

Offline

Board footer

Powered by FluxBB