You are not logged in.

#1 2023-01-16 17:49:40

pmd
Member
From: Poland
Registered: 2008-08-11
Posts: 26

Dracut + systemd-boot - increase root mounting timeout

Hey!

I've just done a clean Arch installation - systemd-boot as a bootloader, dracut for image generation (UEFI). My root partition is encrypted and I've set up the dracut-sshd for remote root decryption. Everything works great, except for the fact that after 90s I'm dropped into emergency shell which effectively blocks the boot process. I mean, I can still SSH into initramfs and provide a decryption key but the emergency shell is still blocking.

How can I completely disable emergency shell and tell systemd-boot to wait indefinitely for root partition?

Thanks

Last edited by pmd (2023-01-16 17:53:55)

Offline

#2 2023-01-16 18:51:14

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 18,209

Re: Dracut + systemd-boot - increase root mounting timeout

Try adding rootwait to the kernel parameters.

Offline

#3 2023-01-16 19:51:45

pmd
Member
From: Poland
Registered: 2008-08-11
Posts: 26

Re: Dracut + systemd-boot - increase root mounting timeout

V1del wrote:

Try adding rootwait to the kernel parameters.

Thanks, but it doesn't work in my setup. Found this anwer while trying to figure out why, sounds exactly like my case - when emergency shell starts initramfs is already loaded from boot partition.

Offline

Board footer

Powered by FluxBB