You are not logged in.

#1 2023-01-26 17:42:42

Registered: 2013-12-28
Posts: 49

Compiling OpenWrt on Arch failing for a specific package (qca-ssdk)


I'm compiling OpenWrt Arch Linux for like five years with minor issues from time to time only (in all cases I was able to solve them in the past). But I'm hitting a wall since a few weeks now.

I try to compile IPQ807x target. This target is quite new in master but I was compiling it for ~1,5 years already out of tree). It requires the package qca-ssdk ( … a-ssdk.git). But since ~4 weeks I'm not able to compile it anymore. I've tried to track down this with the requirements for OpenWrt ( … uildsystem) and I've learned that we have a meta package within the AUR since a while. But no dice.

So I'm on a point where I can say:

- it may be an OpenWrt issue. But the package in question is compiling on an older Arch installation (~ 1,5 month lagging behind; preserving it atm).
- it may be an issue by the package itself. But it is from ~ Sept. 2022 (so nothing got updated within the timeframe).
- a tool got updated and is not working as before. But I didn't find anything which jumped on me. Most packages are either quite old (like asciidoc) or most recent (like gcc).
- beside the usual tools (perl, python, tr, awk, ar, sed, etc.) no tools used or missing as far I was able to look within pstree log (quite hard to read).

I was not able to find anything relevant within the make log (full log: … 2LKeAFYPcE )

Last lines are saying nothing (to me) beside that it is missleading (for me):

make[4]: *** No rule to make target '/home/user/openwrt-src-builds/openwrt/build_dir/target-aarch64_cortex-a53_musl/linux-ipq807x_generic/qca-ssdk-2022-09-12-628b22bc/build/linux/KSLIB/adpt.d', needed by 'adpt.o'.  Stop.
make[4]: Leaving directory '/home/user/openwrt-src-builds/openwrt/build_dir/target-aarch64_cortex-a53_musl/linux-ipq807x_generic/qca-ssdk-2022-09-12-628b22bc/src/adpt'
make[3]: *** [Makefile:27: kslib_o] Error 1
make[3]: Leaving directory '/home/user/openwrt-src-builds/openwrt/build_dir/target-aarch64_cortex-a53_musl/linux-ipq807x_generic/qca-ssdk-2022-09-12-628b22bc'
make[2]: *** [Makefile:85: /home/user/openwrt-src-builds/openwrt/build_dir/target-aarch64_cortex-a53_musl/linux-ipq807x_generic/qca-ssdk-2022-09-12-628b22bc/.built] Error 2
make[2]: Leaving directory '/home/user/openwrt-src-builds/openwrt/package/kernel/qca-ssdk'
time: package/kernel/qca-ssdk/compile#2.64#1.33#3.93
    ERROR: package/kernel/qca-ssdk failed to build.
make[1]: *** [package/Makefile:116: package/kernel/qca-ssdk/compile] Error 1
make[1]: Leaving directory '/home/user/openwrt-src-builds/openwrt'
make: *** [/home/user/openwrt-src-builds/openwrt/include/ package/kernel/qca-ssdk/compile] Error 2

I've asked about within the OpenWrt forum already. But there are not so many Arch Linux users. OpenWrt is done on Debian/Ubuntu by the vast majority.

In the past I had python issues quite often. But no luck this time. The transition period from 2.x to 3.x is gone. I've tried 3.6 and 3.9. Nothing changed.

Any hint is appricated. Even a hint where I could dig further.

Kind regards


Board footer

Powered by FluxBB